Bug 194268 - Kontact crashes at start (Kontact::Plugin::part, K*UniqueAppHandler::newInstance, Kontact::UniqueAppHandler::newInstance)
Summary: Kontact crashes at start (Kontact::Plugin::part, K*UniqueAppHandler::newInsta...
Status: RESOLVED FIXED
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash with 62 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 193213 194683 196149 198107 200800 200968 201541 201618 202260 203019 204000 204420 205023 205334 205711 206002 206429 206448 206675 206710 208177 208319 208626 208664 209791 212261 213629 214016 214098 214194 214315 214583 214609 214750 215169 215361 215466 215512 216728 217386 217773 218117 218747 219979 220020 220476 220587 221968 223045 223788 227577 228438 229766 230500 231080 232822 232851 233641 234172 234971 235195 235277 235496 235668 235761 235846 236698 237094 237352 237446 239984 240876 241142 241881 242078 242278 242751 243710 245005 245901 246414 246527 248611 249231 249430 252373 253472 254686 254895 255029 255030 255044 256534 256717 257170 260348 261042 262516 265347 267971 268954 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-27 07:02 UTC by Michał Gawroński
Modified: 2017-09-12 14:23 UTC (History)
98 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.88 KB, text/plain)
2010-09-04 12:14 UTC, Michael DING
Details
bt full from trunk (13.15 KB, application/octet-stream)
2010-09-26 05:53 UTC, Christophe Marin
Details
Valgrind output during crashed open-attempt (21.26 KB, text/plain)
2010-09-27 19:24 UTC, Anne Wilson
Details
New crash information added by DrKonqi (3.66 KB, text/plain)
2010-12-03 12:43 UTC, underline
Details
New crash information added by DrKonqi (5.90 KB, text/plain)
2010-12-14 06:28 UTC, renota
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Gawroński 2009-05-27 07:02:44 UTC
Application that crashed: kontact
Version of the application: 4.3.0 pre
KDE Version: 4.2.87 (KDE 4.2.87 (KDE 4.3 >= 20090519))
Qt Version: 4.5.1
Operating System: Linux 2.6.29-ARCH i686

What I was doing when the application crashed:
Kmail and Kontact both crashes at the startup.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0xb790c7c0 in Kontact::Plugin::part (this=0x8adbd98) at /home/drf/kdemod-core43/work/kdepim/src/kdepim-4.2.87/kontactinterfaces/plugin.cpp:186
#6  0xb1b2893e in KMailUniqueAppHandler::newInstance (this=0x8aff790) at /home/drf/kdemod-core43/work/kdepim/src/kdepim-4.2.87/kontact/plugins/kmail/kmail_plugin.cpp:208
#7  0xb790f069 in Kontact::UniqueAppHandler::newInstance (this=0x8aff790, asn_id=@0x9bd99f0, args=@0x8ba16d0)
    at /home/drf/kdemod-core43/work/kdepim/src/kdepim-4.2.87/kontactinterfaces/uniqueapphandler.cpp:128
#8  0xb790f0f6 in Kontact::UniqueAppHandler::qt_metacall (this=0x8aff790, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfab0d8c)
    at /home/drf/kdemod-core43/work/kdepim/src/build/kontactinterfaces/uniqueapphandler.moc:73
#9  0xb67dac37 in ?? () from /usr/lib/libQtDBus.so.4
#10 0xb67dbd95 in ?? () from /usr/lib/libQtDBus.so.4
#11 0xb67dc3c0 in ?? () from /usr/lib/libQtDBus.so.4
#12 0xb67dc8da in ?? () from /usr/lib/libQtDBus.so.4
#13 0xb66d69de in QObject::event () from /usr/lib/libQtCore.so.4
#14 0xb5b436ac in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#15 0xb5b4ae44 in QApplication::notify () from /usr/lib/libQtGui.so.4
#16 0xb6cc6bfa in KApplication::notify (this=0xbfab1764, receiver=0x8aff790, event=0x9eee100) at /home/drf/kdemod-core43/work/kdelibs/src/kdelibs-4.2.87/kdeui/kernel/kapplication.cpp:302
#17 0xb66c674b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#18 0xb66c7208 in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib/libQtCore.so.4
#19 0xb66c73dd in QCoreApplication::sendPostedEvents () from /usr/lib/libQtCore.so.4
#20 0xb66f1def in ?? () from /usr/lib/libQtCore.so.4
#21 0xb503a288 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0xb503d878 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#23 0xb503d9ea in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#24 0xb66f1a1c in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#25 0xb5be25c5 in ?? () from /usr/lib/libQtGui.so.4
#26 0xb66c4cd9 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#27 0xb66c5122 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#28 0xb66c749f in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#29 0xb5b43527 in QApplication::exec () from /usr/lib/libQtGui.so.4
#30 0x0804b63a in main (argc=3, argv=0xbfab1984) at /home/drf/kdemod-core43/work/kdepim/src/kdepim-4.2.87/kontact/src/main.cpp:218
Comment 1 Dario Andres 2009-05-30 20:24:13 UTC
*** Bug 194683 has been marked as a duplicate of this bug. ***
Comment 2 Dario Andres 2009-06-12 15:35:52 UTC
*** Bug 196149 has been marked as a duplicate of this bug. ***
Comment 3 Florian Reinhard 2009-06-22 21:46:51 UTC
i can confirm this (random) crash on 4.2.90 with qt 4.5.1.
started korganizer from cli => crash.

Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0xa0617b0) at /build/buildd/kdepim-4.2.90/kontactinterfaces/plugin.cpp:186
#7  0xb19c726a in KOrganizerUniqueAppHandler::newInstance (this=0xa066fc0) at /build/buildd/kdepim-4.2.90/kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0xb7951f39 in Kontact::UniqueAppHandler::newInstance (this=0xa066fc0, asn_id=@0xa2d10f8, args=@0xa104630) at /build/buildd/kdepim-4.2.90/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb7951fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0xa066fc0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfcda2f8)
    at /build/buildd/kdepim-4.2.90/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5e36e2a in QDBusConnectionPrivate::deliverCall (this=0x9cf9060, object=0xa066fc0, msg=@0xb39c228, metaTypes=@0xbfcda3a8, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5e38042 in QDBusConnectionPrivate::activateCall (this=0x9cf9060, object=0xa066fc0, flags=272, msg=@0xb39c228) at qdbusintegrator.cpp:796
#12 0xb5e385b1 in QDBusConnectionPrivate::activateObject (this=0x9cf9060, node=@0xb39c214, msg=@0xb39c228, pathStartPos=26) at qdbusintegrator.cpp:1375
#13 0xb5e38aaa in QDBusActivateObjectEvent::placeMetaCall (this=0xb39c1e8) at qdbusintegrator.cpp:1469
#14 0xb5d2f150 in QObject::event (this=0xa066fc0, e=0xb39c1e8) at kernel/qobject.cpp:1118
#15 0xb61dcbcc in QApplicationPrivate::notify_helper (this=0x9d01840, receiver=0xa066fc0, e=0xb39c1e8) at kernel/qapplication.cpp:4057
#16 0xb61e4ede in QApplication::notify (this=0xbfcdab78, receiver=0xa066fc0, e=0xb39c1e8) at kernel/qapplication.cpp:3604
#17 0xb6e00e8d in KApplication::notify (this=0xbfcdab78, receiver=0xa066fc0, event=0xb39c1e8) at /build/buildd/kde4libs-4.2.90/kdeui/kernel/kapplication.cpp:302
#18 0xb5d1e7ab in QCoreApplication::notifyInternal (this=0xbfcdab78, receiver=0xa066fc0, event=0xb39c1e8) at kernel/qcoreapplication.cpp:610
#19 0xb5d1f405 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9ce0c08) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5d1f5fd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5d4a58f in postEventSourceDispatch (s=0x9d03ac0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4df3b88 in IA__g_main_context_dispatch (context=0x9d03a38) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#23 0xb4df70eb in g_main_context_iterate (context=0x9d03a38, block=1, dispatch=1, self=0x9d012f0) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#24 0xb4df7268 in IA__g_main_context_iteration (context=0x9d03a38, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#25 0xb5d4a1d8 in QEventDispatcherGlib::processEvents (this=0x9d13dd0, flags={i = -1077040568}) at kernel/qeventdispatcher_glib.cpp:324
#26 0xb627e765 in QGuiEventDispatcherGlib::processEvents (this=0x9d13dd0, flags={i = -1077040520}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5d1cdda in QEventLoop::processEvents (this=0xbfcdaaf0, flags={i = -1077040456}) at kernel/qeventloop.cpp:149
#28 0xb5d1d21a in QEventLoop::exec (this=0xbfcdaaf0, flags={i = -1077040392}) at kernel/qeventloop.cpp:200
#29 0xb5d1f6c9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb61dca47 in QApplication::exec () at kernel/qapplication.cpp:3526
#31 0x0804bfef in main (argc=3, argv=0xbfcdae74) at /build/buildd/kdepim-4.2.90/kontact/src/main.cpp:218
Comment 4 Dario Andres 2009-06-28 16:29:29 UTC
*** Bug 198107 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Marin 2009-07-18 10:26:25 UTC
ok, reproduced in trunk. Not sure yet of a reliable way to trigger it.

What I  did so far :
- Launch kontact,
- browse between the different modules (except one which was running alone),
- File/Quit
- Start KMail

#5  0xb781e6ed in Kontact::Plugin::part (this=0x89906d0) at /home/krop/kde/src/KDE/kdepim/kontactinterfaces/plugin.cpp:186                                                                                             
No locals.                                                                                                                                                                                                             
#6  0xb142ecc3 in KMailUniqueAppHandler::newInstance (this=0x8990378) at /home/krop/kde/src/KDE/kdepim/kontact/plugins/kmail/kmail_plugin.cpp:208                                                                      
        __PRETTY_FUNCTION__ = "virtual int KMailUniqueAppHandler::newInstance()"                                                                                                                                       

        kmail = {<QDBusAbstractInterface> = {<QObject> = {_vptr.QObject = 0xbfd26c58, d_ptr = 0x0}, }, }
        reply = {m_error = {code = 3086843892, msg = {d = 0xb698d440}, nm = {d = 0xb67a1d80}, unused = 0xb698d464}, m_data = 24}
#7  0xb78207f7 in Kontact::UniqueAppHandler::newInstance (this=0x8990378, asn_id=@0x95a8d80, args=@0x97181f8) at /home/krop/kde/src/KDE/kdepim/kontactinterfaces/uniqueapphandler.cpp:128                                                 
        ds = {_vptr.QDataStream = 0xb66a1e18, d = 0xbfd26e48, dev = 0x92f1d60, owndev = true, noswap = false, byteorder = QDataStream::BigEndian, 
          ver = 11, q_status = QDataStream::Ok}                                                                                                   
#8  0xb78211cd in Kontact::UniqueAppHandler::qt_metacall (this=0x8990378, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd26e6c)                 
    at /home/krop/kde/build/KDE/kdepim/kontactinterfaces/uniqueapphandler.moc:73                                                                  
        _r = 141524736                                                                                                                            
#9  0xb66c7873 in QDBusConnectionPrivate::deliverCall (this=0x86ee5d8, object=0x8990378, msg=@0x9538f18, metaTypes=@0xbfd26f28, slotIdx=4)        
    at qdbusintegrator.cpp:891                                                                                                                    
        context = {connection = {d = 0x86ee5d8}, message = @0x9538f18}                                                                            
        old = 0x0                                                                                                                                 
        ptr = {o = 0x8990378}                                                                                                                     
        params = {a = 10, s = 3, ptr = 0xbfd26e6c, {                                                                                              
            array = "\310\330\302\b\200\215Z\t\370\201q\t\230nҿo\233\\\266\boҿXoҿ\270nҿH'j\266\0\0\0\0\252\0l\266P\343;\t",                       
            q_for_alignment_1 = 674006675287627976, q_for_alignment_2 = 1.3175680849713402e-263}}                                                 
        auxParameters = {{p = {d = 0xb66a43f4}, d = 0xb66a43f4}}                                                                                  
        i = 3                                                                                                                                     
        pCount = 2                                                                                                                                
        outputArgs = {{p = {d = 0x9ba4da0}, d = 0x9ba4da0}}                                                                                       
        fail = true                                                                                                                               
#10 0xb66c8832 in QDBusConnectionPrivate::activateCall (this=0x86ee5d8, object=0x8990378, flags=272, msg=@0x9538f18) at qdbusintegrator.cpp:796   
        mo = 0xb7826d3c                                                                                                                           
        memberName = {d = 0x9a65b80}                                                                                                              
        slotData = {flags = 272, slotIdx = 4, metaTypes = {{p = {d = 0x95a79b0}, d = 0x95a79b0}}}                                                 
        slotCache = {hash = {<QHash<QString, QDBusSlotCache::Data>> = {{d = 0x9fcad80, e = 0x9fcad80}}, <No data fields>}}                        
        cacheKey = {d = 0x9598e48}                                                                                                                
        signature = {d = 0x939ced8}                                                                                                               
        cachePropertyName = "_qdbus_slotCache"                                                                                                    
#11 0xb66c8da1 in QDBusConnectionPrivate::activateObject (this=0x86ee5d8, node=@0x9538f04, msg=@0x9538f18, pathStartPos=21)                       
    at qdbusintegrator.cpp:1370                                                                                                                   
        connector = 0xb6714ff4                                                                                                                    
#12 0xb66c929a in QDBusActivateObjectEvent::placeMetaCall (this=0x9538ed8) at qdbusintegrator.cpp:1464                                            
No locals.                                                                                                                                        
#13 0xb65bc970 in QObject::event (this=0x8990378, e=0x9538ed8) at kernel/qobject.cpp:1111                                                         
        currentSender = {sender = 0x86ee5d8, signal = -1, ref = 1}                                                                                
        previousSender = 0x0                                                                                                                      
#14 0xb5a837fc in QApplicationPrivate::notify_helper (this=0x8708cf0, receiver=0x8990378, e=0x9538ed8) at kernel/qapplication.cpp:4056            
        consumed = <value optimized out>                                                                                                          
#15 0xb5a8baee in QApplication::notify (this=0xbfd276f4, receiver=0x8990378, e=0x9538ed8) at kernel/qapplication.cpp:3603

(+more output)
Comment 6 Dario Andres 2009-07-19 21:51:02 UTC
*** Bug 200800 has been marked as a duplicate of this bug. ***
Comment 7 Christophe Marin 2009-07-21 11:16:31 UTC
*** Bug 200968 has been marked as a duplicate of this bug. ***
Comment 8 Christophe Marin 2009-07-26 16:27:22 UTC
*** Bug 201541 has been marked as a duplicate of this bug. ***
Comment 9 Dario Andres 2009-08-02 05:26:46 UTC
*** Bug 202260 has been marked as a duplicate of this bug. ***
Comment 10 Alexey Chernov 2009-08-05 22:08:50 UTC
Well, I've reproduced it on 4.3.0 final, maybe my report (with debugfull) will also be useful...

Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#5  0x00007f6a35e4469b in QWidget::show (this=0x14352c0) at /usr/include/QtGui/qwidget.h:473
#6  0x00007f6a35e4421e in Kontact::UniqueAppHandler::newInstance (this=0x16d58a0) at /usr/src/packages/kde4/4.3.0/kdepim-4.3.0/kontactinterfaces/uniqueapphandler.cpp:137
#7  0x00007f6a1dc7021a in KOrganizerUniqueAppHandler::newInstance (this=0x16d58a0) at /usr/src/packages/kde4/4.3.0/kdepim-4.3.0/kontact/plugins/korganizer/korg_uniqueapp.cpp:37
#8  0x00007f6a35e442e9 in Kontact::UniqueAppHandler::newInstance (this=0x16d58a0, asn_id=@0x1f2f160, args=@0x1f2e930)
    at /usr/src/packages/kde4/4.3.0/kdepim-4.3.0/kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00007f6a35e4437e in Kontact::UniqueAppHandler::qt_metacall (this=0x16d58a0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffb4625620)
    at /usr/src/packages/kde4/4.3.0/kdepim-4.3.0/build/kontactinterfaces/uniqueapphandler.moc:73
#10 0x00007f6a328e7b43 in QDBusConnectionPrivate::deliverCall (this=0x1343aa0, object=0x16d58a0, msg=@0x25f1540, metaTypes=@0x1b570c0, slotIdx=4) at qdbusintegrator.cpp:891
#11 0x00007f6a328e8f78 in QDBusConnectionPrivate::activateCall (this=0x1343aa0, object=0x16d58a0, flags=272, msg=@0x25f1540) at qdbusintegrator.cpp:803
#12 0x00007f6a328e9403 in QDBusConnectionPrivate::activateObject (this=0x1343aa0, node=@0x25f1518, msg=@0x25f1540, pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0x00007f6a328e98f8 in QDBusActivateObjectEvent::placeMetaCall (this=0x25f14d0) at qdbusintegrator.cpp:1464
#14 0x00007f6a325d0fd8 in QObject::event (this=0x16d58a0, e=0x25f14d0) at kernel/qobject.cpp:1102
#15 0x00007f6a3131e14d in QApplicationPrivate::notify_helper (this=0x1352a40, receiver=0x16d58a0, e=0x25f14d0) at kernel/qapplication.cpp:4056
#16 0x00007f6a3132490e in QApplication::notify (this=0x7fffb46264c0, receiver=0x16d58a0, e=0x25f14d0) at kernel/qapplication.cpp:4021
#17 0x00007f6a334480cb in KApplication::notify (this=0x7fffb46264c0, receiver=0x16d58a0, event=0x25f14d0) at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/kdeui/kernel/kapplication.cpp:302
#18 0x00007f6a325bfe0b in QCoreApplication::notifyInternal (this=0x7fffb46264c0, receiver=0x16d58a0, event=0x25f14d0) at kernel/qcoreapplication.cpp:610
#19 0x00007f6a325c0dbb in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x13010c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0x00007f6a325ec343 in postEventSourceDispatch (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#21 0x00007f6a2c8492d1 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0x00007f6a2c84ca4d in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#23 0x00007f6a2c84cc0b in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#24 0x00007f6a325ec06f in QEventDispatcherGlib::processEvents (this=0x1300980, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#25 0x00007f6a313bccaf in QGuiEventDispatcherGlib::processEvents (this=0x14352c0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#26 0x00007f6a325be902 in QEventLoop::processEvents (this=<value optimized out>, flags={i = -1268620320}) at kernel/qeventloop.cpp:149
#27 0x00007f6a325becd4 in QEventLoop::exec (this=0x7fffb4626420, flags={i = -1268620240}) at kernel/qeventloop.cpp:201
#28 0x00007f6a325c10d4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#29 0x0000000000404183 in main (argc=1, argv=0x7fffb46269d8) at /usr/src/packages/kde4/4.3.0/kdepim-4.3.0/kontact/src/main.cpp:218
Comment 11 Allen Winter 2009-08-05 22:12:14 UTC
CC'ing David.

Perhaps he knows what's happening here since he wrote much of the code referenced.
Comment 12 Dario Andres 2009-08-08 15:58:37 UTC
*** Bug 203019 has been marked as a duplicate of this bug. ***
Comment 13 Christophe Marin 2009-08-16 00:24:08 UTC
*** Bug 204000 has been marked as a duplicate of this bug. ***
Comment 14 Christophe Marin 2009-08-19 17:55:38 UTC
*** Bug 204420 has been marked as a duplicate of this bug. ***
Comment 15 Christophe Marin 2009-08-25 00:23:55 UTC
*** Bug 205023 has been marked as a duplicate of this bug. ***
Comment 16 Christophe Marin 2009-08-27 14:30:14 UTC
*** Bug 205334 has been marked as a duplicate of this bug. ***
Comment 17 Christophe Marin 2009-08-30 20:39:54 UTC
*** Bug 193213 has been marked as a duplicate of this bug. ***
Comment 18 Christophe Marin 2009-09-02 18:30:14 UTC
*** Bug 205711 has been marked as a duplicate of this bug. ***
Comment 19 Christophe Marin 2009-09-02 18:31:41 UTC
*** Bug 206002 has been marked as a duplicate of this bug. ***
Comment 20 Dario Andres 2009-09-05 21:49:42 UTC
*** Bug 206429 has been marked as a duplicate of this bug. ***
Comment 21 Christophe Marin 2009-09-06 10:33:31 UTC
*** Bug 206448 has been marked as a duplicate of this bug. ***
Comment 22 Christophe Marin 2009-09-07 21:33:49 UTC
*** Bug 206675 has been marked as a duplicate of this bug. ***
Comment 23 Christophe Marin 2009-09-08 09:29:40 UTC
*** Bug 206710 has been marked as a duplicate of this bug. ***
Comment 24 Christophe Marin 2009-09-22 21:15:25 UTC
*** Bug 208177 has been marked as a duplicate of this bug. ***
Comment 25 Dario Andres 2009-09-25 01:39:24 UTC
*** Bug 208319 has been marked as a duplicate of this bug. ***
Comment 26 Christophe Marin 2009-09-26 19:32:50 UTC
*** Bug 208626 has been marked as a duplicate of this bug. ***
Comment 27 Christophe Marin 2009-09-27 11:46:16 UTC
*** Bug 208664 has been marked as a duplicate of this bug. ***
Comment 28 Christophe Marin 2009-10-07 21:04:11 UTC
*** Bug 209791 has been marked as a duplicate of this bug. ***
Comment 29 Christophe Marin 2009-10-29 13:27:14 UTC
*** Bug 212261 has been marked as a duplicate of this bug. ***
Comment 30 Jonathan Thomas 2009-11-10 02:35:26 UTC
*** Bug 213629 has been marked as a duplicate of this bug. ***
Comment 31 Dario Andres 2009-11-10 22:42:53 UTC
*** Bug 214016 has been marked as a duplicate of this bug. ***
Comment 32 Jonathan Thomas 2009-11-12 01:51:43 UTC
*** Bug 214194 has been marked as a duplicate of this bug. ***
Comment 33 Christophe Marin 2009-11-12 23:15:14 UTC
*** Bug 214315 has been marked as a duplicate of this bug. ***
Comment 34 Christophe Marin 2009-11-15 03:07:56 UTC
*** Bug 214583 has been marked as a duplicate of this bug. ***
Comment 35 Christophe Marin 2009-11-16 00:30:19 UTC
*** Bug 214609 has been marked as a duplicate of this bug. ***
Comment 36 Christophe Marin 2009-11-16 10:31:42 UTC
*** Bug 214750 has been marked as a duplicate of this bug. ***
Comment 37 Christophe Marin 2009-11-18 21:46:57 UTC
*** Bug 215169 has been marked as a duplicate of this bug. ***
Comment 38 Dario Andres 2009-11-19 13:53:00 UTC
*** Bug 214098 has been marked as a duplicate of this bug. ***
Comment 39 Christophe Marin 2009-11-20 02:10:59 UTC
*** Bug 215361 has been marked as a duplicate of this bug. ***
Comment 40 Christophe Marin 2009-11-20 19:32:39 UTC
*** Bug 215466 has been marked as a duplicate of this bug. ***
Comment 41 Dario Andres 2009-11-21 14:42:59 UTC
From bug 215512:
---
What I was doing when the application crashed:
I accidentally closed Kontact on the window button (not File=>Quit) and wanted
to reopen it by clicking on the korgac reminder systray icon. I thought that it
was supposed to work that way.
BTW: Kontact doesn't quit all the time when using File=>Quit so you have to
kill a stale process to be able to open it again.
Comment 42 Dario Andres 2009-11-21 14:43:00 UTC
*** Bug 215512 has been marked as a duplicate of this bug. ***
Comment 43 Nicolas L. 2009-11-30 16:49:20 UTC
*** Bug 216728 has been marked as a duplicate of this bug. ***
Comment 44 Christophe Marin 2009-12-05 00:38:27 UTC
*** Bug 217386 has been marked as a duplicate of this bug. ***
Comment 45 pp.f. 2009-12-10 15:20:18 UTC
*** Bug 218117 has been marked as a duplicate of this bug. ***
Comment 46 pp.f. 2009-12-10 15:27:55 UTC
I disabled reminders and the systray of korganizer (implied by kontact in his Journal mandatory component), now i can open all kontact from his kmail icon in the systray. don't understand the logic behind.
Comment 47 pp.f. 2009-12-10 15:31:51 UTC
I disabled reminders and the systray of korganizer (implied by kontact in his Journal mandatory component), now i can open all kontact from his kmail icon in the systray. don't understand the logic behind.
Comment 48 Dario Andres 2009-12-10 17:38:40 UTC
*** Bug 217773 has been marked as a duplicate of this bug. ***
Comment 49 Dario Andres 2009-12-15 13:28:07 UTC
From bug 218747 (KDE SC 4.4 beta1):
-- Information about the crash:
After I disabled everything related to korganizer in kontact and started
korganizer from the system tray icon, kontact immediately crashed. Korganizer
didn't start.
After a restart of kontact, everything works as expected.

Updated backtrace:
---
[KCrash Handler]
#6  0x00fdaae0 in KontactInterface::Plugin::part (this=0x9b83be8) at
../../kontactinterface/plugin.cpp:190
#7  0x02257e0a in KOrganizerUniqueAppHandler::newInstance (this=0xa5678c8) at
../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0x00fdc769 in KontactInterface::UniqueAppHandler::newInstance
(this=0xa5678c8, asn_id=..., args=...) at
../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00fdc7f4 in KontactInterface::UniqueAppHandler::qt_metacall
(this=0xa5678c8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd99d6c) at
./uniqueapphandler.moc:79
...
Comment 50 Dario Andres 2009-12-15 13:28:16 UTC
*** Bug 218747 has been marked as a duplicate of this bug. ***
Comment 51 Dario Andres 2009-12-24 20:14:31 UTC
From bug 219979:
---
What I was doing when the application crashed:
Kontact (Kmail) crashes (segmentation fault) when the wireless network
connection drops and Kontact doesn't know the connection is being
re-negotiated.
Comment 52 Dario Andres 2009-12-24 20:14:33 UTC
*** Bug 219979 has been marked as a duplicate of this bug. ***
Comment 53 Jonathan Thomas 2009-12-29 15:11:03 UTC
*** Bug 201618 has been marked as a duplicate of this bug. ***
Comment 54 Jonathan Thomas 2009-12-29 15:11:09 UTC
*** Bug 220476 has been marked as a duplicate of this bug. ***
Comment 55 Jonathan Thomas 2009-12-29 21:31:54 UTC
*** Bug 220587 has been marked as a duplicate of this bug. ***
Comment 56 Dario Andres 2010-01-18 22:08:44 UTC
*** Bug 223045 has been marked as a duplicate of this bug. ***
Comment 57 Dario Andres 2010-01-22 15:59:43 UTC
From bug 223788:
-- What I was doing when the application crashed:
Kontact crashes upon trying to view my feeds.  I cannot run Akregator as a
stand alone application.
Comment 58 Dario Andres 2010-01-22 16:00:11 UTC
*** Bug 223788 has been marked as a duplicate of this bug. ***
Comment 59 Dario Andres 2010-02-19 23:36:22 UTC
*** Bug 227577 has been marked as a duplicate of this bug. ***
Comment 60 Christophe Marin 2010-02-25 12:28:00 UTC
*** Bug 228438 has been marked as a duplicate of this bug. ***
Comment 61 Christophe Marin 2010-03-26 01:15:14 UTC
*** Bug 231080 has been marked as a duplicate of this bug. ***
Comment 62 Christophe Marin 2010-03-26 01:16:15 UTC
*** Bug 229766 has been marked as a duplicate of this bug. ***
Comment 63 Christophe Marin 2010-03-28 04:17:14 UTC
*** Bug 221968 has been marked as a duplicate of this bug. ***
Comment 64 Christophe Marin 2010-03-28 04:17:22 UTC
*** Bug 220020 has been marked as a duplicate of this bug. ***
Comment 65 Christophe Marin 2010-03-31 17:55:31 UTC
*** Bug 232822 has been marked as a duplicate of this bug. ***
Comment 66 Christophe Marin 2010-03-31 17:58:59 UTC
*** Bug 232851 has been marked as a duplicate of this bug. ***
Comment 67 Christophe Marin 2010-04-08 08:41:40 UTC
*** Bug 233641 has been marked as a duplicate of this bug. ***
Comment 68 Christophe Marin 2010-06-06 15:23:31 UTC
*** Bug 240876 has been marked as a duplicate of this bug. ***
Comment 69 Christophe Marin 2010-06-06 15:24:36 UTC
*** Bug 235668 has been marked as a duplicate of this bug. ***
Comment 70 Christophe Marin 2010-06-06 15:24:50 UTC
*** Bug 235846 has been marked as a duplicate of this bug. ***
Comment 71 Christophe Marin 2010-06-06 15:25:04 UTC
*** Bug 239984 has been marked as a duplicate of this bug. ***
Comment 72 Christophe Marin 2010-06-06 15:26:41 UTC
*** Bug 234971 has been marked as a duplicate of this bug. ***
Comment 73 Christophe Marin 2010-06-06 17:33:35 UTC
*** Bug 237352 has been marked as a duplicate of this bug. ***
Comment 74 Christophe Marin 2010-06-06 17:34:39 UTC
*** Bug 234172 has been marked as a duplicate of this bug. ***
Comment 75 Christophe Marin 2010-06-06 17:35:06 UTC
*** Bug 235496 has been marked as a duplicate of this bug. ***
Comment 76 Christophe Marin 2010-06-06 17:36:19 UTC
*** Bug 237446 has been marked as a duplicate of this bug. ***
Comment 77 Christophe Marin 2010-06-06 17:36:40 UTC
*** Bug 237094 has been marked as a duplicate of this bug. ***
Comment 78 Christophe Marin 2010-06-06 17:36:53 UTC
*** Bug 236698 has been marked as a duplicate of this bug. ***
Comment 79 Christophe Marin 2010-06-07 00:58:55 UTC
*** Bug 235761 has been marked as a duplicate of this bug. ***
Comment 80 Christophe Marin 2010-06-07 00:59:06 UTC
*** Bug 235277 has been marked as a duplicate of this bug. ***
Comment 81 Christophe Marin 2010-06-07 01:29:24 UTC
*** Bug 235195 has been marked as a duplicate of this bug. ***
Comment 82 Christophe Marin 2010-06-09 00:58:16 UTC
*** Bug 241142 has been marked as a duplicate of this bug. ***
Comment 83 Christophe Marin 2010-06-17 13:55:28 UTC
*** Bug 241881 has been marked as a duplicate of this bug. ***
Comment 84 Christophe Marin 2010-06-19 11:22:20 UTC
*** Bug 242078 has been marked as a duplicate of this bug. ***
Comment 85 Christophe Marin 2010-06-25 11:41:31 UTC
*** Bug 242751 has been marked as a duplicate of this bug. ***
Comment 86 Christophe Marin 2010-07-05 15:15:26 UTC
*** Bug 242278 has been marked as a duplicate of this bug. ***
Comment 87 Nicolas L. 2010-07-27 16:29:51 UTC
*** Bug 245901 has been marked as a duplicate of this bug. ***
Comment 88 Michael DING 2010-09-04 12:14:10 UTC
Created attachment 51303 [details]
New crash information added by DrKonqi

First opened kontact,then closed, then start korgnization from daemon icon,then crash.
I repeated it several times
Comment 89 Christophe Marin 2010-09-19 13:39:52 UTC
*** Bug 249430 has been marked as a duplicate of this bug. ***
Comment 90 Christophe Marin 2010-09-19 13:40:30 UTC
*** Bug 245005 has been marked as a duplicate of this bug. ***
Comment 91 Christophe Marin 2010-09-19 13:40:46 UTC
*** Bug 246527 has been marked as a duplicate of this bug. ***
Comment 92 Christophe Marin 2010-09-19 13:40:55 UTC
*** Bug 249231 has been marked as a duplicate of this bug. ***
Comment 93 Christophe Marin 2010-09-19 13:47:56 UTC
*** Bug 248611 has been marked as a duplicate of this bug. ***
Comment 94 Christophe Marin 2010-09-19 13:48:14 UTC
*** Bug 243710 has been marked as a duplicate of this bug. ***
Comment 95 Christophe Marin 2010-09-19 21:57:37 UTC
*** Bug 246414 has been marked as a duplicate of this bug. ***
Comment 96 David Faure 2010-09-20 11:36:43 UTC
Did anyone run "valgrind kontact --nofork", to get a precise valgrind log of the crash?

Well, assuming "kontact --nofork" crashes in the first place. Otherwise use
"valgrind --trace-children=yes kontact".
Comment 97 Christophe Marin 2010-09-25 21:40:27 UTC
*** Bug 252373 has been marked as a duplicate of this bug. ***
Comment 98 Justin 2010-09-25 21:56:03 UTC
@David Faure: Do you mean this?

doonze@doonze-laptop:~$ valgrind kontact --nofork
==2447== Memcheck, a memory error detector
==2447== Copyright (C) 2002-2009, and GNU GPL'd, by Julian Seward et al.
==2447== Using Valgrind-3.6.0.SVN-Debian and LibVEX; rerun with -h for copyright info
==2447== Command: kontact --nofork
==2447== 
<unknown program name>(2447)/: KUniqueApplication: Can't setup D-Bus service. Probably already running. 

==2447== 
==2447== HEAP SUMMARY:
==2447==     in use at exit: 79,632 bytes in 175 blocks
==2447==   total heap usage: 3,450 allocs, 3,275 frees, 285,928 bytes allocated
==2447== 
==2447== LEAK SUMMARY:
==2447==    definitely lost: 0 bytes in 0 blocks
==2447==    indirectly lost: 0 bytes in 0 blocks
==2447==      possibly lost: 0 bytes in 0 blocks
==2447==    still reachable: 79,632 bytes in 175 blocks
==2447==         suppressed: 0 bytes in 0 blocks                                                                                                                                                           
==2447== Rerun with --leak-check=full to see details of leaked memory                                                                                                                                      
==2447==                                                                                                                                                                                                   
==2447== For counts of detected and suppressed errors, rerun with: -v                                                                                                                                      
==2447== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 10 from 6)
Comment 99 Christophe Marin 2010-09-26 05:53:06 UTC
Created attachment 51997 [details]
bt full from trunk

ok, I could finally reproduce (don't ask how yet)

So far:

# ps x |grep kontact
10148 pts/0    Sl     1:15 kontact

# qdbus

[cut]

:1.37
 org.kde.kwalletd
:1.374
 org.kde.akregator
 org.kde.kaddressbook
 org.kde.kjots
 org.kde.kmail
 org.kde.kontact
 org.kde.korganizer
 org.kde.ktimetracker
 org.kde.pim.TransportManager
:1.376

[...]

Running Kontact under valgrind doesn't give any hint (nothing more than in #98).
Kontact seems to crash when starting one of the components only:

valgrind akregator --nofork
==11812== Memcheck, a memory error detector
==11812== Copyright (C) 2002-2009, and GNU GPL'd, by Julian Seward et al.
==11812== Using Valgrind-3.5.0 and LibVEX; rerun with -h for copyright info
==11812== Command: akregator --nofork
==11812==

FAILURE (KCmdLineArgs):
The "qt" options have not be added to KCmdLineArgs!


then kontact crashes
Comment 100 Anne Wilson 2010-09-27 19:19:10 UTC
Not sure whether this is the same bug or not, but system information is:

Application: kontact (4.4.6)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.3-default i686
Distribution: "openSUSE 11.3 (i586)"

This immediately follows a large update of openSUSE.  Interestingly, KMail, KOrganizer and Akregator all start immediately as stand-alone apps (I haven't tried any other components.  Valgrind report follows.
Comment 101 Anne Wilson 2010-09-27 19:24:58 UTC
Created attachment 52032 [details]
Valgrind output during crashed open-attempt

During the activity there was high CPU usage and the temperature rose by ~20'C.  memcheck-x86-li was apparently using 25% of my CPU
Comment 102 Christophe Marin 2010-10-15 23:35:21 UTC
*** Bug 253472 has been marked as a duplicate of this bug. ***
Comment 103 Christophe Marin 2010-10-20 12:15:01 UTC
*** Bug 254686 has been marked as a duplicate of this bug. ***
Comment 104 Christoph Feck 2010-10-31 01:13:38 UTC
*** Bug 255044 has been marked as a duplicate of this bug. ***
Comment 105 Christoph Feck 2010-10-31 01:14:17 UTC
*** Bug 255030 has been marked as a duplicate of this bug. ***
Comment 106 Christoph Feck 2010-10-31 01:14:38 UTC
*** Bug 255029 has been marked as a duplicate of this bug. ***
Comment 107 Christoph Feck 2010-10-31 01:16:07 UTC
*** Bug 254895 has been marked as a duplicate of this bug. ***
Comment 108 Ronny Standtke 2010-11-16 07:10:45 UTC
I just run into the same issue on Kubuntu 10.10 with KDE 4.5.3. Here is the backtrace:

Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77c4730 (LWP 1791))]

Thread 2 (Thread 0xb0622b70 (LWP 1863)):
#0  0x0056af85 in pthread_mutex_unlock (mutex=0xa8c089c) at forward.c:184
#1  0x04e8fe58 in g_main_context_prepare (context=0xa8c0898, priority=0xb062211c) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2467
#2  0x04e90279 in g_main_context_iterate (context=0xa8c0898, block=<value optimized out>, dispatch=1, self=0xa8c0978) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2760
#3  0x04e90848 in g_main_context_iteration (context=0xa8c0898, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#4  0x02de559f in QEventDispatcherGlib::processEvents (this=0xa8c0860, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x02db5609 in QEventLoop::processEvents (this=0xb0622270, flags=) at kernel/qeventloop.cpp:149
#6  0x02db5a8a in QEventLoop::exec (this=0xb0622270, flags=...) at kernel/qeventloop.cpp:201
#7  0x02cb1b7e in QThread::exec (this=0x9bbfc08) at thread/qthread.cpp:490
#8  0x02d9435b in QInotifyFileSystemWatcherEngine::run (this=0x9bbfc08) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x02cb4df9 in QThreadPrivate::start (arg=0x9bbfc08) at thread/qthread_unix.cpp:266
#10 0x00a25cc9 in start_thread (arg=0xb0622b70) at pthread_create.c:304
#11 0x0055d6ae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77c4730 (LWP 1791)):
[KCrash Handler]
#7  0x00000001 in ?? ()
#8  0x00837da3 in KontactInterface::Plugin::part (this=0x9fa9318) at ../../kontactinterface/plugin.cpp:191
#9  0x02c2fd1a in KOrganizerUniqueAppHandler::newInstance (this=0x9fa5838) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#10 0x008390e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x9fa5838, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#11 0x00839174 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x9fa5838, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff720ac) at ./uniqueapphandler.moc:79
#12 0x006319dc in QDBusConnectionPrivate::deliverCall (this=0x9ac8a58, object=0x9fa5838, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:919
#13 0x00632cbf in QDBusConnectionPrivate::activateCall (this=0x9ac8a58, object=0x9fa5838, flags=272, msg=...) at qdbusintegrator.cpp:822
#14 0x0063349c in QDBusConnectionPrivate::activateObject (this=0x9ac8a58, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1399
#15 0x00633a2a in QDBusActivateObjectEvent::placeMetaCall (this=0xa4591b8) at qdbusintegrator.cpp:1493
#16 0x02dc96a2 in QObject::event (this=0x9fa5838, e=0x9fa9b50) at kernel/qobject.cpp:1219
#17 0x01262fdc in QApplicationPrivate::notify_helper (this=0x9ae0a60, receiver=0x9fa5838, e=0xa4591b8) at kernel/qapplication.cpp:4396
#18 0x0126904e in QApplication::notify (this=0xbff72ac4, receiver=0x9fa5838, e=0xa4591b8) at kernel/qapplication.cpp:3798
#19 0x00f5801a in KApplication::notify (this=0xbff72ac4, receiver=0x9fa5838, event=0xa4591b8) at ../../kdeui/kernel/kapplication.cpp:310
#20 0x02db6b3b in QCoreApplication::notifyInternal (this=0xbff72ac4, receiver=0x9fa5838, event=0xa4591b8) at kernel/qcoreapplication.cpp:732
#21 0x02db9d8b in sendEvent (receiver=0x0, event_type=0, data=0x9aafed0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9aafed0) at kernel/qcoreapplication.cpp:1373
#23 0x02db9f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#24 0x02de5a74 in sendPostedEvents (s=0x9ae2590) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=0x9ae2590) at kernel/qeventdispatcher_glib.cpp:277
#26 0x04e8c855 in g_main_dispatch (context=0x9ae2510) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2149
#27 g_main_context_dispatch (context=0x9ae2510) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2702
#28 0x04e90668 in g_main_context_iterate (context=0x9ae2510, block=<value optimized out>, dispatch=1, self=0x9ad11e0) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2780
#29 0x04e90848 in g_main_context_iteration (context=0x9ae2510, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#30 0x02de5565 in QEventDispatcherGlib::processEvents (this=0x9aafb90, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#31 0x01324be5 in QGuiEventDispatcherGlib::processEvents (this=0x9aafb90, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x02db5609 in QEventLoop::processEvents (this=0xbff72a24, flags=) at kernel/qeventloop.cpp:149
#33 0x02db5a8a in QEventLoop::exec (this=0xbff72a24, flags=...) at kernel/qeventloop.cpp:201
#34 0x02dba00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#35 0x01261e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#36 0x0804b132 in main (argc=3, argv=0xbff72ce4) at ../../../kontact/src/main.cpp:224
Comment 109 Anne Wilson 2010-11-17 17:17:24 UTC
I have finally beaten this.  If you haven't already done so, go through all the relevant rc files looking for references to the SpecialDates Plugin, and remove them.  I thought I had already done this, but I had missed one.  Removing that now allows me to use Kontact normally and completely.
Comment 110 Bernhard E. Reiter 2010-11-22 13:07:28 UTC
I believe this could use a thorough retest with the new "Kontact Desktop"
which is now trunk, but should get Kontact 4.6. It fully uses the Kontact
Services for all of Mail, Calendar, Contacts, Notes and Tasks.

With my version I have something similiar, sometimes:

Sometimes "kontact" does not give any respondse and refuses to start,
if try to start korganizer then, I get a crash dialog and after it kontact
starts again.

kontact --version
Qt: 4.6.3
KDE: 4.5.1 (KDE 4.5.1)
Kontact: 4.6 pre
Debian Squeeze/Sid package: kdepim 4:4.5~e5.20101112.1197730-kk4.1198061

part of the backtrace I get from the "Kontact Calender" start:
Thread 1 (Thread 0xb3204710 (LWP 5899)):
[KCrash Handler]
#7  0x0061006d in ?? ()
#8  0xb773ebe9 in KontactInterface::UniqueAppHandler::newInstance (this=0x8bc372
8, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0xb773ec74 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x8d4614
0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfad3cb8) at ./uniqueapphandler
.moc:79
#10 0xb4d0bac1 in QDBusConnectionPrivate::deliverCall (this=0x8b137a8, object=0x
8d46140, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
Comment 111 Christophe Marin 2010-11-29 14:20:16 UTC
*** Bug 257170 has been marked as a duplicate of this bug. ***
Comment 112 Christophe Marin 2010-11-29 16:01:44 UTC
*** Bug 256717 has been marked as a duplicate of this bug. ***
Comment 113 Christophe Marin 2010-11-29 16:03:03 UTC
*** Bug 256534 has been marked as a duplicate of this bug. ***
Comment 114 underline 2010-12-03 12:43:14 UTC
Created attachment 54031 [details]
New crash information added by DrKonqi

Kontact crashes when I close it, go to sleep mode, go back from sleep mode and open Kmail. The bug can be reproduces repeatedly.
Comment 115 renota 2010-12-14 06:28:42 UTC
Created attachment 54534 [details]
New crash information added by DrKonqi

opened kontact, it did not retrieve my email, closed kontact.  was unable to open it again.
Comment 116 Christophe Marin 2010-12-17 10:26:31 UTC
*** Bug 260348 has been marked as a duplicate of this bug. ***
Comment 117 Christophe Marin 2010-12-23 09:02:16 UTC
*** Bug 261042 has been marked as a duplicate of this bug. ***
Comment 118 Christophe Marin 2011-01-15 01:33:32 UTC
*** Bug 262516 has been marked as a duplicate of this bug. ***
Comment 119 Christophe Marin 2011-01-15 01:58:46 UTC
Update for this bug: 
A reliable way to reproduce the crash was given in bug 261042:

-- Information about the crash:
- What I was doing when the application crashed:
I disabled akregator in kontact settings, watched it close and get removed from
the system tray. After it was gone, I started it separately, which resulted in
this crash.

A patch was tested successfully. The fixing commit shall come soon®
Comment 120 Christophe Marin 2011-01-20 13:35:14 UTC
David: Can you commit your fix ? I believe Dirk is about to tag 4.6.0
Comment 121 Christophe Marin 2011-01-20 13:45:19 UTC
SVN commit 1215945 by cgiboudeaux:

Make sure the applications are unregistered when the module is unloaded. 
BUG: 194268
MERGE: 4.6


 M  +4 -1      uniqueapphandler.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1215945
Comment 122 Christophe Marin 2011-01-20 13:48:31 UTC
SVN commit 1215946 by cgiboudeaux:

Backport r1215945 from trunk to 4.6:
Make sure the applications are unregistered when the module is unloaded.
CCBUG: 194268
FIXED-IN: 4.6.0


 M  +4 -1      uniqueapphandler.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1215946
Comment 123 Christophe Marin 2011-02-01 00:11:21 UTC
*** Bug 230500 has been marked as a duplicate of this bug. ***
Comment 124 Filipe Azevedo 2011-02-01 12:20:43 UTC
Please remove me from this bug ... this tracker is ugly and does not seem to allow removing myself from this bug ...
Comment 125 Christophe Marin 2011-02-03 23:43:26 UTC
*** Bug 265347 has been marked as a duplicate of this bug. ***
Comment 126 Christophe Marin 2011-03-09 11:53:32 UTC
*** Bug 267971 has been marked as a duplicate of this bug. ***
Comment 127 Christophe Marin 2011-03-21 11:59:55 UTC
*** Bug 268954 has been marked as a duplicate of this bug. ***