Bug 255030 - Tried to open Kontact and only Korganizer came up minimized in the panel and then it crashed
Summary: Tried to open Kontact and only Korganizer came up minimized in the panel and ...
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-23 12:14 UTC by nikusaf
Modified: 2010-10-31 01:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nikusaf 2010-10-23 12:14:01 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
The title pretty much sums up the crash.  I just upgraded to Lucid.  Also, I have noticed that Firefox doesn't connect to the internet. But somehow Konqueror does.  Firefox worked prior to my upgrade.  Things seem to be a little glitchy now.  This is my first bug report, and I am an inexperienced user of Kubuntu and Linux.  I actually tried to submit a bug report the first time that Kontact crashed, but I couldn't activate my account with you guys from within my email on Konqueror.  I had to restart into Windoze.  I did save a copy of that bug report, and basically what happened with that was, I started Kontact for the very first time after upgrading to Lucid, and it opened, but another program opened minimized in the panel.  I am not sure of the exact name of this program but I believe that it was Korganizer manager.  Or something similiar to that.  Surely, their must be a way to open the Crash Reporting Assistant within Kubuntu.  Sadly, I don't know how...lol    If all of this is a waste of your time, I apologize.  Here is that initial bug report, and I hope that it is helpful:


Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f883ca88780 (LWP 1855))]

Thread 2 (Thread 0x7f8819622710 (LWP 1948)):
#0  0x00007f8839b58f93 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f883268d4a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f883268d8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f883af44566 in QEventDispatcherGlib::processEvents (this=0x24f9810, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f883af19992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f883af19d6c in QEventLoop::exec (this=0x7f8819621d90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f883ae23d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f883aefa178 in QInotifyFileSystemWatcherEngine::run (this=0x2859900) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f883ae26775 in QThreadPrivate::start (arg=0x2859900) at thread/qthread_unix.cpp:248
#9  0x00007f8834c049ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f8839b6570d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f883ca88780 (LWP 1855)):
[KCrash Handler]
#5  0x0000000000000000 in ?? ()
#6  0x00007f883c0eb879 in KontactInterface::Plugin::part (this=0x23a2720) at ../../kontactinterface/plugin.cpp:191
#7  0x00007f8823a91a21 in KOrganizerUniqueAppHandler::newInstance (this=0x239fe80) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0x00007f883c0ed0a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x239fe80, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00007f883c0ed114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x239fe80, _c=QMetaObject::InvokeMetaMethod, _id=37335376, _a=0x7fff0328e990) at ./uniqueapphandler.moc:79
#10 0x00007f8838366486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#11 0x00007f88383676ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x239fe80, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00007f8838367f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#13 0x00007f8838368468 in QDBusActivateObjectEvent::placeMetaCall (this=0x24fc220) at qdbusintegrator.cpp:1477
#14 0x00007f883af2ad49 in QObject::event (this=0x239fe80, e=0x24fc220) at kernel/qobject.cpp:1248
#15 0x00007f883a2d422c in QApplicationPrivate::notify_helper (this=0x1f0ddf0, receiver=0x239fe80, e=0x24fc220) at kernel/qapplication.cpp:4300
#16 0x00007f883a2da6fb in QApplication::notify (this=0x7fff0328f710, receiver=0x239fe80, e=0x24fc220) at kernel/qapplication.cpp:4183
#17 0x00007f883b903526 in KApplication::notify (this=0x7fff0328f710, receiver=0x239fe80, event=0x24fc220) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f883af1b06c in QCoreApplication::notifyInternal (this=0x7fff0328f710, receiver=0x239fe80, event=0x24fc220) at kernel/qcoreapplication.cpp:704
#19 0x00007f883af1d7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1ee2620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1ee2620) at kernel/qcoreapplication.cpp:1345
#21 0x00007f883af449d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#22 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#23 0x00007f88326898c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007f883268d748 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007f883268d8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007f883af44513 in QEventDispatcherGlib::processEvents (this=0x1ee1d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#27 0x00007f883a38446e in QGuiEventDispatcherGlib::processEvents (this=0x23a2720, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f883af19992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007f883af19d6c in QEventLoop::exec (this=0x7fff0328f650, flags=) at kernel/qeventloop.cpp:201
#30 0x00007f883af1daab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#31 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224


Mark Zuckerberg (Facebook) doesn't believe in privacy.

wired.com/epicenter/2010/04/report-facebook-ceo-mark-zuckerberg-doesnt-believe-in-privacy

Facebook has gone rogue.

wired.com/epicenter/2010/05/facebook-rogue

Join and support Diaspora.  Start a revolution.  ; )

Where you go from here, is a choice I leave to you.

Take the Redpill, and open your eyes.  \,,/, {[(^.^)]} ,\,,/

Or take the Bluepill, and join Schäuble and Stasi 2.0.

Welcome to where we are headed.  It's a world wide epidemic

The Matrix Ending Scene Animation: youtube.com/watch?v=a1fK1_yQ7D0&hd=1

Godspeed and Be The Miracle!  (^_^)

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f05d5259780 (LWP 1647))]

Thread 2 (Thread 0x7f05b1df3710 (LWP 1746)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f05b1df2a80 in ?? ()
#2  0x00007fffb6bff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f05d5259780 (LWP 1647)):
[KCrash Handler]
#5  0x00007f05d48bc84a in KontactInterface::Plugin::part (this=0x1ce5750) at ../../kontactinterface/plugin.cpp:190
#6  0x00007f05bc262a21 in KOrganizerUniqueAppHandler::newInstance (this=0x1cea7d0) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#7  0x00007f05d48be0a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x1cea7d0, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#8  0x00007f05d48be114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x1cea7d0, _c=QMetaObject::InvokeMetaMethod, _id=30299984, _a=0x7fffb6a60120) at ./uniqueapphandler.moc:79
#9  0x00007f05d0b37486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#10 0x00007f05d0b386ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x1cea7d0, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007f05d0b38f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007f05d0b39468 in QDBusActivateObjectEvent::placeMetaCall (this=0x18dc3b0) at qdbusintegrator.cpp:1477
#13 0x00007f05d36fbd49 in QObject::event (this=0x1cea7d0, e=0x18dc3b0) at kernel/qobject.cpp:1248
#14 0x00007f05d2aa522c in QApplicationPrivate::notify_helper (this=0x184ef70, receiver=0x1cea7d0, e=0x18dc3b0) at kernel/qapplication.cpp:4300
#15 0x00007f05d2aab6fb in QApplication::notify (this=0x7fffb6a60ea0, receiver=0x1cea7d0, e=0x18dc3b0) at kernel/qapplication.cpp:4183
#16 0x00007f05d40d4526 in KApplication::notify (this=0x7fffb6a60ea0, receiver=0x1cea7d0, event=0x18dc3b0) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f05d36ec06c in QCoreApplication::notifyInternal (this=0x7fffb6a60ea0, receiver=0x1cea7d0, event=0x18dc3b0) at kernel/qcoreapplication.cpp:704
#18 0x00007f05d36ee7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1823620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1823620) at kernel/qcoreapplication.cpp:1345
#20 0x00007f05d37159d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007f05cae5a8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f05cae5e748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f05cae5e8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f05d3715513 in QEventDispatcherGlib::processEvents (this=0x1822d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007f05d2b5546e in QGuiEventDispatcherGlib::processEvents (this=0x1ce5750, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f05d36ea992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f05d36ead6c in QEventLoop::exec (this=0x7fffb6a60de0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f05d36eeaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 254895, bug 254686, bug 247000, bug 246954, bug 246813.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-31 01:14:17 UTC

*** This bug has been marked as a duplicate of bug 194268 ***