Bug 236698 - Kontact crashes when I start Kmail separately
Summary: Kontact crashes when I start Kmail separately
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-07 15:40 UTC by Sylvain Garsault
Modified: 2010-06-06 17:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (3.63 KB, text/plain)
2010-05-26 00:25 UTC, Achim Schaefer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvain Garsault 2010-05-07 15:40:28 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
1. Start Kontact
2. Close Kontact
3. Start Kmail
4. Few secondes later: CRASH

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000000000000 in ?? ()
#6  0x00007fcf84add879 in KontactInterface::Plugin::part() () from /usr/lib/libkontactinterface.so.4
#7  0x00007fcf6c146e2b in ?? () from /usr/lib/kde4/kontact_kmailplugin.so
#8  0x00007fcf84adf0a9 in KontactInterface::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterface.so.4
#9  0x00007fcf84adf114 in KontactInterface::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterface.so.4
#10 0x00007fcf80d59486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#11 0x00007fcf80d5a6ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x1100a60, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00007fcf80d5af0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#13 0x00007fcf80d5b468 in QDBusActivateObjectEvent::placeMetaCall (this=0x2063740) at qdbusintegrator.cpp:1477
#14 0x00007fcf8391cd49 in QObject::event (this=0x1100a60, e=0x2063740) at kernel/qobject.cpp:1248
#15 0x00007fcf82cc622c in QApplicationPrivate::notify_helper (this=0xbe9290, receiver=0x1100a60, e=0x2063740) at kernel/qapplication.cpp:4300
#16 0x00007fcf82ccc6fb in QApplication::notify (this=0x7fff953dc920, receiver=0x1100a60, e=0x2063740) at kernel/qapplication.cpp:4183
#17 0x00007fcf842f5526 in KApplication::notify (this=0x7fff953dc920, receiver=0x1100a60, event=0x2063740) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007fcf8390d06c in QCoreApplication::notifyInternal (this=0x7fff953dc920, receiver=0x1100a60, event=0x2063740) at kernel/qcoreapplication.cpp:704
#19 0x00007fcf8390f7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xbb1620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xbb1620) at kernel/qcoreapplication.cpp:1345
#21 0x00007fcf839369d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#22 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#23 0x00007fcf7b07d8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007fcf7b081748 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007fcf7b0818fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007fcf83936513 in QEventDispatcherGlib::processEvents (this=0xbb0d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#27 0x00007fcf82d7646e in QGuiEventDispatcherGlib::processEvents (this=0x1115b80, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007fcf8390b992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007fcf8390bd6c in QEventLoop::exec (this=0x7fff953dc860, flags=) at kernel/qeventloop.cpp:201
#30 0x00007fcf8390faab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#31 0x0000000000403e8e in _start ()

This bug may be a duplicate of or related to bug 234172.

Possible duplicates by query: bug 235846, bug 235668, bug 235496, bug 234971, bug 234172.

Reported using DrKonqi
Comment 1 Achim Schaefer 2010-05-26 00:25:17 UTC
Created attachment 43894 [details]
New crash information added by DrKonqi

I was running kontact , while browsing for other bugs-)
In the other bug I clicked on an email adress, to write a new mail.

After that I got the crash assistant, I don't remember how long it took
Comment 2 Christophe Giboudeaux 2010-06-06 17:36:53 UTC

*** This bug has been marked as a duplicate of bug 194268 ***