Bug 239984 - akonadi and kde pim does't want to work, crashes
Summary: akonadi and kde pim does't want to work, crashes
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-29 15:52 UTC by Robert Mills
Modified: 2010-06-06 15:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Mills 2010-05-29 15:52:12 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic-pae i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Whenever I start the PIM it stops working, will not retrieve mail. addresses of contacts, calender etc. It starts and seems to be working then just stops

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb368a990 (LWP 2830))]

Thread 2 (Thread 0xab666b70 (LWP 3023)):
#0  0xb4248e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0xb6d6c6fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0xb6d71825 in QTimerInfoList::updateCurrentTime (this=0x89e53f4) at kernel/qeventdispatcher_unix.cpp:340
#3  0xb6d7186a in QTimerInfoList::timerWait (this=0x89e53f4, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0xb6d6f818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xab6660ac) at kernel/qeventdispatcher_glib.cpp:136
#5  0xb6d6f8a5 in timerSourcePrepare (source=0x0, timeout=0xb424cff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0xb41b9aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0xb41b9ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0xb41ba4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0xb6d6f60f in QEventDispatcherGlib::processEvents (this=0x89e3778, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0xb6d42059 in QEventLoop::processEvents (this=0xab666270, flags=) at kernel/qeventloop.cpp:149
#11 0xb6d424aa in QEventLoop::exec (this=0xab666270, flags=...) at kernel/qeventloop.cpp:201
#12 0xb6c3e5a8 in QThread::exec (this=0x89e2ac0) at thread/qthread.cpp:487
#13 0xb6d21c1b in QInotifyFileSystemWatcherEngine::run (this=0x89e2ac0) at io/qfilesystemwatcher_inotify.cpp:248
#14 0xb6c4132e in QThreadPrivate::start (arg=0x89e2ac0) at thread/qthread_unix.cpp:248
#15 0xb44a796e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0xb5fbca4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb368a990 (LWP 2830)):
[KCrash Handler]
#6  0xb7629b50 in KontactInterface::Plugin::part (this=0x8484650) at ../../kontactinterface/plugin.cpp:190
#7  0xaf22dd7a in KOrganizerUniqueAppHandler::newInstance (this=0x8489168) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0xb762b7e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x8489168, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0xb762b874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x8489168, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa9e21c) at ./uniqueapphandler.moc:79
#10 0xb551db34 in QDBusConnectionPrivate::deliverCall (this=0x807d4c0, object=0x8489168, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0xb551eddf in QDBusConnectionPrivate::activateCall (this=0x807d4c0, object=0x8489168, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0xb551f5ac in QDBusConnectionPrivate::activateObject (this=0x807d4c0, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1383
#13 0xb551fb1a in QDBusActivateObjectEvent::placeMetaCall (this=0x82aff88) at qdbusintegrator.cpp:1477
#14 0xb6d543fe in QObject::event (this=0x8489168, e=0x82aff88) at kernel/qobject.cpp:1248
#15 0xb62934dc in QApplicationPrivate::notify_helper (this=0x80853e8, receiver=0x8489168, e=0x82aff88) at kernel/qapplication.cpp:4300
#16 0xb629a05e in QApplication::notify (this=0xbfa9ec34, receiver=0x8489168, e=0x82aff88) at kernel/qapplication.cpp:3704
#17 0xb7294f2a in KApplication::notify (this=0xbfa9ec34, receiver=0x8489168, event=0x82aff88) at ../../kdeui/kernel/kapplication.cpp:302
#18 0xb6d43a3b in QCoreApplication::notifyInternal (this=0xbfa9ec34, receiver=0x8489168, event=0x82aff88) at kernel/qcoreapplication.cpp:704
#19 0xb6d46473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8065a60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8065a60) at kernel/qcoreapplication.cpp:1345
#21 0xb6d465dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0xb6d6fadf in QCoreApplication::sendPostedEvents (s=0x808a790) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x808a790) at kernel/qeventdispatcher_glib.cpp:276
#24 0xb41b65e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0xb41ba2d8 in ?? () from /lib/libglib-2.0.so.0
#26 0xb41ba4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0xb6d6f5d5 in QEventDispatcherGlib::processEvents (this=0x8065588, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0xb6353135 in QGuiEventDispatcherGlib::processEvents (this=0x8065588, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0xb6d42059 in QEventLoop::processEvents (this=0xbfa9eb94, flags=) at kernel/qeventloop.cpp:149
#30 0xb6d424aa in QEventLoop::exec (this=0xbfa9eb94, flags=...) at kernel/qeventloop.cpp:201
#31 0xb6d4669f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0xb6293577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in main (argc=3, argv=0xbfa9ee54) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 235846, bug 235668, bug 234971, bug 218747.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-06 15:25:04 UTC

*** This bug has been marked as a duplicate of bug 194268 ***