Bug 206429 - kontact crashs while starting and Korganizer remains in Systemtray
Summary: kontact crashs while starting and Korganizer remains in Systemtray
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-05 20:53 UTC by Jonathan Kolberg
Modified: 2009-09-05 21:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Kolberg 2009-09-05 20:53:31 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic i686
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0xb78c1500 in Kontact::Plugin::part () from /usr/lib/libkontactinterfaces.so.4
#6  0xb162c22e in ?? () from /usr/lib/kde4/kontact_kmailplugin.so
#7  0xb78c3f39 in Kontact::UniqueAppHandler::newInstance () from /usr/lib/libkontactinterfaces.so.4
#8  0xb78c3fc6 in Kontact::UniqueAppHandler::qt_metacall () from /usr/lib/libkontactinterfaces.so.4
#9  0xb5dcae5a in QDBusConnectionPrivate::deliverCall (this=0x9fd2140, object=0xa327690, msg=@0xa3d2758, metaTypes=@0xbfb5b2f8, slotIdx=4) at qdbusintegrator.cpp:891
#10 0xb5dcc072 in QDBusConnectionPrivate::activateCall (this=0x9fd2140, object=0xa327690, flags=272, msg=@0xa3d2758) at qdbusintegrator.cpp:796
#11 0xb5dcc5e1 in QDBusConnectionPrivate::activateObject (this=0x9fd2140, node=@0xa3d2744, msg=@0xa3d2758, pathStartPos=21) at qdbusintegrator.cpp:1370
#12 0xb5dccada in QDBusActivateObjectEvent::placeMetaCall (this=0xa3d2718) at qdbusintegrator.cpp:1464
#13 0xb5cc33b0 in QObject::event (this=0xa327690, e=0xa3d2718) at kernel/qobject.cpp:1111
#14 0xb6175d3c in QApplicationPrivate::notify_helper (this=0x9fef260, receiver=0xa327690, e=0xa3d2718) at kernel/qapplication.cpp:4056
#15 0xb617e03e in QApplication::notify (this=0xbfb5bac8, receiver=0xa327690, e=0xa3d2718) at kernel/qapplication.cpp:3603
#16 0xb6d6f85d in KApplication::notify (this=0xbfb5bac8, receiver=0xa327690, event=0xa3d2718) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#17 0xb5cb2bcb in QCoreApplication::notifyInternal (this=0xbfb5bac8, receiver=0xa327690, event=0xa3d2718) at kernel/qcoreapplication.cpp:610
#18 0xb5cb3825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9fba440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 0xb5cb3a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#20 0xb5cde6af in postEventSourceDispatch (s=0x9fe5710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#21 0xb4d83b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0xb4d870eb in ?? () from /usr/lib/libglib-2.0.so.0
#23 0xb4d87268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#24 0xb5cde2f8 in QEventDispatcherGlib::processEvents (this=0x9fba028, flags={i = -1078609512}) at kernel/qeventdispatcher_glib.cpp:327
#25 0xb6217a75 in QGuiEventDispatcherGlib::processEvents (this=0x9fba028, flags={i = -1078609464}) at kernel/qguieventdispatcher_glib.cpp:202
#26 0xb5cb11fa in QEventLoop::processEvents (this=0xbfb5ba40, flags={i = -1078609400}) at kernel/qeventloop.cpp:149
#27 0xb5cb1642 in QEventLoop::exec (this=0xbfb5ba40, flags={i = -1078609336}) at kernel/qeventloop.cpp:201
#28 0xb5cb3ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#29 0xb6175bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#30 0x0804bfef in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-05 21:49:42 UTC
Merging with bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***