Bug 208664 - Kontact crashes after opening it from the Kmenu
Summary: Kontact crashes after opening it from the Kmenu
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-27 05:51 UTC by Nick
Modified: 2009-09-27 11:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick 2009-09-27 05:51:48 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
I clicked Kmenu, and then Kontact from the favorites. It didn't even start, I just received the crash notification.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0xb783c500 in Kontact::Plugin::part () from /usr/lib/libkontactinterfaces.so.4
#7  0xb17b022e in ?? () from /usr/lib/kde4/kontact_kmailplugin.so
#8  0xb783ef39 in Kontact::UniqueAppHandler::newInstance () from /usr/lib/libkontactinterfaces.so.4
#9  0xb783efc6 in Kontact::UniqueAppHandler::qt_metacall () from /usr/lib/libkontactinterfaces.so.4
#10 0xb5d45e5a in QDBusConnectionPrivate::deliverCall (this=0x9346f40, object=0x96bbae8, msg=@0x946a480, metaTypes=@0xbfac9218, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5d47072 in QDBusConnectionPrivate::activateCall (this=0x9346f40, object=0x96bbae8, flags=272, msg=@0x946a480) at qdbusintegrator.cpp:796
#12 0xb5d475e1 in QDBusConnectionPrivate::activateObject (this=0x9346f40, node=@0x946a46c, msg=@0x946a480, pathStartPos=21) at qdbusintegrator.cpp:1370
#13 0xb5d47ada in QDBusActivateObjectEvent::placeMetaCall (this=0x946a440) at qdbusintegrator.cpp:1464
#14 0xb5c3e3b0 in QObject::event (this=0x96bbae8, e=0x946a440) at kernel/qobject.cpp:1111
#15 0xb60f0d3c in QApplicationPrivate::notify_helper (this=0x934e718, receiver=0x96bbae8, e=0x946a440) at kernel/qapplication.cpp:4056
#16 0xb60f903e in QApplication::notify (this=0xbfac99e8, receiver=0x96bbae8, e=0x946a440) at kernel/qapplication.cpp:3603
#17 0xb6cea85d in KApplication::notify (this=0xbfac99e8, receiver=0x96bbae8, event=0x946a440) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#18 0xb5c2dbcb in QCoreApplication::notifyInternal (this=0xbfac99e8, receiver=0x96bbae8, event=0x946a440) at kernel/qcoreapplication.cpp:610
#19 0xb5c2e825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x932f440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5c2ea1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5c596af in postEventSourceDispatch (s=0x9350510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4cfeb88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4d020eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4d02268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5c592f8 in QEventDispatcherGlib::processEvents (this=0x932f028, flags={i = -1079207752}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb6192a75 in QGuiEventDispatcherGlib::processEvents (this=0x932f028, flags={i = -1079207704}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5c2c1fa in QEventLoop::processEvents (this=0xbfac9960, flags={i = -1079207640}) at kernel/qeventloop.cpp:149
#28 0xb5c2c642 in QEventLoop::exec (this=0xbfac9960, flags={i = -1079207576}) at kernel/qeventloop.cpp:201
#29 0xb5c2eae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb60f0bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in _start ()

This bug may be a duplicate of or related to bug 205040

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-09-27 11:46:15 UTC

*** This bug has been marked as a duplicate of bug 194268 ***