Bug 218747 - Kontact crash after disabling korganizer parts [KontactInterface::Plugin::part, KOrganizerUniqueAppHandler::newInstance, KontactInterface::UniqueAppHandler::newInstance]
Summary: Kontact crash after disabling korganizer parts [KontactInterface::Plugin::par...
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4 pre
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-15 03:33 UTC by ancow
Modified: 2009-12-15 13:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ancow 2009-12-15 03:33:39 UTC
Application: kontact (4.4 pre)
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
After I disabled everything related to korganizer in kontact and started korganizer from the system tray icon, kontact immediately crashed. Korganizer didn't start.
After a restart of kontact, everything works as expected.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00fdaae0 in KontactInterface::Plugin::part (this=0x9b83be8) at ../../kontactinterface/plugin.cpp:190
#7  0x02257e0a in KOrganizerUniqueAppHandler::newInstance (this=0xa5678c8) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0x00fdc769 in KontactInterface::UniqueAppHandler::newInstance (this=0xa5678c8, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00fdc7f4 in KontactInterface::UniqueAppHandler::qt_metacall (this=0xa5678c8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd99d6c) at ./uniqueapphandler.moc:79
#10 0x0097c9f4 in QDBusConnectionPrivate::deliverCall (this=0x96b1bb8, object=0xa5678c8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x0097dcef in QDBusConnectionPrivate::activateCall (this=0x96b1bb8, object=0xa5678c8, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x0097e4bc in QDBusConnectionPrivate::activateObject (this=0x96b1bb8, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1387
#13 0x0097ea2a in QDBusActivateObjectEvent::placeMetaCall (this=0xa57c200) at qdbusintegrator.cpp:1481
#14 0x006828ae in QObject::event (this=0xa5678c8, e=0xa57c200) at kernel/qobject.cpp:1260
#15 0x060f619c in QApplicationPrivate::notify_helper (this=0x96c0e18, receiver=0xa5678c8, e=0xa57c200) at kernel/qapplication.cpp:4242
#16 0x060fcdf7 in QApplication::notify (this=0xbfd9a714, receiver=0xa5678c8, e=0xa57c200) at kernel/qapplication.cpp:3661
#17 0x011bdf8a in KApplication::notify (this=0xbfd9a714, receiver=0xa5678c8, event=0xa57c200) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00671eab in QCoreApplication::notifyInternal (this=0xbfd9a714, receiver=0xa5678c8, event=0xa57c200) at kernel/qcoreapplication.cpp:704
#19 0x006748e3 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x96997f8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x96997f8) at kernel/qcoreapplication.cpp:1345
#21 0x00674a4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x0069e0df in QCoreApplication::sendPostedEvents (s=0x96d1578) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x96d1578) at kernel/qeventdispatcher_glib.cpp:276
#24 0x07e02e88 in g_main_dispatch (context=0x96d14f0) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#25 IA__g_main_context_dispatch (context=0x96d14f0) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#26 0x07e06730 in g_main_context_iterate (context=0x96d14f0, block=<value optimized out>, dispatch=1, self=0x96c0ef0) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#27 0x07e06863 in IA__g_main_context_iteration (context=0x96d14f0, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#28 0x0069dbd5 in QEventDispatcherGlib::processEvents (this=0x96cd520, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#29 0x061b3b75 in QGuiEventDispatcherGlib::processEvents (this=0x96cd520, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#30 0x006704c9 in QEventLoop::processEvents (this=0xbfd9a674, flags=) at kernel/qeventloop.cpp:149
#31 0x0067091a in QEventLoop::exec (this=0xbfd9a674, flags=...) at kernel/qeventloop.cpp:201
#32 0x00674b0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#33 0x060f6237 in QApplication::exec () at kernel/qapplication.cpp:3570
#34 0x0804b4b6 in main (argc=1, argv=0xbfd9a934) at ../../../kontact/src/main.cpp:221

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-15 13:28:16 UTC
Merging with bug 194268 Thanks

*** This bug has been marked as a duplicate of bug 194268 ***