Bug 265347 - crash on start
Summary: crash on start
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-03 23:22 UTC by sievert
Modified: 2011-02-03 23:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sievert 2011-02-03 23:22:47 UTC
Application: kontact (4.4.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
Starting PIM from the desktop time is running a while and then nothing happens.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0xffffffff00000041 in ?? ()
#6  0x00007f7ce2fd822b in show (this=0x91abf0) at /usr/include/QtGui/qwidget.h:485
#7  KontactInterface::UniqueAppHandler::newInstance (this=0x91abf0) at /usr/src/debug/kdepimlibs-4.4.4/kontactinterface/uniqueapphandler.cpp:138
#8  0x00007f7ce2fd8b89 in KontactInterface::UniqueAppHandler::newInstance (this=0x91abf0, asn_id=<value optimized out>, args=...)
    at /usr/src/debug/kdepimlibs-4.4.4/kontactinterface/uniqueapphandler.cpp:129
#9  0x00007f7ce2fda574 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x91abf0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffd199a1d0)
    at /usr/src/debug/kdepimlibs-4.4.4/build/kontactinterface/uniqueapphandler.moc:79
#10 0x00007f7cdf3d2188 in QDBusConnectionPrivate::deliverCall (this=0x62f1d0, object=0x91abf0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x00007f7cdf3d41ae in QDBusConnectionPrivate::activateCall (this=0x62f1d0, object=0x91abf0, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00007f7cdf3d485c in QDBusConnectionPrivate::activateObject (this=0x62f1d0, node=..., msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#13 0x00007f7cdf3d4cf8 in QDBusActivateObjectEvent::placeMetaCall (this=0x1ec3900) at qdbusintegrator.cpp:1477
#14 0x00007f7ce1ed0509 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#15 0x00007f7ce12b04d4 in QApplicationPrivate::notify_helper (this=0x644660, receiver=0x91abf0, e=0x1ec3900) at kernel/qapplication.cpp:4302
#16 0x00007f7ce12b8aca in QApplication::notify (this=<value optimized out>, receiver=0x91abf0, e=0x1ec3900) at kernel/qapplication.cpp:4185
#17 0x00007f7ce27a1c06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#18 0x00007f7ce1ebee4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#19 0x00007f7ce1ec25ba in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#20 0x00007f7ce1ee7173 in ?? () from /usr/lib64/libQtCore.so.4
#21 0x00007f7cd99e7a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f7cd99e8270 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f7cd99e8510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f7ce1ee767f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#25 0x00007f7ce135114e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f7ce1ebe292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#27 0x00007f7ce1ebe495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#28 0x00007f7ce1ec288b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#29 0x000000000040417e in _start ()

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 254973, bug 252373, bug 241881, bug 237446, bug 234971.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-02-03 23:43:26 UTC

*** This bug has been marked as a duplicate of bug 194268 ***