Bug 214098 - kontact crash on startup - 50% of the time
Summary: kontact crash on startup - 50% of the time
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 223801 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-11 13:19 UTC by Mark Purcell
Modified: 2010-03-28 03:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Purcell 2009-11-11 13:19:26 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.30-2-686 i686
Distribution: Debian GNU/Linux unstable (sid)

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0xb6ff4de0 in QPen::QPen() () from /usr/lib/libQtGui.so.4
#7  0xb6fc3a8b in QPainterState::QPainterState() () from /usr/lib/libQtGui.so.4
#8  0xb6fc507d in QPainter::begin(QPaintDevice*) () from /usr/lib/libQtGui.so.4
#9  0xb6fc5a38 in QPainter::QPainter(QPaintDevice*) () from /usr/lib/libQtGui.so.4
#10 0xb6ef6629 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/libQtGui.so.4
#11 0xb7081b0c in ?? () from /usr/lib/libQtGui.so.4
#12 0xb6ee6bf6 in QWidgetPrivate::syncBackingStore() () from /usr/lib/libQtGui.so.4
#13 0xb6eeec3d in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#14 0xb72b18f7 in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb7e3d797 in KMainWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#16 0xb7e8239c in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#17 0xb6e98a94 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#18 0xb6ea0cc2 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#19 0xb7d5b0fd in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#20 0xb78591eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#21 0xb707f0d7 in ?? () from /usr/lib/libQtGui.so.4
#22 0xb7082347 in ?? () from /usr/lib/libQtGui.so.4
#23 0xb6ee94f6 in QWidget::repaint(QRect const&) () from /usr/lib/libQtGui.so.4
#24 0xb6ee95fc in QWidget::repaint() () from /usr/lib/libQtGui.so.4
#25 0xb72ebfd5 in QProgressBar::reset() () from /usr/lib/libQtGui.so.4
#26 0xb72ec034 in QProgressBar::setRange(int, int) () from /usr/lib/libQtGui.so.4
#27 0xb72ec07e in QProgressBar::setMaximum(int) () from /usr/lib/libQtGui.so.4
#28 0xb7fb424d in KPIM::StatusbarProgressWidget::activateSingleItemMode() () from /usr/lib/libkdepim.so.4
#29 0xb7fb443d in KPIM::StatusbarProgressWidget::slotProgressItemCompleted(KPIM::ProgressItem*) () from /usr/lib/libkdepim.so.4
#30 0xb7fb55fc in KPIM::StatusbarProgressWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdepim.so.4
#31 0xb786e303 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#32 0xb786ef42 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#33 0xb7faeb33 in KPIM::ProgressManager::progressItemCompleted(KPIM::ProgressItem*) () from /usr/lib/libkdepim.so.4
#34 0xb7fafe9e in KPIM::ProgressManager::slotTransactionCompleted(KPIM::ProgressItem*) () from /usr/lib/libkdepim.so.4
#35 0xb7fb0697 in KPIM::ProgressManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdepim.so.4
#36 0xb786e303 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#37 0xb786ef42 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#38 0xb7faedb3 in KPIM::ProgressItem::progressItemCompleted(KPIM::ProgressItem*) () from /usr/lib/libkdepim.so.4
#39 0xb7fb0126 in KPIM::ProgressItem::setComplete() () from /usr/lib/libkdepim.so.4
#40 0xb1153dcc in ?? () from /usr/lib/kde4/akregatorpart.so
#41 0xb11547b3 in ?? () from /usr/lib/kde4/akregatorpart.so
#42 0xb786e303 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#43 0xb786ef42 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#44 0xb10f58b3 in Akregator::Feed::fetchAborted(Akregator::Feed*) () from /usr/lib/kde4/akregatorpart.so
#45 0xb10f9673 in Akregator::Feed::fetchCompleted(Syndication::Loader*, boost::shared_ptr<Syndication::Feed>, Syndication::ErrorCode) () from /usr/lib/kde4/akregatorpart.so
#46 0xb10f9d78 in Akregator::Feed::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/akregatorpart.so
#47 0xb786e303 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#48 0xb786ef42 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#49 0xb104af6f in Syndication::Loader::loadingComplete(Syndication::Loader*, boost::shared_ptr<Syndication::Feed>, Syndication::ErrorCode) () from /usr/lib/libsyndication.so.4
#50 0xb104b498 in Syndication::Loader::abort() () from /usr/lib/libsyndication.so.4
#51 0xb10f6067 in Akregator::Feed::slotAbortFetch() () from /usr/lib/kde4/akregatorpart.so
#52 0xb110ac86 in Akregator::FetchQueue::slotAbort() () from /usr/lib/kde4/akregatorpart.so
#53 0xb110b0a0 in Akregator::FetchQueue::~FetchQueue() () from /usr/lib/kde4/akregatorpart.so
#54 0xb115554e in ?? () from /usr/lib/kde4/akregatorpart.so
#55 0xb11557c7 in ?? () from /usr/lib/kde4/akregatorpart.so
#56 0xb6b4a461 in ?? () from /lib/i686/cmov/libc.so.6
#57 0xb6b4a4bf in exit () from /lib/i686/cmov/libc.so.6
#58 0xaed6a436 in KMail::lockOrDie() () from /usr/lib/libkmailprivate.so.4
#59 0xaf1a4239 in ?? () from /usr/lib/kde4/kmailpart.so
#60 0xaf1a4e55 in QObject* KPluginFactory::createPartInstance<KMailPart>(QWidget*, QObject*, QList<QVariant> const&) () from /usr/lib/kde4/kmailpart.so
#61 0xb7b36e87 in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib/libkdecore.so.5
#62 0xb80314bb in Kontact::Core::createPart(char const*) () from /usr/lib/libkontactinterfaces.so.4
#63 0xb8032687 in Kontact::Plugin::loadPart() () from /usr/lib/libkontactinterfaces.so.4
#64 0xb1a13725 in ?? () from /usr/lib/kde4/kontact_kmailplugin.so
#65 0xb80325e2 in Kontact::Plugin::part() () from /usr/lib/libkontactinterfaces.so.4
#66 0xb804e3d4 in Kontact::MainWindow::selectPlugin(Kontact::Plugin*) () from /usr/lib/libkontactprivate.so.4
#67 0xb80534cc in Kontact::MainWindow::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactprivate.so.4
#68 0xb786e303 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#69 0xb786ef42 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#70 0xb8054c13 in ?? () from /usr/lib/libkontactprivate.so.4
#71 0xb8054caf in ?? () from /usr/lib/libkontactprivate.so.4
#72 0xb8054f5a in ?? () from /usr/lib/libkontactprivate.so.4
#73 0xb786e303 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#74 0xb786ef42 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#75 0xb8055043 in ?? () from /usr/lib/libkontactprivate.so.4
#76 0xb80550ce in ?? () from /usr/lib/libkontactprivate.so.4
#77 0xb80559ed in ?? () from /usr/lib/libkontactprivate.so.4
#78 0xb786e303 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#79 0xb786ef42 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#80 0xb742db69 in QItemSelectionModel::currentChanged(QModelIndex const&, QModelIndex const&) () from /usr/lib/libQtGui.so.4
#81 0xb742dd0d in QItemSelectionModel::setCurrentIndex(QModelIndex const&, QFlags<QItemSelectionModel::SelectionFlag>) () from /usr/lib/libQtGui.so.4
#82 0xb73df4a6 in QAbstractItemView::mousePressEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#83 0xb6eeeafe in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#84 0xb7294543 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#85 0xb733259f in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#86 0xb73e3887 in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#87 0xb7334b75 in ?? () from /usr/lib/libQtGui.so.4
#88 0xb785841a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#89 0xb6e98a6c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#90 0xb6ea1551 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#91 0xb7d5b0fd in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#92 0xb78591eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#93 0xb6ea05de in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
#94 0xb6f0f175 in ?? () from /usr/lib/libQtGui.so.4
#95 0xb6f0e646 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#96 0xb6f38bc2 in ?? () from /usr/lib/libQtGui.so.4
#97 0xb52d6e98 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#98 0xb52da623 in ?? () from /lib/libglib-2.0.so.0
#99 0xb52da7a8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#100 0xb7884041 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#101 0xb6f38305 in ?? () from /usr/lib/libQtGui.so.4
#102 0xb785783a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#103 0xb7857c82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#104 0xb785a0d9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#105 0xb6e98917 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#106 0x0804bd40 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-11 22:32:44 UTC
- What were you doing when the application crashed ? (According to the trace you were using the Akregator component) - Have you found a way to repeat the crash in a reliable way ?
Thanks
Comment 2 Christophe Giboudeaux 2009-11-14 01:18:25 UTC
Changing status until we get feedback (a useful backtrace would be welcome as well).
Comment 3 Mark Purcell 2009-11-19 12:36:29 UTC
Here is some more details.

kontact was running and then closed normally.

Window disappears however kontact is still running in the background:
$ ps aux | grep kontact
mark      3779  0.2  4.3 206232 89668 ?        S    Nov18   5:12 kontact -session 10687000000125816729300000034940037_1258167309_913406
mark     15539  0.0  0.0   3324   700 pts/0    R+   22:28   0:00 grep kontact


Attempts to start contact from the command line do nothing..  The window does not appear...
$ kontact


When starting kmail to get something happening kontact crashes:

 kmail
<unknown program name>(16030)/: Communication problem with  "kmail" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." "


Detailed backtrack (with -dbg) attached:

Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x8e1bfe0) at ../../kontactinterfaces/plugin.cpp:186
#7  0xb10f718b in KMailUniqueAppHandler::newInstance (this=0x8e1f480) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:208
#8  0xb76e0fb9 in Kontact::UniqueAppHandler::newInstance (this=0x8e1f480, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb76e1044 in Kontact::UniqueAppHandler::qt_metacall (this=0x8e1f480, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfbf3458) at ./uniqueapphandler.moc:73
#10 0xb5823be5 in QDBusConnectionPrivate::deliverCall (this=0x8b41a40, object=0x8e1f480, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5824d32 in QDBusConnectionPrivate::activateCall (this=0x8b41a40, object=0x8e1f480, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0xb5825254 in QDBusConnectionPrivate::activateObject (this=0x8b41a40, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1370
#13 0xb582573a in QDBusActivateObjectEvent::placeMetaCall (this=0xa107a50) at qdbusintegrator.cpp:1464
#14 0xb6f155e0 in QObject::event (this=0x8e1f480, e=0xa107a50) at kernel/qobject.cpp:1110
#15 0xb6544a94 in QApplicationPrivate::notify_helper (this=0x8b52538, receiver=0x8e1f480, e=0xa107a50) at kernel/qapplication.cpp:4065
#16 0xb654cbee in QApplication::notify (this=0xbfbf3e6c, receiver=0x8e1f480, e=0xa107a50) at kernel/qapplication.cpp:3605
#17 0xb74070fd in KApplication::notify (this=0xbfbf3e6c, receiver=0x8e1f480, event=0xa107a50) at ../../kdeui/kernel/kapplication.cpp:302
#18 0xb6f051eb in QCoreApplication::notifyInternal (this=0xbfbf3e6c, receiver=0x8e1f480, event=0xa107a50) at kernel/qcoreapplication.cpp:610
#19 0xb6f05e2e in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8b29998) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8b29998) at kernel/qcoreapplication.cpp:1247
#21 0xb6f0600d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0xb6f304cf in QCoreApplication::sendPostedEvents (s=0x8b49178) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x8b49178) at kernel/qeventdispatcher_glib.cpp:276
#24 0xb4982e98 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0xb4986623 in ?? () from /lib/libglib-2.0.so.0
#26 0xb49867a8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0xb6f30041 in QEventDispatcherGlib::processEvents (this=0x8b296e8, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#28 0xb65e4305 in QGuiEventDispatcherGlib::processEvents (this=0x8b296e8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0xb6f0383a in QEventLoop::processEvents (this=0xbfbf3ce0, flags=...) at kernel/qeventloop.cpp:149
#30 0xb6f03c82 in QEventLoop::exec (this=0xbfbf3ce0, flags=...) at kernel/qeventloop.cpp:201
#31 0xb6f060d9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0xb6544917 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804bd40 in main (argc=3, argv=0xbfbf4064) at ../../../kontact/src/main.cpp:218
Comment 4 Dario Andres 2009-11-19 13:25:34 UTC
The new crash is like bug 194268 Thanks
Comment 5 Dario Andres 2009-11-19 13:53:00 UTC

*** This bug has been marked as a duplicate of bug 194268 ***
Comment 6 Christophe Giboudeaux 2010-03-28 03:00:27 UTC
*** Bug 223801 has been marked as a duplicate of this bug. ***