Bug 201618 - Kontact crash on startup waiting password unlock
Summary: Kontact crash on startup waiting password unlock
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.12.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-27 05:14 UTC by rapsys
Modified: 2009-12-29 15:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rapsys 2009-07-27 05:14:48 UTC
Application that crashed: kontact
Version of the application: 4.3.0 rc3
KDE Version: 4.2.98 (KDE 4.2.98 (KDE 4.3 RC3))
Qt Version: 4.5.2
Operating System: Linux 2.6.30.2-server-1mnb i686
Distribution: "Mandriva Linux 2009.1"

What I was doing when the application crashed:
While waiting the kwallet unlock kontact crashed on startup.

This is a duplicate not fixed bug

 -- Backtrace:
Application: Kontact (kontact), signal: Aborted
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb69d59e1 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0xb69d7374 in abort () at abort.c:88
#9  0xb69ce83e in __assert_fail (assertion=0xb1289dbf "mFolder", file=0xb122af24 "/home/mandrake/rpm/BUILD/kdepim-4.2.98/kmail/kmacctcachedimap.cpp", line=206, 
    function=0xb122b560 "virtual void KMAcctCachedImap::processNewMail(bool)") at assert.c:78
#10 0xb0f48226 in KMAcctCachedImap::processNewMail (this=0x92ecf38) at /usr/src/debug/kdepim-4.2.98/kmail/kmacctcachedimap.cpp:206
#11 0xb0edd993 in KMail::AccountManager::processNextCheck (this=0x920ed78, _newMail=224) at /usr/src/debug/kdepim-4.2.98/kmail/accountmanager.cpp:230
#12 0xb0eddb50 in KMail::AccountManager::singleCheckMail (this=0x920ed78, account=0x92ecf38, interactive=false) at /usr/src/debug/kdepim-4.2.98/kmail/accountmanager.cpp:157
#13 0xb0e6a017 in KMAccount::mailCheck (this=0x92ecf38) at /usr/src/debug/kdepim-4.2.98/kmail/kmaccount.cpp:445
#14 0xb0e6c60c in KMAccount::qt_metacall (this=0x92ecf38, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfe6dfdc) at /usr/src/debug/kdepim-4.2.98/build/kmail/kmaccount.moc:147
#15 0xb0f2fea3 in KMail::NetworkAccount::qt_metacall (this=0x92ecf38, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfe6dfdc) at /usr/src/debug/kdepim-4.2.98/build/kmail/networkaccount.moc:58
#16 0xb0f3b712 in KMail::ImapAccountBase::qt_metacall (this=0x92ecf38, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfe6dfdc) at /usr/src/debug/kdepim-4.2.98/build/kmail/imapaccountbase.moc:113
#17 0xb0f47c72 in KMAcctCachedImap::qt_metacall (this=0x92ecf38, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfe6dfdc) at /usr/src/debug/kdepim-4.2.98/build/kmail/kmacctcachedimap.moc:78
#18 0xb770bf29 in QMetaObject::activate (sender=0x92f8d80, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3104
#19 0xb770cc65 in QMetaObject::activate (sender=0x92f8d80, m=0xb77e9904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3178
#20 0xb7748015 in QTimer::timeout (this=0x92f8d80) at .moc/release-shared/moc_qtimer.cpp:128
#21 0xb7711906 in QTimer::timerEvent (this=0x92f8d80, e=0xbfe6e450) at kernel/qtimer.cpp:261
#22 0xb7705b2b in QObject::event (this=0x92f8d80, e=0xbfe6e450) at kernel/qobject.cpp:1066
#23 0xb6d0f3ac in QApplicationPrivate::notify_helper (this=0x8e2ea00, receiver=0x92f8d80, e=0xbfe6e450) at kernel/qapplication.cpp:4056
#24 0xb6d16efe in QApplication::notify (this=0xbfe6f300, receiver=0x92f8d80, e=0xbfe6e450) at kernel/qapplication.cpp:3603
#25 0xb7c00e88 in KApplication::notify (this=0xbfe6f300, receiver=0x92f8d80, event=0xbfe6e450) at /usr/src/debug/kdelibs-4.2.98/kdeui/kernel/kapplication.cpp:302
#26 0xb76f579e in QCoreApplication::notifyInternal (this=0xbfe6f300, receiver=0x92f8d80, event=0xbfe6e450) at kernel/qcoreapplication.cpp:610
#27 0xb77242b9 in QTimerInfoList::activateTimers (this=0x8e1ecbc) at ../../src/corelib/kernel/qcoreapplication.h:213
#28 0xb7721a8e in timerSourceDispatch (source=0x8e1ec88) at kernel/qeventdispatcher_glib.cpp:165
#29 0xb4fa4ed2 in IA__g_main_context_dispatch (context=0x8e1ec00) at gmain.c:1960
#30 0xb4fa8888 in g_main_context_iterate (context=0x8e1ec00, block=<value optimized out>, dispatch=1, self=0x8e2a338) at gmain.c:2591
#31 0xb4fa89ae in IA__g_main_context_iteration (context=0x8e1ec00, may_block=1) at gmain.c:2654
#32 0xb77219d8 in QEventDispatcherGlib::processEvents (this=0x8e25ce8, flags={i = 36}) at kernel/qeventdispatcher_glib.cpp:327
#33 0xb6db225a in QGuiEventDispatcherGlib::processEvents (this=0x8e25ce8, flags={i = 36}) at kernel/qguieventdispatcher_glib.cpp:202
#34 0xb76f3d8d in QEventLoop::processEvents (this=0xbfe6e720, flags=) at kernel/qeventloop.cpp:149
#35 0xb76f41d9 in QEventLoop::exec (this=0xbfe6e720, flags={i = 0}) at kernel/qeventloop.cpp:201
#36 0xb7c8defd in KWallet::Wallet::openWallet (name=@0xbfe6e78c, w=0, ot=KWallet::Wallet::Synchronous) at /usr/src/debug/kdelibs-4.2.98/kdeui/util/kwallet.cpp:252
#37 0xb0f93a55 in KMKernel::wallet (this=0x91d4bc0) at /usr/src/debug/kdepim-4.2.98/kmail/kmkernel.cpp:2344
#38 0xb0f309b5 in KMail::NetworkAccount::readPassword (this=0x92ecf38) at /usr/src/debug/kdepim-4.2.98/kmail/networkaccount.cpp:328
#39 0xb0f310e5 in KMail::NetworkAccount::readConfig (this=0x92ecf38, config=@0xbfe6eab4) at /usr/src/debug/kdepim-4.2.98/kmail/networkaccount.cpp:170
#40 0xb0f3c526 in KMail::ImapAccountBase::readConfig (this=0x92ecf38, config=@0xbfe6eab4) at /usr/src/debug/kdepim-4.2.98/kmail/imapaccountbase.cpp:204
#41 0xb0f47714 in KMAcctCachedImap::readConfig (this=0x92ecf38, config=@0xbfe6eab4) at /usr/src/debug/kdepim-4.2.98/kmail/kmacctcachedimap.cpp:319
#42 0xb0ede53e in KMail::AccountManager::readConfig (this=0x920ed78) at /usr/src/debug/kdepim-4.2.98/kmail/accountmanager.cpp:131
#43 0xb0f9c164 in KMKernel::init (this=0x91d4bc0) at /usr/src/debug/kdepim-4.2.98/kmail/kmkernel.cpp:1465
#44 0xb13e029a in KMailPart (this=0x913ecd0, parentWidget=0x8f26d58, parent=0x0) at /usr/src/debug/kdepim-4.2.98/kmail/kmail_part.cpp:73
#45 0xb13e1c04 in KPluginFactory::createPartInstance<KMailPart> (parentWidget=0x8f26d58, parent=0x8f26d58, args=@0xbfe6eee8) at /usr/include/kpluginfactory.h:467
#46 0xb79a30f9 in KPluginFactory::create (this=0x8f2d8e0, iface=0xb699b020 "KParts::ReadOnlyPart", parentWidget=0x8f26d58, parent=0x8f26d58, args=@0xbfe6eee8, keyword=@0xbfe6ee1c)
    at /usr/src/debug/kdelibs-4.2.98/kdecore/util/kpluginfactory.cpp:191
#47 0xb7f6fb05 in KPluginFactory::create<KParts::ReadOnlyPart> (this=0x8f2d8e0, parent=0x8f26d58, args=@0xbfe6eee8) at /usr/include/kpluginfactory.h:491
#48 0xb7f6e6e5 in Kontact::Core::createPart (this=0x8f26d58, libname=0x911d290 "kmailpart") at /usr/src/debug/kdepim-4.2.98/kontactinterfaces/core.cpp:87
#49 0xb7f70982 in Kontact::Plugin::loadPart (this=0x9128db8) at /usr/src/debug/kdepim-4.2.98/kontactinterfaces/plugin.cpp:148
#50 0xb148eb6a in KMailPlugin::createPart (this=0x9128db8) at /usr/src/debug/kdepim-4.2.98/kontact/plugins/kmail/kmail_plugin.cpp:170
#51 0xb7f703b4 in Kontact::Plugin::part (this=0x9128db8) at /usr/src/debug/kdepim-4.2.98/kontactinterfaces/plugin.cpp:187
#52 0xb7f8bd93 in Kontact::MainWindow::selectPlugin (this=0x8f26d58, plugin=0x9128db8) at /usr/src/debug/kdepim-4.2.98/kontact/src/mainwindow.cpp:754
#53 0xb7f8b901 in Kontact::MainWindow::loadSettings (this=0x8f26d58) at /usr/src/debug/kdepim-4.2.98/kontact/src/mainwindow.cpp:926
#54 0xb7f906e7 in Kontact::MainWindow::initObject (this=0x8f26d58) at /usr/src/debug/kdepim-4.2.98/kontact/src/mainwindow.cpp:226
#55 0xb7f90f1e in MainWindow (this=0x8f26d58) at /usr/src/debug/kdepim-4.2.98/kontact/src/mainwindow.cpp:162
#56 0x0804b10b in main (argc=3, argv=0xbfe6f4e4) at /usr/src/debug/kdepim-4.2.98/kontact/src/main.cpp:210

Reported using DrKonqi
Comment 1 Jonathan Thomas 2009-12-29 15:11:03 UTC

*** This bug has been marked as a duplicate of bug 194268 ***