Bug 235668 - Kontact Crash on Open
Summary: Kontact Crash on Open
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-28 23:09 UTC by James Sakalaukus
Modified: 2010-06-06 15:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Sakalaukus 2010-04-28 23:09:03 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Kontact crashed when I opened it from the system tray for the first time.  I was scanning my music collection in Amarok at the time.  When I opened Kontact again, it ran fine.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb99aab0780 (LWP 1436))]

Thread 2 (Thread 0x7fb976bd0710 (LWP 1580)):
#0  0x00007fb997b72f53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb9906a84a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fb9906a88fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fb998f5d566 in QEventDispatcherGlib::processEvents (this=0x28e7690, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fb998f32992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fb998f32d6c in QEventLoop::exec (this=0x7fb976bcfd90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fb998e3cd59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fb998f13178 in QInotifyFileSystemWatcherEngine::run (this=0x28e6b90) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb998e3f775 in QThreadPrivate::start (arg=0x28e6b90) at thread/qthread_unix.cpp:248
#9  0x00007fb992c1e9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fb997b7f69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb99aab0780 (LWP 1436)):
[KCrash Handler]
#5  0x00007fb99a10484a in KontactInterface::Plugin::part (this=0x2357090) at ../../kontactinterface/plugin.cpp:190
#6  0x00007fb981b1ba21 in KOrganizerUniqueAppHandler::newInstance (this=0x2357f00) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#7  0x00007fb99a1060a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x2357f00, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#8  0x00007fb99a106114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x2357f00, _c=QMetaObject::InvokeMetaMethod, _id=37056656, _a=0x7fffdf84f1a0) at ./uniqueapphandler.moc:79
#9  0x00007fb996380486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#10 0x00007fb9963816ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x2357f00, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007fb996381f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007fb996382468 in QDBusActivateObjectEvent::placeMetaCall (this=0x2103460) at qdbusintegrator.cpp:1477
#13 0x00007fb998f43d49 in QObject::event (this=0x2357f00, e=0x2103460) at kernel/qobject.cpp:1248
#14 0x00007fb9982ed22c in QApplicationPrivate::notify_helper (this=0x1ed5120, receiver=0x2357f00, e=0x2103460) at kernel/qapplication.cpp:4300
#15 0x00007fb9982f36fb in QApplication::notify (this=0x7fffdf84ff20, receiver=0x2357f00, e=0x2103460) at kernel/qapplication.cpp:4183
#16 0x00007fb99991c526 in KApplication::notify (this=0x7fffdf84ff20, receiver=0x2357f00, event=0x2103460) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007fb998f3406c in QCoreApplication::notifyInternal (this=0x7fffdf84ff20, receiver=0x2357f00, event=0x2103460) at kernel/qcoreapplication.cpp:704
#18 0x00007fb998f367e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1ea9620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1ea9620) at kernel/qcoreapplication.cpp:1345
#20 0x00007fb998f5d9d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007fb9906a48c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007fb9906a8748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007fb9906a88fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007fb998f5d513 in QEventDispatcherGlib::processEvents (this=0x1ea8d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007fb99839d46e in QGuiEventDispatcherGlib::processEvents (this=0x2357090, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007fb998f32992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007fb998f32d6c in QEventLoop::exec (this=0x7fffdf84fe60, flags=) at kernel/qeventloop.cpp:201
#29 0x00007fb998f36aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 234971, bug 218747, bug 194268.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-06 15:24:36 UTC

*** This bug has been marked as a duplicate of bug 194268 ***