Bug 201541 - Kontact crashed just after opening
Summary: Kontact crashed just after opening
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-26 11:58 UTC by Bitta Jam
Modified: 2009-07-26 16:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bitta Jam 2009-07-26 11:58:33 UTC
Application that crashed: kontact
Version of the application: 4.3.0 rc3
KDE Version: 4.2.98 (KDE 4.2.98 (KDE 4.3 RC3))
Qt Version: 4.5.1
Operating System: Linux 2.6.28-11-generic i686
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x9c9c6f8) at /build/buildd/kdepim-4.2.98/kontactinterfaces/plugin.cpp:186
#7  0xb189026a in KOrganizerUniqueAppHandler::newInstance (this=0x9c35c40) at /build/buildd/kdepim-4.2.98/kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0xb78b5f39 in Kontact::UniqueAppHandler::newInstance (this=0x9c35c40, asn_id=@0x9e28990, args=@0x9e0a518) at /build/buildd/kdepim-4.2.98/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb78b5fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x9c35c40, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf9447a8)
    at /build/buildd/kdepim-4.2.98/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5d96e2a in QDBusConnectionPrivate::deliverCall (this=0x98ba150, object=0x9c35c40, msg=@0x9cb0ac0, metaTypes=@0xbf944858, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5d98042 in QDBusConnectionPrivate::activateCall (this=0x98ba150, object=0x9c35c40, flags=272, msg=@0x9cb0ac0) at qdbusintegrator.cpp:796
#12 0xb5d985b1 in QDBusConnectionPrivate::activateObject (this=0x98ba150, node=@0x9cb0aac, msg=@0x9cb0ac0, pathStartPos=26) at qdbusintegrator.cpp:1375
#13 0xb5d98aaa in QDBusActivateObjectEvent::placeMetaCall (this=0x9cb0a80) at qdbusintegrator.cpp:1469
#14 0xb5c8f150 in QObject::event (this=0x9c35c40, e=0x9cb0a80) at kernel/qobject.cpp:1118
#15 0xb613ebcc in QApplicationPrivate::notify_helper (this=0x98cda98, receiver=0x9c35c40, e=0x9cb0a80) at kernel/qapplication.cpp:4057
#16 0xb6146ede in QApplication::notify (this=0xbf945028, receiver=0x9c35c40, e=0x9cb0a80) at kernel/qapplication.cpp:3604
#17 0xb6d635cd in KApplication::notify (this=0xbf945028, receiver=0x9c35c40, event=0x9cb0a80) at /build/buildd/kde4libs-4.2.98a/kdeui/kernel/kapplication.cpp:302
#18 0xb5c7e7ab in QCoreApplication::notifyInternal (this=0xbf945028, receiver=0x9c35c40, event=0x9cb0a80) at kernel/qcoreapplication.cpp:610
#19 0xb5c7f405 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x98a2440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5c7f5fd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5caa58f in postEventSourceDispatch (s=0x98c2090) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4d52b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4d560eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4d56268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5caa1d8 in QEventDispatcherGlib::processEvents (this=0x98a2028, flags={i = -1080799496}) at kernel/qeventdispatcher_glib.cpp:324
#26 0xb61e0765 in QGuiEventDispatcherGlib::processEvents (this=0x98a2028, flags={i = -1080799448}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5c7cdda in QEventLoop::processEvents (this=0xbf944fa0, flags={i = -1080799384}) at kernel/qeventloop.cpp:149
#28 0xb5c7d21a in QEventLoop::exec (this=0xbf944fa0, flags={i = -1080799320}) at kernel/qeventloop.cpp:200
#29 0xb5c7f6c9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb613ea47 in QApplication::exec () at kernel/qapplication.cpp:3526
#31 0x0804bfef in main (argc=3, argv=0xbf945324) at /build/buildd/kdepim-4.2.98/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 200968

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-07-26 16:27:22 UTC

*** This bug has been marked as a duplicate of bug 194268 ***