Bug 254895 - Korganizer crashes when closing Kontact
Summary: Korganizer crashes when closing Kontact
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-21 20:14 UTC by StefanGER
Modified: 2010-10-31 01:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description StefanGER 2010-10-21 20:14:32 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
after closing Kontact Korganizer-Modul always crashes

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8227ce9780 (LWP 3975))]

Thread 2 (Thread 0x7f81fffff710 (LWP 4052)):
#0  0x00007f8224db6f93 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f821d8eb4a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f821d8eb8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f82261a2566 in QEventDispatcherGlib::processEvents (this=0x154f6d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f8226177992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f8226177d6c in QEventLoop::exec (this=0x7f81ffffed90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f8226081d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f8226158178 in QInotifyFileSystemWatcherEngine::run (this=0xf3d410) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8226084775 in QThreadPrivate::start (arg=0xf3d410) at thread/qthread_unix.cpp:248
#9  0x00007f821fe629ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f8224dc370d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8227ce9780 (LWP 3975)):
[KCrash Handler]
#5  0x00007f822734984a in KontactInterface::Plugin::part (this=0xf85240) at ../../kontactinterface/plugin.cpp:190
#6  0x00007f820eaf9a21 in KOrganizerUniqueAppHandler::newInstance (this=0xf99ad0) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#7  0x00007f822734b0a9 in KontactInterface::UniqueAppHandler::newInstance (this=0xf99ad0, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#8  0x00007f822734b114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0xf99ad0, _c=QMetaObject::InvokeMetaMethod, _id=16273984, _a=0x7fff56f09610) at ./uniqueapphandler.moc:79
#9  0x00007f82235c4486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#10 0x00007f82235c56ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0xf99ad0, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007f82235c5f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007f82235c6468 in QDBusActivateObjectEvent::placeMetaCall (this=0xc6e790) at qdbusintegrator.cpp:1477
#13 0x00007f8226188d49 in QObject::event (this=0xf99ad0, e=0xc6e790) at kernel/qobject.cpp:1248
#14 0x00007f822553222c in QApplicationPrivate::notify_helper (this=0xae7570, receiver=0xf99ad0, e=0xc6e790) at kernel/qapplication.cpp:4300
#15 0x00007f82255386fb in QApplication::notify (this=0x7fff56f0a390, receiver=0xf99ad0, e=0xc6e790) at kernel/qapplication.cpp:4183
#16 0x00007f8226b61526 in KApplication::notify (this=0x7fff56f0a390, receiver=0xf99ad0, event=0xc6e790) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f822617906c in QCoreApplication::notifyInternal (this=0x7fff56f0a390, receiver=0xf99ad0, event=0xc6e790) at kernel/qcoreapplication.cpp:704
#18 0x00007f822617b7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xabd620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xabd620) at kernel/qcoreapplication.cpp:1345
#20 0x00007f82261a29d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007f821d8e78c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f821d8eb748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f821d8eb8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f82261a2513 in QEventDispatcherGlib::processEvents (this=0xabcd70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007f82255e246e in QGuiEventDispatcherGlib::processEvents (this=0xf85240, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f8226177992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f8226177d6c in QEventLoop::exec (this=0x7fff56f0a2d0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f822617baab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 240876.

Possible duplicates by query: bug 254686, bug 247000, bug 246954, bug 246813, bug 246445.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-31 01:16:07 UTC

*** This bug has been marked as a duplicate of bug 194268 ***