Bug 260348 - Kontact crashes on startup
Summary: Kontact crashes on startup
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-17 09:48 UTC by Ludovic
Modified: 2010-12-17 10:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludovic 2010-12-17 09:48:01 UTC
Application: kontact (4.4.6)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.36-020636-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: Tried to start Kontact.

I clicked the kontact button; nothing happened, so I tried again. And after trying one more time, the crash dialog appeared. While filling in the this dialog, I tried it again (after installing the 
kdepimlibs-dbg  and kdepim-dbg packages), and it started just fine.

This is on Kubuntu 10.10.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe9cd3ac780 (LWP 18568))]

Thread 2 (Thread 0x7fe9a9ab4700 (LWP 18961)):
#0  0x00007fe9ca3de203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe9c3151009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fe9c315145c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fe9cab221e6 in QEventDispatcherGlib::processEvents (this=0xc801f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007fe9caaf4a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fe9caaf4dec in QEventLoop::exec (this=0x7fe9a9ab3d90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fe9ca9ff2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fe9caad45f8 in QInotifyFileSystemWatcherEngine::run (this=0x1ef57c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe9caa0227e in QThreadPrivate::start (arg=0x1ef57c0) at thread/qthread_unix.cpp:266
#9  0x00007fe9c54e0971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007fe9ca3ea92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe9cd3ac780 (LWP 18568)):
[KCrash Handler]
#6  0x00000000010b8cca in ?? ()
#7  0x00007fe9cca0da09 in KontactInterface::Plugin::part (this=0x10a3080) at ../../kontactinterface/plugin.cpp:191
#8  0x00007fe9aff02aab in KMailUniqueAppHandler::newInstance (this=<value optimized out>) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#9  0x00007fe9cca0e9f9 in KontactInterface::UniqueAppHandler::newInstance (this=0x1099e00, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#10 0x00007fe9cca0ea64 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x1099e00, _c=QMetaObject::InvokeMetaMethod, _id=17533920, _a=0x7fffd6e236c0) at ./uniqueapphandler.moc:79
#11 0x00007fe9c8bbf0ee in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#12 0x00007fe9c8bc036f in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x1099e00, flags=272, msg=...) at qdbusintegrator.cpp:822
#13 0x00007fe9c8bc0bae in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1399
#14 0x00007fe9c8bc1108 in QDBusActivateObjectEvent::placeMetaCall (this=0xc88220) at qdbusintegrator.cpp:1493
#15 0x00007fe9cab07bde in QObject::event (this=0x1099e00, e=0x10a3080) at kernel/qobject.cpp:1219
#16 0x00007fe9cb4abfdc in QApplicationPrivate::notify_helper (this=0xb21980, receiver=0x1099e00, e=0xc88220) at kernel/qapplication.cpp:4396
#17 0x00007fe9cb4b1aed in QApplication::notify (this=0x7fffd6e24440, receiver=0x1099e00, e=0xc88220) at kernel/qapplication.cpp:4277
#18 0x00007fe9cc1fe156 in KApplication::notify (this=0x7fffd6e24440, receiver=0x1099e00, event=0xc88220) at ../../kdeui/kernel/kapplication.cpp:310
#19 0x00007fe9caaf5cdc in QCoreApplication::notifyInternal (this=0x7fffd6e24440, receiver=0x1099e00, event=0xc88220) at kernel/qcoreapplication.cpp:732
#20 0x00007fe9caaf8c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xaf2380) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xaf2380) at kernel/qcoreapplication.cpp:1373
#22 0x00007fe9cab22653 in sendPostedEvents (s=0xb279a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0xb279a0) at kernel/qeventdispatcher_glib.cpp:277
#24 0x00007fe9c314d342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x00007fe9c31512a8 in ?? () from /lib/libglib-2.0.so.0
#26 0x00007fe9c315145c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x00007fe9cab22193 in QEventDispatcherGlib::processEvents (this=0xaf1e90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#28 0x00007fe9cb55ea4e in QGuiEventDispatcherGlib::processEvents (this=0x10a3080, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007fe9caaf4a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#30 0x00007fe9caaf4dec in QEventLoop::exec (this=0x7fffd6e24380, flags=) at kernel/qeventloop.cpp:201
#31 0x00007fe9caaf8ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#32 0x0000000000403b4e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 255958, bug 255029, bug 253472, bug 249231, bug 246527.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-12-17 10:26:31 UTC

*** This bug has been marked as a duplicate of bug 194268 ***