Bug 204420 - kontact crashed, when restarting akregator
Summary: kontact crashed, when restarting akregator
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-19 16:48 UTC by fake name
Modified: 2009-08-19 17:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fake name 2009-08-19 16:48:09 UTC
Application that crashed: kontact
Version of the application: 4.3.0
KDE Version: 4.3.00 (KDE 4.3.0) "release 155"
Qt Version: 4.5.2
Operating System: Linux 2.6.27.25-0.1-default x86_64
Distribution: "openSUSE 11.1 (x86_64)"

What I was doing when the application crashed:
Kontact has crashed doing the same that the related bug, but I was with the akregator component inside of Kmail.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000000aff100 in ?? ()
#6  0x00007f44da2cd9f9 in Kontact::Plugin::part (this=0x99d220) at /usr/src/debug/kdepim-4.3.0/kontactinterfaces/plugin.cpp:187
#7  0x00007f44c377b84e in AkregatorUniqueAppHandler::newInstance (this=0x8ee8a0) at /usr/src/debug/kdepim-4.3.0/kontact/plugins/akregator/akregator_plugin.cpp:155
#8  0x00007f44da2d0022 in Kontact::UniqueAppHandler::newInstance (this=0x8ee8a0, asn_id=@0x123a910, args=@0x278bab0) at /usr/src/debug/kdepim-4.3.0/kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00007f44da2d009a in Kontact::UniqueAppHandler::qt_metacall (this=0x8ee8a0, _c=QMetaObject::InvokeMetaMethod, _id=9426944, _a=0x7fff24072170)
    at /usr/src/debug/kdepim-4.3.0/build/kontactinterfaces/uniqueapphandler.moc:73
#10 0x00007f44d6f17354 in QDBusConnectionPrivate::deliverCall (this=0x62b560, object=0x8ee8a0, msg=@0x48af8d0, metaTypes=@0x7fff24072278, slotIdx=4) at qdbusintegrator.cpp:891
#11 0x00007f44d6f1828f in QDBusConnectionPrivate::activateCall (this=0x62b560, object=0x8ee8a0, flags=272, msg=@0x48af8d0) at qdbusintegrator.cpp:796
#12 0x00007f44d6f187e3 in QDBusConnectionPrivate::activateObject (this=0x62b560, node=@0x48af8a8, msg=@0x48af8d0, pathStartPos=25) at qdbusintegrator.cpp:1370
#13 0x00007f44d6f18cd8 in QDBusActivateObjectEvent::placeMetaCall (this=0x48af860) at qdbusintegrator.cpp:1464
#14 0x00007f44d6c0c8a8 in QObject::event (this=0x8ee8a0, e=0x48af860) at kernel/qobject.cpp:1111
#15 0x00007f44d591bb0d in QApplicationPrivate::notify_helper (this=0x643370, receiver=0x8ee8a0, e=0x48af860) at kernel/qapplication.cpp:4056
#16 0x00007f44d5923d9a in QApplication::notify (this=0x7fff24072e20, receiver=0x8ee8a0, e=0x48af860) at kernel/qapplication.cpp:4021
#17 0x00007f44d7a3b71b in KApplication::notify (this=0x7fff24072e20, receiver=0x8ee8a0, event=0x48af860) at /usr/src/debug/kdelibs-4.3.0/kdeui/kernel/kapplication.cpp:302
#18 0x00007f44d6bfc94c in QCoreApplication::notifyInternal (this=0x7fff24072e20, receiver=0x8ee8a0, event=0x48af860) at kernel/qcoreapplication.cpp:610
#19 0x00007f44d6bfd5ca in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60f210) at kernel/qcoreapplication.h:213
#20 0x00007f44d6c260b3 in postEventSourceDispatch (s=<value optimized out>) at kernel/qcoreapplication.h:218
#21 0x00007f44d04d20fb in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f44d04d58cd in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f44d04d5a8b in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f44d6c25d3f in QEventDispatcherGlib::processEvents (this=0x60ea40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#25 0x00007f44d59b2fff in QGuiEventDispatcherGlib::processEvents (this=0x99d220, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#26 0x00007f44d6bfb1d2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 604450112}) at kernel/qeventloop.cpp:149
#27 0x00007f44d6bfb5a4 in QEventLoop::exec (this=0x7fff24072d80, flags={i = 604450192}) at kernel/qeventloop.cpp:201
#28 0x00007f44d6bfd894 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#29 0x0000000000404995 in main (argc=1, argv=0x7fff24073508) at /usr/src/debug/kdepim-4.3.0/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 204000

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-08-19 17:55:38 UTC

*** This bug has been marked as a duplicate of bug 194268 ***