Bug 256534 - Kontact crashed when loading Akregator
Summary: Kontact crashed when loading Akregator
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.5
Platform: OpenSUSE Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-10 17:59 UTC by Janík Tománek
Modified: 2010-11-29 16:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janík Tománek 2010-11-10 17:59:34 UTC
Application: kontact (4.4.5)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
1) I turned the Kontact off.
2) After some time I wanted to read mails, so I tried to start Kmail. Nothing happened and I forgot about it.
3)Then I wanted to see what's new in RSS channels → tried to start Akregator → crash

I am using openSuse 11.3, KDE 4.4.?, style is Bespin. My usually crashes with KDE apps are bespin-related (please fix Bespin, it is the only cool style). :-)

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000002402740 in ?? ()
#6  0x00007fada01a622b in KontactInterface::UniqueAppHandler::newInstance() () from /usr/lib64/libkontactinterface.so.4
#7  0x00007fad87a984ce in ?? () from /usr/lib64/kde4/kontact_akregatorplugin.so
#8  0x00007fada01a6b89 in KontactInterface::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib64/libkontactinterface.so.4
#9  0x00007fada01a8574 in KontactInterface::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkontactinterface.so.4
#10 0x00007fad9c5a0188 in QDBusConnectionPrivate::deliverCall (this=0x62f1e0, object=0x99e0e0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x00007fad9c5a21ae in QDBusConnectionPrivate::activateCall (this=0x62f1e0, object=0x99e0e0, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00007fad9c5a285c in QDBusConnectionPrivate::activateObject (this=0x62f1e0, node=..., msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#13 0x00007fad9c5a2cf8 in QDBusActivateObjectEvent::placeMetaCall (this=0x7fad70075fc0) at qdbusintegrator.cpp:1477
#14 0x00007fad9f09e509 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#15 0x00007fad9e47e4d4 in QApplicationPrivate::notify_helper (this=0x63bdf0, receiver=0x99e0e0, e=0x7fad70075fc0) at kernel/qapplication.cpp:4302
#16 0x00007fad9e486aca in QApplication::notify (this=<value optimized out>, receiver=0x99e0e0, e=0x7fad70075fc0) at kernel/qapplication.cpp:4185
#17 0x00007fad9f96fc06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#18 0x00007fad9f08ce4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#19 0x00007fad9f0905ba in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#20 0x00007fad9f0b5173 in ?? () from /usr/lib64/libQtCore.so.4
#21 0x00007fad96bb5a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fad96bb6270 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fad96bb6510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007fad9f0b567f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#25 0x00007fad9e51f14e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007fad9f08c292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#27 0x00007fad9f08c495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#28 0x00007fad9f09088b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#29 0x000000000040417e in main (argc=1, argv=0x7fff507ec368) at /usr/src/debug/kdepim-4.4.4/kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 255958, bug 255044, bug 255030, bug 255029, bug 254973.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-11-29 16:03:02 UTC

*** This bug has been marked as a duplicate of bug 194268 ***