Bug 205711 - Kontact crashed when clicking on KOrganizer Daemon icon
Summary: Kontact crashed when clicking on KOrganizer Daemon icon
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-30 18:48 UTC by Ben Boeckel
Modified: 2009-09-02 18:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Boeckel 2009-08-30 18:48:54 UTC
Application that crashed: kontact
Version of the application: 4.3.0
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30.5-32.fc11.x86_64 x86_64
Distribution: "Fedora release 11 (Leonidas)"

What I was doing when the application crashed:
While Kontact was starting up (window had yet to appear), I clicked on KOrganizer's tray icon. Kontact promptly crashed.

May be related to #194268 as well.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000003039670 in ?? ()
#6  0x00007fc55e8a362b in QWidget::show (this=<value optimized out>) at /usr/include/QtGui/qwidget.h:473
#7  Kontact::UniqueAppHandler::newInstance (this=<value optimized out>) at /usr/src/debug/kdepim-4.3.0/kontactinterfaces/uniqueapphandler.cpp:137
#8  0x00007fc55e8a36d9 in Kontact::UniqueAppHandler::newInstance (this=0x246f6d0, asn_id=<value optimized out>, args=@0x7f92d70)
    at /usr/src/debug/kdepim-4.3.0/kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00007fc55e8a3744 in Kontact::UniqueAppHandler::qt_metacall (this=0x246f6d0, _c=QMetaObject::InvokeMetaMethod, _id=50613616, _a=0x7fff51f5e310)
    at /usr/src/debug/kdepim-4.3.0/x86_64-redhat-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0x00000035de822f84 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=@0x7fff51f5e408, 
    slotIdx=<value optimized out>) at qdbusintegrator.cpp:891
#11 0x00000035de8240f9 in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x246f6d0, flags=272, msg=@0x242ff90) at qdbusintegrator.cpp:796
#12 0x00000035de82475d in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=@0x242ff68, msg=<value optimized out>, pathStartPos=<value optimized out>)
    at qdbusintegrator.cpp:1370
#13 0x00000035de824c28 in QDBusActivateObjectEvent::placeMetaCall (this=0x242ff20) at qdbusintegrator.cpp:1464
#14 0x00000035dd74f309 in QObject::event (this=0x246f6d0, e=0x242ff20) at kernel/qobject.cpp:1111
#15 0x00000035df18f69c in QApplicationPrivate::notify_helper (this=0x2017c90, receiver=0x246f6d0, e=0x242ff20) at kernel/qapplication.cpp:4056
#16 0x00000035df1966ce in QApplication::notify (this=0x7fff51f5ef20, receiver=0x246f6d0, e=0x242ff20) at kernel/qapplication.cpp:4021
#17 0x00000035e1811296 in KApplication::notify (this=0x7fff51f5ef20, receiver=0x246f6d0, event=0x242ff20) at /usr/src/debug/kdelibs-4.3.0/kdeui/kernel/kapplication.cpp:302
#18 0x00000035dd73fcbc in QCoreApplication::notifyInternal (this=0x7fff51f5ef20, receiver=0x246f6d0, event=0x242ff20) at kernel/qcoreapplication.cpp:610
#19 0x00000035dd7408c8 in QCoreApplication::sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1247
#21 0x00000035dd768743 in QCoreApplication::sendPostedEvents () at kernel/qcoreapplication.h:218
#22 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:210
#23 0x00000035d5a37abe in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#24 0x00000035d5a3b278 in ?? () from /lib64/libglib-2.0.so.0
#25 0x00000035d5a3b3a0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#26 0x00000035dd7683b6 in QEventDispatcherGlib::processEvents (this=0x1fdf130, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#27 0x00000035df22242e in QGuiEventDispatcherGlib::processEvents (this=0x21b5d80, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#28 0x00000035dd73e5f2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 36}) at kernel/qeventloop.cpp:149
#29 0x00000035dd73e9c4 in QEventLoop::exec (this=0x7fff51f5ee60, flags={i = 0}) at kernel/qeventloop.cpp:201
#30 0x00000035dd740b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#31 0x0000000000403d17 in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdepim-4.3.0/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 205334

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-02 04:40:23 UTC
This could be related to bug 194268. Thanks
Comment 2 Christophe Giboudeaux 2009-09-02 18:30:14 UTC

*** This bug has been marked as a duplicate of bug 194268 ***