Bug 245901 - Kontact cannot be started again
Summary: Kontact cannot be started again
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.5
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-27 14:09 UTC by Thoar
Modified: 2010-07-27 16:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thoar 2010-07-27 14:09:30 UTC
Application: kontact (4.4.5)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2"
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
Kontact crashes when restarting it. After starting it for the first time and closing it, Kontact does not load again when trying to restart it.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00770020 in ?? ()
#7  0xb76bbde0 in KontactInterface::Plugin::part (this=0x82b3440) at /usr/src/debug/kdepimlibs-4.4.4/kontactinterface/plugin.cpp:191
#8  0xafc04123 in KMailUniqueAppHandler::newInstance (this=0x82b4938) at /usr/src/debug/kdepim-4.4.4/kontact/plugins/kmail/kmail_plugin.cpp:216
#9  0xb76ba29d in KontactInterface::UniqueAppHandler::newInstance (this=0x82b4938, asn_id=..., args=...) at /usr/src/debug/kdepimlibs-4.4.4/kontactinterface/uniqueapphandler.cpp:129
#10 0xb76bbeec in KontactInterface::UniqueAppHandler::qt_metacall (this=0x82b4938, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc0299c)
    at /usr/src/debug/kdepimlibs-4.4.4/build/kontactinterface/uniqueapphandler.moc:79
#11 0xb55b5a37 in QDBusConnectionPrivate::deliverCall (this=0x806d7f0, object=0x82b4938, msg=..., metaTypes=..., slotIdx=137070392) at qdbusintegrator.cpp:904
#12 0xb55b7be7 in QDBusConnectionPrivate::activateCall (this=0x806d7f0, object=0x82b4938, flags=272, msg=...) at qdbusintegrator.cpp:809
#13 0xb55b8378 in QDBusConnectionPrivate::activateObject (this=0x806d7f0, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#14 0xb55b8878 in QDBusActivateObjectEvent::placeMetaCall (this=0x82bd9d8) at qdbusintegrator.cpp:1477
#15 0xb6dd193f in QObject::event (this=0x82b4938, e=0x82bd9d8) at kernel/qobject.cpp:1248
#16 0xb6313c64 in QApplicationPrivate::notify_helper (this=0x807af48, receiver=0x82b4938, e=0x82bd9d8) at kernel/qapplication.cpp:4302
#17 0xb631bbf7 in QApplication::notify (this=0xbfc03344, receiver=0x82b4938, e=0x82bd9d8) at kernel/qapplication.cpp:3706
#18 0xb725e9d1 in KApplication::notify (this=0xbfc03344, receiver=0x82b4938, event=0x82bd9d8) at /usr/src/debug/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:302
#19 0xb6dbee0e in QCoreApplication::notifyInternal (this=0xbfc03344, receiver=0x82b4938, event=0x82bd9d8) at kernel/qcoreapplication.cpp:726
#20 0xb6dc29b4 in sendEvent (receiver=0x0, event_type=0, data=0x8053380) at kernel/qcoreapplication.h:215
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8053380) at kernel/qcoreapplication.cpp:1367
#22 0xb6dc2b9c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#23 0xb6dea83d in sendPostedEvents (s=0x8077f10) at kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=0x8077f10) at kernel/qeventdispatcher_glib.cpp:276
#25 0xb4261b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0xb4262350 in ?? () from /usr/lib/libglib-2.0.so.0
#27 0xb426260e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#28 0xb6dead4b in QEventDispatcherGlib::processEvents (this=0x8056b50, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#29 0xb63c419a in QGuiEventDispatcherGlib::processEvents (this=0x8056b50, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0xb6dbe11d in QEventLoop::processEvents (this=0xbfc032a4, flags=...) at kernel/qeventloop.cpp:149
#31 0xb6dbe319 in QEventLoop::exec (this=0xbfc032a4, flags=...) at kernel/qeventloop.cpp:201
#32 0xb6dc2c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#33 0xb6311164 in QApplication::exec () at kernel/qapplication.cpp:3581
#34 0x0804b813 in _start ()

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 242078, bug 237446, bug 237352, bug 237094, bug 234172.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-07-27 16:29:51 UTC

*** This bug has been marked as a duplicate of bug 194268 ***