Bug 208319 - kontact crashed while openning after clicking Korganizer Reminder Daemon
Summary: kontact crashed while openning after clicking Korganizer Reminder Daemon
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-23 19:50 UTC by FranJPR
Modified: 2009-09-25 01:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FranJPR 2009-09-23 19:50:25 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-14-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
I clicked on the Korganizer Reminder Daemon and Kontact crashed starting up the bug report assistant. 

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0xa265ee8) at /build/buildd/kdepim-4.3.1/kontactinterfaces/plugin.cpp:186
#7  0xb1afa26a in KOrganizerUniqueAppHandler::newInstance (this=0xa26fad8) at /build/buildd/kdepim-4.3.1/kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0xb7949f39 in Kontact::UniqueAppHandler::newInstance (this=0xa26fad8, asn_id=@0x9f159f8, args=@0x9f19e28) at /build/buildd/kdepim-4.3.1/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb7949fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0xa26fad8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfcd5b38)
    at /build/buildd/kdepim-4.3.1/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5e50e5a in QDBusConnectionPrivate::deliverCall (this=0x9f13138, object=0xa26fad8, msg=@0xad592d8, metaTypes=@0xbfcd5be8, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5e52072 in QDBusConnectionPrivate::activateCall (this=0x9f13138, object=0xa26fad8, flags=272, msg=@0xad592d8) at qdbusintegrator.cpp:796
#12 0xb5e525e1 in QDBusConnectionPrivate::activateObject (this=0x9f13138, node=@0xad592c4, msg=@0xad592d8, pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0xb5e52ada in QDBusActivateObjectEvent::placeMetaCall (this=0xad59298) at qdbusintegrator.cpp:1464
#14 0xb5d493b0 in QObject::event (this=0xa26fad8, e=0xad59298) at kernel/qobject.cpp:1111
#15 0xb61fbd3c in QApplicationPrivate::notify_helper (this=0x9f20de8, receiver=0xa26fad8, e=0xad59298) at kernel/qapplication.cpp:4056
#16 0xb620403e in QApplication::notify (this=0xbfcd63b8, receiver=0xa26fad8, e=0xad59298) at kernel/qapplication.cpp:3603
#17 0xb6df585d in KApplication::notify (this=0xbfcd63b8, receiver=0xa26fad8, event=0xad59298) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#18 0xb5d38bcb in QCoreApplication::notifyInternal (this=0xbfcd63b8, receiver=0xa26fad8, event=0xad59298) at kernel/qcoreapplication.cpp:610
#19 0xb5d39825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9efb440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5d39a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5d646af in postEventSourceDispatch (s=0x9f1c910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4e09b88 in IA__g_main_context_dispatch (context=0x9f1c890) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#23 0xb4e0d0eb in g_main_context_iterate (context=0x9f1c890, block=1, dispatch=1, self=0x9f185e8) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#24 0xb4e0d268 in IA__g_main_context_iteration (context=0x9f1c890, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#25 0xb5d642f8 in QEventDispatcherGlib::processEvents (this=0x9efb028, flags={i = -1077058936}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb629da75 in QGuiEventDispatcherGlib::processEvents (this=0x9efb028, flags={i = -1077058888}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5d371fa in QEventLoop::processEvents (this=0xbfcd6330, flags={i = -1077058824}) at kernel/qeventloop.cpp:149
#28 0xb5d37642 in QEventLoop::exec (this=0xbfcd6330, flags={i = -1077058760}) at kernel/qeventloop.cpp:201
#29 0xb5d39ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb61fbbb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in main (argc=3, argv=0xbfcd66b4) at /build/buildd/kdepim-4.3.1/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-25 01:39:24 UTC
Merging with bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***