Bug 267971 - Clicked a mailto: link, Kontact crashed.
Summary: Clicked a mailto: link, Kontact crashed.
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-08 15:28 UTC by Richard Hartmann
Modified: 2011-03-09 11:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Hartmann 2011-03-08 15:28:05 UTC
Application: kontact (4.4.7)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.6.3
Operating System: Linux 2.6.37-trunk-686 i686
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:

Clicked a mailto: link, Kontact crashed. I don't know what else to tell about this, but the wizard forces me to write more.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#7  0x00310078 in ?? ()
#8  0xb753a8a3 in KontactInterface::Plugin::part() () from /usr/lib/libkontactinterface.so.4
#9  0xaeb24a7d in ?? () from /usr/lib/kde4/kontact_kmailplugin.so
#10 0xb753bb89 in KontactInterface::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterface.so.4
#11 0xb753bc14 in KontactInterface::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterface.so.4
#12 0xb53d3ac1 in QDBusConnectionPrivate::deliverCall (this=0x86b13d8, object=0x8f3f040, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#13 0xb53d4c9f in QDBusConnectionPrivate::activateCall (this=0x86b13d8, object=0x8f3f040, flags=272, msg=...) at qdbusintegrator.cpp:809
#14 0xb53d546c in QDBusConnectionPrivate::activateObject (this=0x86b13d8, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#15 0xb53d59da in QDBusActivateObjectEvent::placeMetaCall (this=0xc205a18) at qdbusintegrator.cpp:1477
#16 0xb6bfbdfe in QObject::event (this=0x8f3f040, e=0xc205a18) at kernel/qobject.cpp:1248
#17 0xb61335cc in QApplicationPrivate::notify_helper (this=0x86bfb78, receiver=0x8f3f040, e=0xc205a18) at kernel/qapplication.cpp:4302
#18 0xb613a15e in QApplication::notify (this=0xbfb67454, receiver=0x8f3f040, e=0xc205a18) at kernel/qapplication.cpp:3706
#19 0xb7186caa in KApplication::notify (this=0xbfb67454, receiver=0x8f3f040, event=0xc205a18) at ../../kdeui/kernel/kapplication.cpp:310
#20 0xb6beb4cb in QCoreApplication::notifyInternal (this=0xbfb67454, receiver=0x8f3f040, event=0xc205a18) at kernel/qcoreapplication.cpp:726
#21 0xb6beef2c in sendEvent (receiver=0x0, event_type=0, data=0x8699dd0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8699dd0) at kernel/qcoreapplication.cpp:1367
#23 0xb6bef0ad in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#24 0xb6c1757f in sendPostedEvents (s=0x86c24d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=0x86c24d0) at kernel/qeventdispatcher_glib.cpp:276
#26 0xb3fe4755 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0xb3fe8d08 in ?? () from /lib/libglib-2.0.so.0
#28 0xb3fe8ee8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0xb6c17075 in QEventDispatcherGlib::processEvents (this=0x8699898, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#30 0xb61f1ed5 in QGuiEventDispatcherGlib::processEvents (this=0x8699898, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0xb6be9ae9 in QEventLoop::processEvents (this=0xbfb673b4, flags=) at kernel/qeventloop.cpp:149
#32 0xb6be9f3a in QEventLoop::exec (this=0xbfb673b4, flags=...) at kernel/qeventloop.cpp:201
#33 0xb6bef16f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#34 0xb6133667 in QApplication::exec () at kernel/qapplication.cpp:3581
#35 0x0804b472 in _start ()

Possible duplicates by query: bug 261042, bug 260348, bug 255958, bug 255044, bug 255030.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-03-09 11:53:32 UTC

*** This bug has been marked as a duplicate of bug 194268 ***