Bug 249430 - Kontact crashed at startup
Summary: Kontact crashed at startup
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-29 18:05 UTC by Ronny Standtke
Modified: 2010-09-19 13:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronny Standtke 2010-08-29 18:05:28 UTC
Application: kontact (4.4.5)
KDE Platform Version: 4.5.00 (KDE 4.5.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Kontact did no longer start from the kickoff menu, so I tried starting kmail from the command line. Then kontact just crashed with the attached backtrace.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb772f950 (LWP 3301))]

Thread 2 (Thread 0xb06f5b70 (LWP 3332)):
#0  0x00a2c344 in __pthread_mutex_unlock_usercnt (mutex=0xa120d54, decr=<value optimized out>) at pthread_mutex_unlock.c:52
#1  0x08c42be6 in pthread_mutex_unlock (mutex=0xa120d54) at forward.c:184
#2  0x01d41ab8 in IA__g_main_context_prepare (context=0xa120d50, priority=0xb06f511c) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2278
#3  0x01d41ee9 in g_main_context_iterate (context=0xa120d50, block=<value optimized out>, dispatch=1, self=0xa11f0b8) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2571
#4  0x01d424b8 in IA__g_main_context_iteration (context=0xa120d50, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#5  0x01f8c1cf in QEventDispatcherGlib::processEvents (this=0xa107918, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x01f5c419 in QEventLoop::processEvents (this=0xb06f5270, flags=) at kernel/qeventloop.cpp:149
#7  0x01f5c89a in QEventLoop::exec (this=0xb06f5270, flags=...) at kernel/qeventloop.cpp:201
#8  0x01e59b5e in QThread::exec (this=0xa1c9670) at thread/qthread.cpp:490
#9  0x01f3b55b in QInotifyFileSystemWatcherEngine::run (this=0xa1c9670) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01e5ce39 in QThreadPrivate::start (arg=0xa1c9670) at thread/qthread_unix.cpp:266
#11 0x00a2896e in start_thread (arg=0xb06f5b70) at pthread_create.c:300
#12 0x08c35a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb772f950 (LWP 3301)):
[KCrash Handler]
#7  0x0abaccda in ?? ()
#8  0x0558b36d in KMailUniqueAppHandler::newInstance (this=0x959ff58) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#9  0x00b80d19 in KontactInterface::UniqueAppHandler::newInstance (this=0x959ff58, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#10 0x00b80da4 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x959ff58, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbffac7ac) at ./uniqueapphandler.moc:79
#11 0x0048e1b4 in QDBusConnectionPrivate::deliverCall (this=0x91a8be0, object=0x959ff58, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:909
#12 0x0048f45f in QDBusConnectionPrivate::activateCall (this=0x91a8be0, object=0x959ff58, flags=272, msg=...) at qdbusintegrator.cpp:812
#13 0x0048fc2c in QDBusConnectionPrivate::activateObject (this=0x91a8be0, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1388
#14 0x004901aa in QDBusActivateObjectEvent::placeMetaCall (this=0xad6a598) at qdbusintegrator.cpp:1482
#15 0x01f70462 in QObject::event (this=0x959ff58, e=0x9710760) at kernel/qobject.cpp:1219
#16 0x00e970cc in QApplicationPrivate::notify_helper (this=0x91bfa78, receiver=0x959ff58, e=0xad6a598) at kernel/qapplication.cpp:4389
#17 0x00e9d11e in QApplication::notify (this=0xbffad1c4, receiver=0x959ff58, e=0xad6a598) at kernel/qapplication.cpp:3791
#18 0x0079582a in KApplication::notify (this=0xbffad1c4, receiver=0x959ff58, event=0xad6a598) at ../../kdeui/kernel/kapplication.cpp:310
#19 0x01f5d96b in QCoreApplication::notifyInternal (this=0xbffad1c4, receiver=0x959ff58, event=0xad6a598) at kernel/qcoreapplication.cpp:732
#20 0x01f60bcb in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x918faf0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x918faf0) at kernel/qcoreapplication.cpp:1373
#22 0x01f60d8d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#23 0x01f8c69f in QCoreApplication::sendPostedEvents (s=0x91b1db8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=0x91b1db8) at kernel/qeventdispatcher_glib.cpp:276
#25 0x01d3e5e5 in g_main_dispatch (context=0x91b1d30) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:1960
#26 IA__g_main_context_dispatch (context=0x91b1d30) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2513
#27 0x01d422d8 in g_main_context_iterate (context=0x91b1d30, block=<value optimized out>, dispatch=1, self=0x91bfca8) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2591
#28 0x01d424b8 in IA__g_main_context_iteration (context=0x91b1d30, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#29 0x01f8c195 in QEventDispatcherGlib::processEvents (this=0x91b0558, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#30 0x00f583b5 in QGuiEventDispatcherGlib::processEvents (this=0x91b0558, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x01f5c419 in QEventLoop::processEvents (this=0xbffad124, flags=) at kernel/qeventloop.cpp:149
#32 0x01f5c89a in QEventLoop::exec (this=0xbffad124, flags=...) at kernel/qeventloop.cpp:201
#33 0x01f60e4f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#34 0x00e95ef7 in QApplication::exec () at kernel/qapplication.cpp:3665
#35 0x0804b472 in main (argc=1, argv=0xbffad3e4) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 249231.

Possible duplicates by query: bug 249231, bug 246527, bug 246414, bug 245901, bug 242078.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-09-19 13:39:52 UTC

*** This bug has been marked as a duplicate of bug 194268 ***