Bug 206002 - Kontact crashes after quitting and launching Korganizer from the menu
Summary: Kontact crashes after quitting and launching Korganizer from the menu
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-02 16:19 UTC by gpetetin
Modified: 2009-09-02 18:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gpetetin 2009-09-02 16:19:23 UTC
Application that crashed: kontact
Version of the application: 4.3.0
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.29.6-217.2.16.fc11.x86_64 x86_64
Distribution: "Fedora release 11 (Leonidas)"

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000000000000 in ?? ()
#6  0x00007f9aba89e62b in Kontact::UniqueAppHandler::newInstance() () from /usr/lib64/libkontactinterfaces.so.4
#7  0x00007f9aba89e6d9 in Kontact::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib64/libkontactinterfaces.so.4
#8  0x00007f9aba89e744 in Kontact::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkontactinterfaces.so.4
#9  0x0000003658822f84 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=@0x22aa560, 
    slotIdx=<value optimized out>) at qdbusintegrator.cpp:891
#10 0x0000003658824153 in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x16da040, flags=272, msg=@0x2554400) at qdbusintegrator.cpp:803
#11 0x000000365882475d in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=@0x25543d8, msg=<value optimized out>, pathStartPos=<value optimized out>)
    at qdbusintegrator.cpp:1370
#12 0x0000003658824c28 in QDBusActivateObjectEvent::placeMetaCall (this=0x2554390) at qdbusintegrator.cpp:1464
#13 0x0000003658d4f309 in QObject::event (this=0x16da040, e=0x2554390) at kernel/qobject.cpp:1111
#14 0x0000003659d8f69c in QApplicationPrivate::notify_helper (this=0x13dc290, receiver=0x16da040, e=0x2554390) at kernel/qapplication.cpp:4056
#15 0x0000003659d966ce in QApplication::notify (this=0x7ffff4440870, receiver=0x16da040, e=0x2554390) at kernel/qapplication.cpp:4021
#16 0x00000031b3611296 in KApplication::notify (this=0x7ffff4440870, receiver=0x16da040, event=0x2554390) at /usr/src/debug/kdelibs-4.3.0/kdeui/kernel/kapplication.cpp:302
#17 0x0000003658d3fcbc in QCoreApplication::notifyInternal (this=0x7ffff4440870, receiver=0x16da040, event=0x2554390) at kernel/qcoreapplication.cpp:610
#18 0x0000003658d408c8 in QCoreApplication::sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#19 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1247
#20 0x0000003658d68743 in QCoreApplication::sendPostedEvents () at kernel/qcoreapplication.h:218
#21 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:210
#22 0x0000003039037abe in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#23 0x000000303903b278 in ?? () from /lib64/libglib-2.0.so.0
#24 0x000000303903b3a0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#25 0x0000003658d683b6 in QEventDispatcherGlib::processEvents (this=0x13a9150, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x0000003659e2242e in QGuiEventDispatcherGlib::processEvents (this=0x1529600, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x0000003658d3e5f2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 36}) at kernel/qeventloop.cpp:149
#28 0x0000003658d3e9c4 in QEventLoop::exec (this=0x7ffff44407b0, flags={i = 0}) at kernel/qeventloop.cpp:201
#29 0x0000003658d40b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x0000000000403d17 in _start ()
Warning: the current language does not match this frame.

This bug may be a duplicate of or related to bug 200968

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-09-02 18:31:41 UTC

*** This bug has been marked as a duplicate of bug 194268 ***