Bug 232851 - Kontact crashes on 4.4.1 when closing Kmail with Ctrl+Q and internet connection not working
Summary: Kontact crashes on 4.4.1 when closing Kmail with Ctrl+Q and internet connecti...
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.1
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-31 15:24 UTC by Andrei Sebastian Cimpean
Modified: 2010-03-31 17:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Sebastian Cimpean 2010-03-31 15:24:48 UTC
Application: kontact (4.4.1)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
My internet connection dropped and I manually reconnected. KMail was unable to get new emails, it seemed that it was unable to reconnect to google, and i closed it, with ctrl+q and an Kontact error message appeared.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00d98350 in QObject::connect (sender=0x92182f0, signal=0x12151d "2destroyed()", receiver=0x9257368, method=0x12150c "1partDestroyed()", type=Qt::AutoConnection) at kernel/qobject.cpp:2518
#7  0x0011db3b in QObject::connect (this=0x9257368) at /usr/include/qt4/QtCore/qobject.h:315
#8  KontactInterface::Plugin::part (this=0x9257368) at ../../kontactinterface/plugin.cpp:193
#9  0x032f6b4d in KMailUniqueAppHandler::newInstance (this=0x925cb98) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#10 0x0011f769 in KontactInterface::UniqueAppHandler::newInstance (this=0x925cb98, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#11 0x0011f7f4 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x925cb98, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff9b64c) at ./uniqueapphandler.moc:79
#12 0x003cace4 in QDBusConnectionPrivate::deliverCall (this=0x8ea24d0, object=0x925cb98, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#13 0x003cbf8f in QDBusConnectionPrivate::activateCall (this=0x8ea24d0, object=0x925cb98, flags=272, msg=...) at qdbusintegrator.cpp:809
#14 0x003cc75c in QDBusConnectionPrivate::activateObject (this=0x8ea24d0, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#15 0x003cccca in QDBusActivateObjectEvent::placeMetaCall (this=0x924f4a8) at qdbusintegrator.cpp:1477
#16 0x00d9663e in QObject::event (this=0x925cb98, e=0x924f4a8) at kernel/qobject.cpp:1248
#17 0x010c93cc in QApplicationPrivate::notify_helper (this=0x8eb0c78, receiver=0x925cb98, e=0x924f4a8) at kernel/qapplication.cpp:4300
#18 0x010d001e in QApplication::notify (this=0xbff9c064, receiver=0x925cb98, e=0x924f4a8) at kernel/qapplication.cpp:3704
#19 0x00a4542a in KApplication::notify (this=0xbff9c064, receiver=0x925cb98, event=0x924f4a8) at ../../kdeui/kernel/kapplication.cpp:302
#20 0x00d85beb in QCoreApplication::notifyInternal (this=0xbff9c064, receiver=0x925cb98, event=0x924f4a8) at kernel/qcoreapplication.cpp:704
#21 0x00d88623 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8e8ab68) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8e8ab68) at kernel/qcoreapplication.cpp:1345
#23 0x00d8878d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#24 0x00db1d0f in QCoreApplication::sendPostedEvents (s=0x8eb3710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=0x8eb3710) at kernel/qeventdispatcher_glib.cpp:276
#26 0x0298be88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x0298f730 in ?? () from /lib/libglib-2.0.so.0
#28 0x0298f863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x00db1805 in QEventDispatcherGlib::processEvents (this=0x8e8a700, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#30 0x01188b35 in QGuiEventDispatcherGlib::processEvents (this=0x8e8a700, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00d84209 in QEventLoop::processEvents (this=0xbff9bfc4, flags=) at kernel/qeventloop.cpp:149
#32 0x00d8465a in QEventLoop::exec (this=0xbff9bfc4, flags=...) at kernel/qeventloop.cpp:201
#33 0x00d8884f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#34 0x010c9467 in QApplication::exec () at kernel/qapplication.cpp:3579
#35 0x0804b4c2 in main (argc=3, argv=0xbff9c284) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 218654.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-03-31 17:58:59 UTC

*** This bug has been marked as a duplicate of bug 194268 ***