Bug 214194 - Kontact crash when click on File-Quit
Summary: Kontact crash when click on File-Quit
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-11 23:52 UTC by Sebastián Ramírez
Modified: 2009-11-12 01:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastián Ramírez 2009-11-11 23:52:13 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Kontact crash when i try close it. 

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x67756c70 in ?? ()
#7  0x03c183bf in AkregatorUniqueAppHandler::newInstance (this=0x89bf7f8) at ../../../../kontact/plugins/akregator/akregator_plugin.cpp:155
#8  0x00eb5ff9 in Kontact::UniqueAppHandler::newInstance (this=0x89bf7f8, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00eb6084 in Kontact::UniqueAppHandler::qt_metacall (this=0x89bf7f8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf85b84c) at ./uniqueapphandler.moc:73
#10 0x007b77b4 in QDBusConnectionPrivate::deliverCall (this=0x860be98, object=0x89bf7f8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x007b895d in QDBusConnectionPrivate::activateCall (this=0x860be98, object=0x89bf7f8, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x007b8fc3 in QDBusConnectionPrivate::activateObject (this=0x860be98, node=..., msg=..., pathStartPos=25) at qdbusintegrator.cpp:1370
#13 0x007b94da in QDBusActivateObjectEvent::placeMetaCall (this=0x8eb0700) at qdbusintegrator.cpp:1464
#14 0x00ca45fe in QObject::event (this=0x89bf7f8, e=0x8eb0700) at kernel/qobject.cpp:1111
#15 0x00fdbf54 in QApplicationPrivate::notify_helper (this=0x8626c40, receiver=0x89bf7f8, e=0x8eb0700) at kernel/qapplication.cpp:4056
#16 0x00fe367c in QApplication::notify (this=0xbf85c194, receiver=0x89bf7f8, e=0x8eb0700) at kernel/qapplication.cpp:3603
#17 0x005d6bfa in KApplication::notify (this=0xbf85c194, receiver=0x89bf7f8, event=0x8eb0700) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00c946cb in QCoreApplication::notifyInternal (this=0xbf85c194, receiver=0x89bf7f8, event=0x8eb0700) at kernel/qcoreapplication.cpp:610
#19 0x00c952b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x85f3820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x85f3820) at kernel/qcoreapplication.cpp:1247
#21 0x00c9547d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x00cbf3ff in QCoreApplication::sendPostedEvents (s=0x8625698) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x8625698) at kernel/qeventdispatcher_glib.cpp:210
#24 0x04156e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x0415a720 in ?? () from /lib/libglib-2.0.so.0
#26 0x0415a853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x00cbf02c in QEventDispatcherGlib::processEvents (this=0x85f39f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x0107cbe5 in QGuiEventDispatcherGlib::processEvents (this=0x85f39f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x00c92c79 in QEventLoop::processEvents (this=0xbf85c0f4, flags=) at kernel/qeventloop.cpp:149
#30 0x00c930ca in QEventLoop::exec (this=0xbf85c0f4, flags=...) at kernel/qeventloop.cpp:201
#31 0x00c9553f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x00fdbdd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4e6 in main (argc=3, argv=0xbf85c3b4) at ../../../kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Jonathan Thomas 2009-11-12 01:51:43 UTC

*** This bug has been marked as a duplicate of bug 194268 ***