Bug 241881 - Kontact crash at launch
Summary: Kontact crash at launch
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-16 07:33 UTC by maxmin88
Modified: 2010-06-17 13:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maxmin88 2010-06-16 07:33:42 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Kontact crashed during launching the program.  This seems to have happened a few times in the past.  I just clicked the program to start and it crashed after a few moments during its launching.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d6990 (LWP 3696))]

Thread 2 (Thread 0xb2bbdb70 (LWP 3724)):
#0  0x0016f422 in __kernel_vsyscall ()
#1  0x007a6b86 in *__GI___poll (fds=0x83cff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x04cf24eb in g_poll () from /lib/libglib-2.0.so.0
#3  0x04ce50ac in ?? () from /lib/libglib-2.0.so.0
#4  0x04ce54b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00bf960f in QEventDispatcherGlib::processEvents (this=0x9d6dde0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x00bcc059 in QEventLoop::processEvents (this=0xb2bbd270, flags=) at kernel/qeventloop.cpp:149
#7  0x00bcc4aa in QEventLoop::exec (this=0xb2bbd270, flags=...) at kernel/qeventloop.cpp:201
#8  0x00ac85a8 in QThread::exec (this=0x9d6b470) at thread/qthread.cpp:487
#9  0x00babc1b in QInotifyFileSystemWatcherEngine::run (this=0x9d6b470) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00acb32e in QThreadPrivate::start (arg=0x9d6b470) at thread/qthread_unix.cpp:248
#11 0x00db196e in start_thread (arg=0xb2bbdb70) at pthread_create.c:300
#12 0x007b4a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77d6990 (LWP 3696)):
[KCrash Handler]
#6  0x00d0772d in QWidget::show (this=0x9cec550) at /usr/include/qt4/QtGui/qwidget.h:485
#7  KontactInterface::UniqueAppHandler::newInstance (this=0x9cec550) at ../../kontactinterface/uniqueapphandler.cpp:138
#8  0x05fc1eb2 in KOrganizerUniqueAppHandler::newInstance (this=0x9cec550) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#9  0x00d077e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x9cec550, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#10 0x00d07874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x9cec550, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb30a2c) at ./uniqueapphandler.moc:79
#11 0x07c37b34 in QDBusConnectionPrivate::deliverCall (this=0x94d32e8, object=0x9cec550, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#12 0x07c38ddf in QDBusConnectionPrivate::activateCall (this=0x94d32e8, object=0x9cec550, flags=272, msg=...) at qdbusintegrator.cpp:809
#13 0x07c395ac in QDBusConnectionPrivate::activateObject (this=0x94d32e8, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1383
#14 0x07c39b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x9523c20) at qdbusintegrator.cpp:1477
#15 0x00bde3fe in QObject::event (this=0x9cec550, e=0x9523c20) at kernel/qobject.cpp:1248
#16 0x015534dc in QApplicationPrivate::notify_helper (this=0x94e0d10, receiver=0x9cec550, e=0x9523c20) at kernel/qapplication.cpp:4300
#17 0x0155a05e in QApplication::notify (this=0xbfb31444, receiver=0x9cec550, e=0x9523c20) at kernel/qapplication.cpp:3704
#18 0x00fc1f2a in KApplication::notify (this=0xbfb31444, receiver=0x9cec550, event=0x9523c20) at ../../kdeui/kernel/kapplication.cpp:302
#19 0x00bcda3b in QCoreApplication::notifyInternal (this=0xbfb31444, receiver=0x9cec550, event=0x9523c20) at kernel/qcoreapplication.cpp:704
#20 0x00bd0473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x94bba60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x94bba60) at kernel/qcoreapplication.cpp:1345
#22 0x00bd05dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#23 0x00bf9adf in QCoreApplication::sendPostedEvents (s=0x94e4f40) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=0x94e4f40) at kernel/qeventdispatcher_glib.cpp:276
#25 0x04ce15e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x04ce52d8 in ?? () from /lib/libglib-2.0.so.0
#27 0x04ce54b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x00bf95d5 in QEventDispatcherGlib::processEvents (this=0x94bb588, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#29 0x01613135 in QGuiEventDispatcherGlib::processEvents (this=0x94bb588, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00bcc059 in QEventLoop::processEvents (this=0xbfb313a4, flags=) at kernel/qeventloop.cpp:149
#31 0x00bcc4aa in QEventLoop::exec (this=0xbfb313a4, flags=...) at kernel/qeventloop.cpp:201
#32 0x00bd069f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#33 0x01553577 in QApplication::exec () at kernel/qapplication.cpp:3579
#34 0x0804b472 in main (argc=1, argv=0xbfb31664) at ../../../kontact/src/main.cpp:224

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-17 13:55:28 UTC

*** This bug has been marked as a duplicate of bug 194268 ***