Bug 240876 - crash after closing kontact and launching korganizer
Summary: crash after closing kontact and launching korganizer
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-06 11:38 UTC by tom
Modified: 2011-02-19 16:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.66 KB, text/plain)
2011-02-19 16:14 UTC, Alessandro Buggin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tom 2010-06-06 11:38:58 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Kubuntu 10.04.
crash after closing kontact and launching korganizer.
After closing kontact, I can't launch kontact again, nor can I launch kmail.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6dac507780 (LWP 1572))]

Thread 2 (Thread 0x7f6d88c4c710 (LWP 1775)):
#0  0x00007f6da210c49c in ?? () from /lib/libglib-2.0.so.0
#1  0x00007f6da210c8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x00007f6daa9c2566 in QEventDispatcherGlib::processEvents (this=0x214b190, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#3  0x00007f6daa997992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#4  0x00007f6daa997d6c in QEventLoop::exec (this=0x7f6d88c4bd90, flags=) at kernel/qeventloop.cpp:201
#5  0x00007f6daa8a1d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#6  0x00007f6daa978178 in QInotifyFileSystemWatcherEngine::run (this=0x2723880) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007f6daa8a4775 in QThreadPrivate::start (arg=0x2723880) at thread/qthread_unix.cpp:248
#8  0x00007f6da46839ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007f6da95e46cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6dac507780 (LWP 1572)):
[KCrash Handler]
#5  0x00007f6dabb6984a in KontactInterface::Plugin::part (this=0x22971b0) at ../../kontactinterface/plugin.cpp:190
#6  0x00007f6d93da37e1 in KOrganizerUniqueAppHandler::newInstance (this=0x229c0c0) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#7  0x00007f6dabb6b0a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x229c0c0, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#8  0x00007f6dabb6b114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x229c0c0, _c=QMetaObject::InvokeMetaMethod, _id=36270512, _a=0x7fffad43bda0) at ./uniqueapphandler.moc:79
#9  0x00007f6da7de5486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#10 0x00007f6da7de66ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x229c0c0, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007f6da7de6f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007f6da7de7468 in QDBusActivateObjectEvent::placeMetaCall (this=0x210e570) at qdbusintegrator.cpp:1477
#13 0x00007f6daa9a8d49 in QObject::event (this=0x229c0c0, e=0x210e570) at kernel/qobject.cpp:1248
#14 0x00007f6da9d5222c in QApplicationPrivate::notify_helper (this=0x1dcd9f0, receiver=0x229c0c0, e=0x210e570) at kernel/qapplication.cpp:4300
#15 0x00007f6da9d586fb in QApplication::notify (this=0x7fffad43cb20, receiver=0x229c0c0, e=0x210e570) at kernel/qapplication.cpp:4183
#16 0x00007f6dab381526 in KApplication::notify (this=0x7fffad43cb20, receiver=0x229c0c0, event=0x210e570) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f6daa99906c in QCoreApplication::notifyInternal (this=0x7fffad43cb20, receiver=0x229c0c0, event=0x210e570) at kernel/qcoreapplication.cpp:704
#18 0x00007f6daa99b7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1da1620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1da1620) at kernel/qcoreapplication.cpp:1345
#20 0x00007f6daa9c29d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007f6da21088c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f6da210c748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f6da210c8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f6daa9c2513 in QEventDispatcherGlib::processEvents (this=0x1da0d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007f6da9e0246e in QGuiEventDispatcherGlib::processEvents (this=0x22971b0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f6daa997992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f6daa997d6c in QEventLoop::exec (this=0x7fffad43ca60, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f6daa99baab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 235846.

Possible duplicates by query: bug 239984, bug 235846, bug 235668, bug 234971, bug 218747.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-06 15:23:31 UTC

*** This bug has been marked as a duplicate of bug 194268 ***
Comment 2 Alessandro Buggin 2011-02-19 16:14:37 UTC
Created attachment 57377 [details]
New crash information added by DrKonqi

kontact (4.6 beta3) on KDE Platform 4.6.41 (4.7 >= 20110106) using Qt 4.7.1

- What I was doing when the application crashed:
i close kontact and then reopened only korganizer from Alt+F2
than it crashed
- Unusual behavior I noticed:

- Custom settings of the application:
x86
REPO:
#kde-snapshot
#testing
#community-testing

-- Backtrace (Reduced):
#7  0xb77a74f0 in KontactInterface::Plugin::part (this=0x979b670) at /home/build/build/i686/kdepimlibs/src/kdepimlibs/kontactinterface/plugin.cpp:190
#8  0xafcea9e7 in KOrganizerUniqueAppHandler::newInstance (this=0x97b9bf8) at /home/build/build/i686/kdepim/src/kdepim/kontact/plugins/korganizer/korg_uniqueapp.cpp:41
#9  0xb77a8d69 in KontactInterface::UniqueAppHandler::newInstance (this=0x97b9bf8, asn_id=..., args=...) at /home/build/build/i686/kdepimlibs/src/kdepimlibs/kontactinterface/uniqueapphandler.cpp:129
#10 0xb77a8e34 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x97b9bf8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf9afcc4) at /home/build/build/i686/kdepimlibs/src/build/kontactinterface/uniqueapphandler.moc:79
[...]
#15 0xb65c492f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4