Bug 206448 - crash while starting kmail
Summary: crash while starting kmail
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-06 03:59 UTC by p92
Modified: 2009-09-06 10:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p92 2009-09-06 03:59:52 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-11-generic i686
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x8cc7fe8) at /build/buildd/kdepim-4.3.1/kontactinterfaces/plugin.cpp:186
#7  0xb156422e in KMailUniqueAppHandler::newInstance (this=0x8ccade0) at /build/buildd/kdepim-4.3.1/kontact/plugins/kmail/kmail_plugin.cpp:208
#8  0xb77c4f39 in Kontact::UniqueAppHandler::newInstance (this=0x8ccade0, asn_id=@0x8e0e928, args=@0x8d97d28) at /build/buildd/kdepim-4.3.1/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb77c4fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x8ccade0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfe52ca8)
    at /build/buildd/kdepim-4.3.1/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5ccbe5a in QDBusConnectionPrivate::deliverCall (this=0x8944130, object=0x8ccade0, msg=@0xb751df0, metaTypes=@0xbfe52d58, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5ccd072 in QDBusConnectionPrivate::activateCall (this=0x8944130, object=0x8ccade0, flags=272, msg=@0xb751df0) at qdbusintegrator.cpp:796
#12 0xb5ccd5e1 in QDBusConnectionPrivate::activateObject (this=0x8944130, node=@0xb751ddc, msg=@0xb751df0, pathStartPos=21) at qdbusintegrator.cpp:1370
#13 0xb5ccdada in QDBusActivateObjectEvent::placeMetaCall (this=0xb751db0) at qdbusintegrator.cpp:1464
#14 0xb5bc43b0 in QObject::event (this=0x8ccade0, e=0xb751db0) at kernel/qobject.cpp:1111
#15 0xb6076d3c in QApplicationPrivate::notify_helper (this=0x894b970, receiver=0x8ccade0, e=0xb751db0) at kernel/qapplication.cpp:4056
#16 0xb607f03e in QApplication::notify (this=0xbfe53528, receiver=0x8ccade0, e=0xb751db0) at kernel/qapplication.cpp:3603
#17 0xb6c7085d in KApplication::notify (this=0xbfe53528, receiver=0x8ccade0, event=0xb751db0) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#18 0xb5bb3bcb in QCoreApplication::notifyInternal (this=0xbfe53528, receiver=0x8ccade0, event=0xb751db0) at kernel/qcoreapplication.cpp:610
#19 0xb5bb4825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x892c440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5bb4a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5bdf6af in postEventSourceDispatch (s=0x8952a80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4c84b88 in IA__g_main_context_dispatch (context=0x8952a00) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#23 0xb4c880eb in g_main_context_iterate (context=0x8952a00, block=1, dispatch=1, self=0x8959438) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#24 0xb4c88268 in IA__g_main_context_iteration (context=0x8952a00, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#25 0xb5bdf2f8 in QEventDispatcherGlib::processEvents (this=0x892c028, flags={i = -1075497992}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb6118a75 in QGuiEventDispatcherGlib::processEvents (this=0x892c028, flags={i = -1075497944}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5bb21fa in QEventLoop::processEvents (this=0xbfe534a0, flags={i = -1075497880}) at kernel/qeventloop.cpp:149
#28 0xb5bb2642 in QEventLoop::exec (this=0xbfe534a0, flags={i = -1075497816}) at kernel/qeventloop.cpp:201
#29 0xb5bb4ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb6076bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in main (argc=3, argv=0xbfe53824) at /build/buildd/kdepim-4.3.1/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 194268

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-09-06 10:33:31 UTC

*** This bug has been marked as a duplicate of bug 194268 ***