Bug 220020 - Kontact crashed by clicking on KOrganizer-Icon in the tray
Summary: Kontact crashed by clicking on KOrganizer-Icon in the tray
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-25 03:04 UTC by Pogo_Dick
Modified: 2010-03-28 04:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pogo_Dick 2009-12-25 03:04:57 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I last used Akregator within Kontact. Kontact was configurerd to be invisibly minimized to tray and become visible when e.g. KMail received new Mails. I wanted to open Kontact by clicking on the KOrganizer-Icon in the tray, then Kontact crashed. KOrganizer was further running in the tray excluded from Kontact.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x00007fddbf3cbcca in Kontact::Plugin::part (this=0x2536350) at ../../kontactinterfaces/plugin.cpp:186
#6  0x00007fdda92f6bf1 in KOrganizerUniqueAppHandler::newInstance (this=0x25288c0) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#7  0x00007fddbf3ce0f9 in Kontact::UniqueAppHandler::newInstance (this=0x25288c0, asn_id=<value optimized out>, args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#8  0x00007fddbf3ce164 in Kontact::UniqueAppHandler::qt_metacall (this=0x25288c0, _c=QMetaObject::InvokeMetaMethod, _id=39019344, _a=0x7fffef51f600) at ./uniqueapphandler.moc:73
#9  0x00007fddbb856ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#10 0x00007fddbb857c69 in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x25288c0, flags=272, msg=...) at qdbusintegrator.cpp:796
#11 0x00007fddbb8582d5 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=..., msg=<value optimized out>, pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1370
#12 0x00007fddbb8587c8 in QDBusActivateObjectEvent::placeMetaCall (this=0x2bd3c70) at qdbusintegrator.cpp:1464
#13 0x00007fddbd7360f9 in QObject::event (this=0x25288c0, e=0x2bd3c70) at kernel/qobject.cpp:1111
#14 0x00007fddbe046efc in QApplicationPrivate::notify_helper (this=0x2074b70, receiver=0x25288c0, e=0x2bd3c70) at kernel/qapplication.cpp:4056
#15 0x00007fddbe04e1ce in QApplication::notify (this=0x7fffef520210, receiver=0x25288c0, e=0x2bd3c70) at kernel/qapplication.cpp:4021
#16 0x00007fddbec7dab6 in KApplication::notify (this=0x7fffef520210, receiver=0x25288c0, event=0x2bd3c70) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007fddbd726c2c in QCoreApplication::notifyInternal (this=0x7fffef520210, receiver=0x25288c0, event=0x2bd3c70) at kernel/qcoreapplication.cpp:610
#18 0x00007fddbd72780a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x2041080) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x2041080) at kernel/qcoreapplication.cpp:1247
#20 0x00007fddbd74f533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#22 0x00007fddb6fa0bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007fddb6fa4598 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007fddb6fa46c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007fddbd74f1a6 in QEventDispatcherGlib::processEvents (this=0x2040cb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007fddbe0db4be in QGuiEventDispatcherGlib::processEvents (this=0x2536350, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007fddbd725532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007fddbd725904 in QEventLoop::exec (this=0x7fffef520150, flags=) at kernel/qeventloop.cpp:201
#29 0x00007fddbd727ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x0000000000403f47 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 215512

Reported using DrKonqi
Comment 1 Raphaël Vinet 2009-12-25 09:13:17 UTC
Hi,

See https://bugs.kde.org/show_bug.cgi?id=193514

A+
Raph
Comment 2 Christophe Giboudeaux 2010-03-28 04:17:22 UTC

*** This bug has been marked as a duplicate of bug 194268 ***