Bug 204000 - Kontact crashed while opening after closing and opening previously
Summary: Kontact crashed while opening after closing and opening previously
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-15 23:38 UTC by Kevin Kraft
Modified: 2009-08-16 00:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Kraft 2009-08-15 23:38:06 UTC
Application that crashed: kontact
Version of the application: 4.3.0
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-14-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
Problems seem to have begun since upgrade to KDE 4.3. Opening Kontact after a logout is fine, but if closed and opened again it occasionally crashes.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x99faa18) at /build/buildd/kdepim-4.3.0/kontactinterfaces/plugin.cpp:186
#7  0xb175022e in KMailUniqueAppHandler::newInstance (this=0x99f8e40) at /build/buildd/kdepim-4.3.0/kontact/plugins/kmail/kmail_plugin.cpp:208
#8  0xb790cf39 in Kontact::UniqueAppHandler::newInstance (this=0x99f8e40, asn_id=@0xa4343f0, args=@0xa3b8780) at /build/buildd/kdepim-4.3.0/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb790cfc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x99f8e40, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf8a06d8)
    at /build/buildd/kdepim-4.3.0/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5e16e5a in QDBusConnectionPrivate::deliverCall (this=0x9981f40, object=0x99f8e40, msg=@0xa3ef9c8, metaTypes=@0xbf8a0788, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5e18072 in QDBusConnectionPrivate::activateCall (this=0x9981f40, object=0x99f8e40, flags=272, msg=@0xa3ef9c8) at qdbusintegrator.cpp:796
#12 0xb5e185e1 in QDBusConnectionPrivate::activateObject (this=0x9981f40, node=@0xa3ef9b4, msg=@0xa3ef9c8, pathStartPos=21) at qdbusintegrator.cpp:1370
#13 0xb5e18ada in QDBusActivateObjectEvent::placeMetaCall (this=0xa3ef988) at qdbusintegrator.cpp:1464
#14 0xb5d103b0 in QObject::event (this=0x99f8e40, e=0xa3ef988) at kernel/qobject.cpp:1111
#15 0xb61c0d3c in QApplicationPrivate::notify_helper (this=0x999b5d0, receiver=0x99f8e40, e=0xa3ef988) at kernel/qapplication.cpp:4056
#16 0xb61c903e in QApplication::notify (this=0xbf8a0f58, receiver=0x99f8e40, e=0xa3ef988) at kernel/qapplication.cpp:3603
#17 0xb6db95cd in KApplication::notify (this=0xbf8a0f58, receiver=0x99f8e40, event=0xa3ef988) at /build/buildd/kde4libs-4.3.0/kdeui/kernel/kapplication.cpp:302
#18 0xb5cffbcb in QCoreApplication::notifyInternal (this=0xbf8a0f58, receiver=0x99f8e40, event=0xa3ef988) at kernel/qcoreapplication.cpp:610
#19 0xb5d00825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x996a440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5d00a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5d2b6af in postEventSourceDispatch (s=0x999dd20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4dd1b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4dd50eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4dd5268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5d2b2f8 in QEventDispatcherGlib::processEvents (this=0x996a028, flags={i = -1081471448}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb6262a75 in QGuiEventDispatcherGlib::processEvents (this=0x996a028, flags={i = -1081471400}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5cfe1fa in QEventLoop::processEvents (this=0xbf8a0ed0, flags={i = -1081471336}) at kernel/qeventloop.cpp:149
#28 0xb5cfe642 in QEventLoop::exec (this=0xbf8a0ed0, flags={i = -1081471272}) at kernel/qeventloop.cpp:201
#29 0xb5d00ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb61c0bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in main (argc=1, argv=0xbf8a1254) at /build/buildd/kdepim-4.3.0/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-08-16 00:24:08 UTC

*** This bug has been marked as a duplicate of bug 194268 ***