Bug 209791 - kontact quit korganiser system tray
Summary: kontact quit korganiser system tray
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-07 20:01 UTC by Filipe Azevedo
Modified: 2009-10-07 21:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filipe Azevedo 2009-10-07 20:01:18 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic x86_64
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
It seem this bug could have potentially some duplicate entries existing but after checking the backtrace, it seem not in the same object.
Others post show KOrganiser::UniqueAppHandler::newInstance() and this one show Kontact::UniqueAppHandler::newInstance()

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 0 (LWP 9338)]

Thread 3 (Thread 0x7fef15983950 (LWP 9339)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
#1  0x00007fef31325cf7 in QWaitCondition::wait (this=0x2f56758, mutex=0x2f56750, time=30000) at thread/qwaitcondition_unix.cpp:85
#2  0x00007fef3131b929 in QThreadPoolThread::run (this=0x2da69a0) at concurrent/qthreadpool.cpp:140
#3  0x00007fef31324d35 in QThreadPrivate::start (arg=0x2da69a0) at thread/qthread_unix.cpp:188
#4  0x00007fef2d9983ba in start_thread (arg=<value optimized out>) at pthread_create.c:297
#5  0x00007fef3088ffcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fef14d57950 (LWP 9342)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
#1  0x00007fef31325cf7 in QWaitCondition::wait (this=0x2f56758, mutex=0x2f56750, time=30000) at thread/qwaitcondition_unix.cpp:85
#2  0x00007fef3131b929 in QThreadPoolThread::run (this=0x1f88280) at concurrent/qthreadpool.cpp:140
#3  0x00007fef31324d35 in QThreadPrivate::start (arg=0x1f88280) at thread/qthread_unix.cpp:188
#4  0x00007fef2d9983ba in start_thread (arg=<value optimized out>) at pthread_create.c:297
#5  0x00007fef3088ffcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fef36e8a750 (LWP 9338)):
[KCrash Handler]
#5  0x0000000000000000 in ?? ()
#6  0x00007fef35c28f3b in Kontact::UniqueAppHandler::newInstance () from /usr/lib/libkontactinterfaces.so.4
#7  0x00007fef35c28fe2 in Kontact::UniqueAppHandler::newInstance () from /usr/lib/libkontactinterfaces.so.4
#8  0x00007fef35c2905a in Kontact::UniqueAppHandler::qt_metacall () from /usr/lib/libkontactinterfaces.so.4
#9  0x00007fef31728453 in QDBusConnectionPrivate::deliverCall (this=0x16f17c0, object=0x1bc5390, msg=@0x1f46eb0, metaTypes=@0x7fff3eed2548, slotIdx=4) at qdbusintegrator.cpp:891
#10 0x00007fef3172966f in QDBusConnectionPrivate::activateCall (this=0x16f17c0, object=0x1bc5390, flags=272, msg=@0x1f46eb0) at qdbusintegrator.cpp:796
#11 0x00007fef31729bc3 in QDBusConnectionPrivate::activateObject (this=0x16f17c0, node=@0x1f46e88, msg=@0x1f46eb0, pathStartPos=26) at qdbusintegrator.cpp:1370
#12 0x00007fef3172a0b8 in QDBusActivateObjectEvent::placeMetaCall (this=0x1f46e40) at qdbusintegrator.cpp:1464
#13 0x00007fef3141e5d8 in QObject::event (this=0x1bc5390, e=0x1f46e40) at kernel/qobject.cpp:1111
#14 0x00007fef31f8ff4d in QApplicationPrivate::notify_helper (this=0x171ca50, receiver=0x1bc5390, e=0x1f46e40) at kernel/qapplication.cpp:4056
#15 0x00007fef31f9818a in QApplication::notify (this=0x7fff3eed30f0, receiver=0x1bc5390, e=0x1f46e40) at kernel/qapplication.cpp:4021
#16 0x00007fef33394abb in KApplication::notify (this=0x7fff3eed30f0, receiver=0x1bc5390, event=0x1f46e40) at /build/buildd/kde4libs-4.3.2/kdeui/kernel/kapplication.cpp:302
#17 0x00007fef3140e6ac in QCoreApplication::notifyInternal (this=0x7fff3eed30f0, receiver=0x1bc5390, event=0x1f46e40) at kernel/qcoreapplication.cpp:610
#18 0x00007fef3140f31a in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x16d4850) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 0x00007fef31437e03 in postEventSourceDispatch (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#20 0x00007fef2ab5f20a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#21 0x00007fef2ab628e0 in ?? () from /usr/lib/libglib-2.0.so.0
#22 0x00007fef2ab62a7c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#23 0x00007fef31437a8f in QEventDispatcherGlib::processEvents (this=0x16d40a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#24 0x00007fef32028bdf in QGuiEventDispatcherGlib::processEvents (this=0x1872780, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#25 0x00007fef3140cf42 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1055731728}) at kernel/qeventloop.cpp:149
#26 0x00007fef3140d314 in QEventLoop::exec (this=0x7fff3eed3050, flags={i = 1055731808}) at kernel/qeventloop.cpp:201
#27 0x00007fef3140f5e4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#28 0x0000000000404945 in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-10-07 21:04:10 UTC
K*UniqueAppHandler::newInstance depends on the Kontact module that's supposed to be displayed when Kontact starts.

bug 194268 is the "collect them all" report :-)

*** This bug has been marked as a duplicate of bug 194268 ***