Bug 261042 - kontact crash after starting disabled application
Summary: kontact crash after starting disabled application
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-23 08:44 UTC by ancow
Modified: 2010-12-23 09:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ancow 2010-12-23 08:44:01 UTC
Application: kontact (4.4.7)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I disabled akregator in kontact settings, watched it close and get removed from the system tray. After it was gone, I started it separately, which resulted in this crash.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f26855ea9da in KontactInterface::Plugin::part (this=0x1be46e0) at ../../kontactinterface/plugin.cpp:190
#7  0x00007f266332a3c9 in AkregatorUniqueAppHandler::newInstance (this=<value optimized out>) at ../../../../kontact/plugins/akregator/akregator_plugin.cpp:151
#8  0x00007f26855eb9f9 in KontactInterface::UniqueAppHandler::newInstance (this=0x1b76b90, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00007f26855eba64 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x1b76b90, _c=QMetaObject::InvokeMetaMethod, _id=29247200, _a=0x7fff94b34580) at ./uniqueapphandler.moc:79
#10 0x00007f26817910ee in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#11 0x00007f268179236f in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x1b76b90, flags=272, msg=...) at qdbusintegrator.cpp:822
#12 0x00007f2681792bae in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1399
#13 0x00007f2681793108 in QDBusActivateObjectEvent::placeMetaCall (this=0x3adf590) at qdbusintegrator.cpp:1493
#14 0x00007f26836debde in QObject::event (this=0x1b76b90, e=0x1be46e0) at kernel/qobject.cpp:1219
#15 0x00007f2684083fdc in QApplicationPrivate::notify_helper (this=0x16ed7d0, receiver=0x1b76b90, e=0x3adf590) at kernel/qapplication.cpp:4396
#16 0x00007f2684089aed in QApplication::notify (this=0x7fff94b35300, receiver=0x1b76b90, e=0x3adf590) at kernel/qapplication.cpp:4277
#17 0x00007f2684dd7576 in KApplication::notify (this=0x7fff94b35300, receiver=0x1b76b90, event=0x3adf590) at ../../kdeui/kernel/kapplication.cpp:310
#18 0x00007f26836cccdc in QCoreApplication::notifyInternal (this=0x7fff94b35300, receiver=0x1b76b90, event=0x3adf590) at kernel/qcoreapplication.cpp:732
#19 0x00007f26836cfc22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x16b9380) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x16b9380) at kernel/qcoreapplication.cpp:1373
#21 0x00007f26836f9653 in sendPostedEvents (s=0x16e7d80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#22 postEventSourceDispatch (s=0x16e7d80) at kernel/qeventdispatcher_glib.cpp:277
#23 0x00007f267bd1f342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007f267bd232a8 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007f267bd2345c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007f26836f9193 in QEventDispatcherGlib::processEvents (this=0x16b8e90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#27 0x00007f2684136a4e in QGuiEventDispatcherGlib::processEvents (this=0x1be46e0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f26836cba02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007f26836cbdec in QEventLoop::exec (this=0x7fff94b35240, flags=) at kernel/qeventloop.cpp:201
#30 0x00007f26836cfebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#31 0x0000000000403b4e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 248582.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-12-23 09:02:16 UTC

*** This bug has been marked as a duplicate of bug 194268 ***