Bug 198107 - Kmail crashes when trying to startup
Summary: Kmail crashes when trying to startup
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-28 02:51 UTC by Quentin
Modified: 2009-06-28 16:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Quentin 2009-06-28 02:51:01 UTC
Application that crashed: kontact
Version of the application: 4.3.0 pre
KDE Version: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2)) "release 138"
Qt Version: 4.5.1
Operating System: Linux 2.6.27.23-0.1-default x86_64
Distribution: "openSUSE 11.1 (x86_64)"

What I was doing when the application crashed:
Kmail crahsed when trying to open it. This occurred when starting from the icon and commandline, the trace is provided

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x00000000018db6e0 in ?? ()
#6  0x00007fc1065109f9 in Kontact::Plugin::part (this=0xa2f2b0) at /usr/src/debug/kdepim-4.2.90/kontactinterfaces/plugin.cpp:187
#7  0x00007fc0f08413e9 in KMailUniqueAppHandler::newInstance (this=0xa11180) at /usr/src/debug/kdepim-4.2.90/kontact/plugins/kmail/kmail_plugin.cpp:208
#8  0x00007fc106513022 in Kontact::UniqueAppHandler::newInstance (this=0xa11180, asn_id=@0x2b21f10, args=@0x1b0f900) at /usr/src/debug/kdepim-4.2.90/kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00007fc10651309a in Kontact::UniqueAppHandler::qt_metacall (this=0xa11180, _c=QMetaObject::InvokeMetaMethod, _id=24154192, _a=0x7fff0f7b3360)
    at /usr/src/debug/kdepim-4.2.90/build/kontactinterfaces/uniqueapphandler.moc:73
#10 0x00007fc103160324 in ?? () from /usr/lib64/libQtDBus.so.4
#11 0x00007fc10316128f in ?? () from /usr/lib64/libQtDBus.so.4
#12 0x00007fc1031617e3 in ?? () from /usr/lib64/libQtDBus.so.4
#13 0x00007fc103161cd8 in ?? () from /usr/lib64/libQtDBus.so.4
#14 0x00007fc102e562b8 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#15 0x00007fc101b3978d in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#16 0x00007fc101b41a2a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#17 0x00007fc103c8104b in KApplication::notify (this=0x7fff0f7b4010, receiver=0xa11180, event=0x1b60020) at /usr/src/debug/kdelibs-4.2.90/kdeui/kernel/kapplication.cpp:302
#18 0x00007fc102e4615c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#19 0x00007fc102e46dda in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#20 0x00007fc102e6fc13 in ?? () from /usr/lib64/libQtCore.so.4
#21 0x00007fc0fc6ef0fb in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fc0fc6f28cd in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fc0fc6f2a8b in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007fc102e6f89f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#25 0x00007fc101bd0b0f in ?? () from /usr/lib64/libQtGui.so.4
#26 0x00007fc102e449f2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#27 0x00007fc102e44dbd in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#28 0x00007fc102e470a4 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#29 0x0000000000404995 in main (argc=1, argv=0x7fff0f7b46f8) at /usr/src/debug/kdepim-4.2.90/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Dario Andres 2009-06-28 16:29:29 UTC
Thanks

*** This bug has been marked as a duplicate of bug 194268 ***