Bug 237352 - Kontact can not be started twice
Summary: Kontact can not be started twice
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-12 10:35 UTC by fleog
Modified: 2010-06-06 17:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fleog 2010-05-12 10:35:48 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
First start of Kontact : OK
Second start : NOK
Launch Kmail few times may launch the bug report assistant
Kontact could not be closed anymore when the second start is succesfully passed after many attempts.



The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78c7990 (LWP 1428))]

Thread 2 (Thread 0xb14b4b70 (LWP 1630)):
#0  0x08268dda in ?? () from /lib/tls/i686/cmov/libc.so.6
#1  0x0824db70 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x060504eb in g_poll () from /lib/libglib-2.0.so.0
#3  0x060430ac in ?? () from /lib/libglib-2.0.so.0
#4  0x060434b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00fd460f in QEventDispatcherGlib::processEvents (this=0xa65a978, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x00fa7059 in QEventLoop::processEvents (this=0xb14b4270, flags=) at kernel/qeventloop.cpp:149
#7  0x00fa74aa in QEventLoop::exec (this=0xb14b4270, flags=...) at kernel/qeventloop.cpp:201
#8  0x00ea35a8 in QThread::exec (this=0xa8990e0) at thread/qthread.cpp:487
#9  0x00f86c1b in QInotifyFileSystemWatcherEngine::run (this=0xa8990e0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00ea632e in QThreadPrivate::start (arg=0xa8990e0) at thread/qthread_unix.cpp:248
#11 0x07a7f96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x0825ba0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb78c7990 (LWP 1428)):
[KCrash Handler]
#6  0x00931b50 in KontactInterface::Plugin::part (this=0xa2016a8) at ../../kontactinterface/plugin.cpp:190
#7  0x025efa7d in KMailUniqueAppHandler::newInstance (this=0xa1a5fa8) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#8  0x009337e9 in KontactInterface::UniqueAppHandler::newInstance (this=0xa1a5fa8, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00933874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0xa1a5fa8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb5729c) at ./uniqueapphandler.moc:79
#10 0x00849b34 in QDBusConnectionPrivate::deliverCall (this=0x9e4ef50, object=0xa1a5fa8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x0084ae45 in QDBusConnectionPrivate::activateCall (this=0x9e4ef50, object=0xa1a5fa8, flags=272, msg=...) at qdbusintegrator.cpp:816
#12 0x0084b5ac in QDBusConnectionPrivate::activateObject (this=0x9e4ef50, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#13 0x0084bb1a in QDBusActivateObjectEvent::placeMetaCall (this=0xa3e77a0) at qdbusintegrator.cpp:1477
#14 0x00fb93fe in QObject::event (this=0xa1a5fa8, e=0xa3e77a0) at kernel/qobject.cpp:1248
#15 0x06cbc4dc in QApplicationPrivate::notify_helper (this=0x9e5af80, receiver=0xa1a5fa8, e=0xa3e77a0) at kernel/qapplication.cpp:4300
#16 0x06cc305e in QApplication::notify (this=0xbfb57cb4, receiver=0xa1a5fa8, e=0xa3e77a0) at kernel/qapplication.cpp:3704
#17 0x00b17f2a in KApplication::notify (this=0xbfb57cb4, receiver=0xa1a5fa8, event=0xa3e77a0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00fa8a3b in QCoreApplication::notifyInternal (this=0xbfb57cb4, receiver=0xa1a5fa8, event=0xa3e77a0) at kernel/qcoreapplication.cpp:704
#19 0x00fab473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9e374e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9e374e0) at kernel/qcoreapplication.cpp:1345
#21 0x00fab5dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x00fd4adf in QCoreApplication::sendPostedEvents (s=0x9e5e0b8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x9e5e0b8) at kernel/qeventdispatcher_glib.cpp:276
#24 0x0603f5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x060432d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x060434b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x00fd45d5 in QEventDispatcherGlib::processEvents (this=0x9e37070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x06d7c135 in QGuiEventDispatcherGlib::processEvents (this=0x9e37070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00fa7059 in QEventLoop::processEvents (this=0xbfb57c14, flags=) at kernel/qeventloop.cpp:149
#30 0x00fa74aa in QEventLoop::exec (this=0xbfb57c14, flags=...) at kernel/qeventloop.cpp:201
#31 0x00fab69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x06cbc577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in main (argc=3, argv=0xbfb57ed4) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 237094.

Possible duplicates by query: bug 237094, bug 234172, bug 232851.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-06 17:33:35 UTC

*** This bug has been marked as a duplicate of bug 194268 ***