Bug 234172 - Kontact crashed when i start kmail seperately.
Summary: Kontact crashed when i start kmail seperately.
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-12 18:10 UTC by Steffen Koch
Modified: 2010-06-06 17:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Koch 2010-04-12 18:10:00 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
I finished Kontact and started Kmail as a single component. In the backround works the Korganizer memory module.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x0011dae0 in KontactInterface::Plugin::part (this=0x8844148) at ../../kontactinterface/plugin.cpp:190
#7  0x02d38b4d in KMailUniqueAppHandler::newInstance (this=0x88445f8) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#8  0x0011f769 in KontactInterface::UniqueAppHandler::newInstance (this=0x88445f8, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x0011f7f4 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x88445f8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfedf2cc) at ./uniqueapphandler.moc:79
#10 0x00a34ce4 in QDBusConnectionPrivate::deliverCall (this=0x84ab560, object=0x88445f8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x00a35f8f in QDBusConnectionPrivate::activateCall (this=0x84ab560, object=0x88445f8, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00a3675c in QDBusConnectionPrivate::activateObject (this=0x84ab560, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#13 0x00a36cca in QDBusActivateObjectEvent::placeMetaCall (this=0x9dce608) at qdbusintegrator.cpp:1477
#14 0x01fad63e in QObject::event (this=0x88445f8, e=0x9dce608) at kernel/qobject.cpp:1248
#15 0x0139d3cc in QApplicationPrivate::notify_helper (this=0x84b6108, receiver=0x88445f8, e=0x9dce608) at kernel/qapplication.cpp:4300
#16 0x013a401e in QApplication::notify (this=0xbfedfce4, receiver=0x88445f8, e=0x9dce608) at kernel/qapplication.cpp:3704
#17 0x008265ba in KApplication::notify (this=0xbfedfce4, receiver=0x88445f8, event=0x9dce608) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x01f9cbeb in QCoreApplication::notifyInternal (this=0xbfedfce4, receiver=0x88445f8, event=0x9dce608) at kernel/qcoreapplication.cpp:704
#19 0x01f9f623 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8493ae8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8493ae8) at kernel/qcoreapplication.cpp:1345
#21 0x01f9f78d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x01fc8d0f in QCoreApplication::sendPostedEvents (s=0x84ba510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x84ba510) at kernel/qeventdispatcher_glib.cpp:276
#24 0x06a4ce88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x06a50730 in ?? () from /lib/libglib-2.0.so.0
#26 0x06a50863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x01fc8805 in QEventDispatcherGlib::processEvents (this=0x8493680, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x0145cb35 in QGuiEventDispatcherGlib::processEvents (this=0x8493680, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x01f9b209 in QEventLoop::processEvents (this=0xbfedfc44, flags=) at kernel/qeventloop.cpp:149
#30 0x01f9b65a in QEventLoop::exec (this=0xbfedfc44, flags=...) at kernel/qeventloop.cpp:201
#31 0x01f9f84f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x0139d467 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b4c2 in main (argc=1, argv=0xbfedff04) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 232851.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-06 17:34:39 UTC

*** This bug has been marked as a duplicate of bug 194268 ***