Bug 257170 - Kontact crashed
Summary: Kontact crashed
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-17 17:45 UTC by afg2006
Modified: 2010-11-29 14:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description afg2006 2010-11-17 17:45:44 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Kontact was not retrieving the mail from one of my three gmail accounts after repeated attempts, so I closed the program and restarted it. Kontact then only started minimized in the system tray. When I tried to open it via the system tray, it crashed.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb773a990 (LWP 8495))]

Thread 2 (Thread 0xb1f58b70 (LWP 8513)):
#0  0x027bbe16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x00ddb6fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x00de0825 in QTimerInfoList::updateCurrentTime (this=0x9058cf4) at kernel/qeventdispatcher_unix.cpp:340
#3  0x00de086a in QTimerInfoList::timerWait (this=0x9058cf4, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x00dde818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb1f580ac) at kernel/qeventdispatcher_glib.cpp:136
#5  0x00dde8a5 in timerSourcePrepare (source=0x0, timeout=0x27bfff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x04c67aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x04c67ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x04c684b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x00dde60f in QEventDispatcherGlib::processEvents (this=0x9040448, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x00db1059 in QEventLoop::processEvents (this=0xb1f58270, flags=) at kernel/qeventloop.cpp:149
#11 0x00db14aa in QEventLoop::exec (this=0xb1f58270, flags=...) at kernel/qeventloop.cpp:201
#12 0x00cad5a8 in QThread::exec (this=0x8af8150) at thread/qthread.cpp:487
#13 0x00d90c1b in QInotifyFileSystemWatcherEngine::run (this=0x8af8150) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x00cb032e in QThreadPrivate::start (arg=0x8af8150) at thread/qthread_unix.cpp:248
#15 0x083ee96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x02898a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb773a990 (LWP 8495)):
[KCrash Handler]
#6  0x0929027f in ?? ()
#7  0x0784ad7a in ?? () from /usr/lib/kde4/kontact_todoplugin.so
#8  0x004cd7e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x0, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x004cd874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x8c43170, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfe6011c) at ./uniqueapphandler.moc:79
#10 0x00965b34 in QDBusConnectionPrivate::deliverCall (this=0x88e52d0, object=0x8c43170, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x00966e45 in QDBusConnectionPrivate::activateCall (this=0x88e52d0, object=0x8c43170, flags=272, msg=...) at qdbusintegrator.cpp:816
#12 0x009675ac in QDBusConnectionPrivate::activateObject (this=0x88e52d0, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1383
#13 0x00967b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x9b58258) at qdbusintegrator.cpp:1477
#14 0x00dc33fe in QObject::event (this=0x8c43170, e=0x9b58258) at kernel/qobject.cpp:1248
#15 0x00ffd4dc in QApplicationPrivate::notify_helper (this=0x88eda28, receiver=0x8c43170, e=0x9b58258) at kernel/qapplication.cpp:4300
#16 0x0100405e in QApplication::notify (this=0xbfe60b34, receiver=0x8c43170, e=0x9b58258) at kernel/qapplication.cpp:3704
#17 0x006b1f2a in KApplication::notify (this=0xbfe60b34, receiver=0x8c43170, event=0x9b58258) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00db2a3b in QCoreApplication::notifyInternal (this=0xbfe60b34, receiver=0x8c43170, event=0x9b58258) at kernel/qcoreapplication.cpp:704
#19 0x00db5473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x88cda60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x88cda60) at kernel/qcoreapplication.cpp:1345
#21 0x00db55dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x00ddeadf in QCoreApplication::sendPostedEvents (s=0x88f0d90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x88f0d90) at kernel/qeventdispatcher_glib.cpp:276
#24 0x04c645e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x04c682d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x04c684b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x00dde5d5 in QEventDispatcherGlib::processEvents (this=0x88cd588, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x010bd135 in QGuiEventDispatcherGlib::processEvents (this=0x88cd588, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00db1059 in QEventLoop::processEvents (this=0xbfe60a94, flags=) at kernel/qeventloop.cpp:149
#30 0x00db14aa in QEventLoop::exec (this=0xbfe60a94, flags=...) at kernel/qeventloop.cpp:201
#31 0x00db569f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x00ffd577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in _start ()

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 256717, bug 256534, bug 255958, bug 255044, bug 255030.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-11-29 14:20:16 UTC

*** This bug has been marked as a duplicate of bug 194268 ***