Bug 235846 - crash after closing contact and starting korganizer
Summary: crash after closing contact and starting korganizer
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-30 21:07 UTC by Martin Schmidt
Modified: 2010-09-16 09:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (3.64 KB, text/plain)
2010-05-09 06:12 UTC, Matt Wald
Details
New crash information added by DrKonqi (3.79 KB, text/plain)
2010-06-04 04:23 UTC, David Huang
Details
New crash information added by DrKonqi (6.49 KB, text/plain)
2010-09-16 09:47 UTC, Christiaan ter Veen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schmidt 2010-04-30 21:07:27 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
When I close Kontact it is impossible to start it again (not always, but in most cases).
In this case I try to start KOrganizer with the tray icon, and this is when i get this crash.
i have 10.04 but this also happened with 9.10

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2edf322780 (LWP 1884))]

Thread 2 (Thread 0x7f2ebab87710 (LWP 1996)):
#0  0x00007f2edc3fbf53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2ed4f314a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f2ed4f318fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f2edd7e6566 in QEventDispatcherGlib::processEvents (this=0x1512f40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f2edd7bb992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f2edd7bbd6c in QEventLoop::exec (this=0x7f2ebab86d90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f2edd6c5d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f2edd79c178 in QInotifyFileSystemWatcherEngine::run (this=0x11a7a20) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2edd6c8775 in QThreadPrivate::start (arg=0x11a7a20) at thread/qthread_unix.cpp:248
#9  0x00007f2ed74a79ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f2edc40869d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2edf322780 (LWP 1884)):
[KCrash Handler]
#5  0x00007f2ede98d84a in KontactInterface::Plugin::part (this=0xd0bee0) at ../../kontactinterface/plugin.cpp:190
#6  0x00007f2ec6bb47e1 in KOrganizerUniqueAppHandler::newInstance (this=0xd2e220) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#7  0x00007f2ede98f0a9 in KontactInterface::UniqueAppHandler::newInstance (this=0xd2e220, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#8  0x00007f2ede98f114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0xd2e220, _c=QMetaObject::InvokeMetaMethod, _id=13680352, _a=0x7fff3b5f8850) at ./uniqueapphandler.moc:79
#9  0x00007f2edac09486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#10 0x00007f2edac0a6ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0xd2e220, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007f2edac0af0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007f2edac0b468 in QDBusActivateObjectEvent::placeMetaCall (this=0x2564fe0) at qdbusintegrator.cpp:1477
#13 0x00007f2edd7ccd49 in QObject::event (this=0xd2e220, e=0x2564fe0) at kernel/qobject.cpp:1248
#14 0x00007f2edcb7622c in QApplicationPrivate::notify_helper (this=0x76ded0, receiver=0xd2e220, e=0x2564fe0) at kernel/qapplication.cpp:4300
#15 0x00007f2edcb7c6fb in QApplication::notify (this=0x7fff3b5f95d0, receiver=0xd2e220, e=0x2564fe0) at kernel/qapplication.cpp:4183
#16 0x00007f2ede1a5526 in KApplication::notify (this=0x7fff3b5f95d0, receiver=0xd2e220, event=0x2564fe0) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f2edd7bd06c in QCoreApplication::notifyInternal (this=0x7fff3b5f95d0, receiver=0xd2e220, event=0x2564fe0) at kernel/qcoreapplication.cpp:704
#18 0x00007f2edd7bf7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x736620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x736620) at kernel/qcoreapplication.cpp:1345
#20 0x00007f2edd7e69d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007f2ed4f2d8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f2ed4f31748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f2ed4f318fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f2edd7e6513 in QEventDispatcherGlib::processEvents (this=0x735d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007f2edcc2646e in QGuiEventDispatcherGlib::processEvents (this=0xd0bee0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f2edd7bb992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f2edd7bbd6c in QEventLoop::exec (this=0x7fff3b5f9510, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f2edd7bfaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 235668, bug 234971, bug 218747, bug 194268.

Reported using DrKonqi
Comment 1 Matt Wald 2010-05-09 06:12:47 UTC
Created attachment 43383 [details]
New crash information added by DrKonqi

You open Kmail and it freezes and crashes.
Comment 2 David Huang 2010-06-04 04:23:48 UTC
Created attachment 47659 [details]
New crash information added by DrKonqi

I did exactly the same as the bug reporter said: 1. It takes a long time to get emails, so I quit kontact. 2. start kontact again, but kontact won't show up. 3. start  korganizer by clicking the system tray, then crashed.
Comment 3 Christophe Giboudeaux 2010-06-06 15:24:50 UTC

*** This bug has been marked as a duplicate of bug 194268 ***
Comment 4 Christiaan ter Veen 2010-09-16 09:47:13 UTC
Created attachment 51703 [details]
New crash information added by DrKonqi

It's the same situation as the original poster currently in Kubuntu 10.04 LTS but it also occured in 9.10. When I boot my computer and start Kontact, the KOrganizer Reminder Daemon also starts and everything works fine except for akonadi that can't find any useragents and thus is blocking the Addressbook. After that I close Kontact and the KOrganizer Reminder Daemon keeps running.

When I try to reopen Kontact it doesn't show up, I have to click the KOrganizer Reminder Daemon after which it crashes and generates attached bug report. After closing I can start Kontact again and everything (including akonadi) seems to work fine again.

Closing the KOrganizer Reminder Daemon from the System Tray doesn't prevent the error.