Bug 249231 - kontact crashes when kmail is opened
Summary: kontact crashes when kmail is opened
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-27 15:12 UTC by Jon Ringle
Modified: 2010-09-19 13:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Ringle 2010-08-27 15:12:01 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic-pae i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
First time I tried opening kmail, kontact crashed. A subsequent attempt to open kmail resulted in no crash.

The crash does not seem to be reproducible.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb35de990 (LWP 26797))]

Thread 2 (Thread 0xae63eb70 (LWP 26865)):
#0  0xb410d79f in g_main_context_check () from /lib/libglib-2.0.so.0
#1  0xb410e0ce in ?? () from /lib/libglib-2.0.so.0
#2  0xb410e4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0xb6cbf60f in QEventDispatcherGlib::processEvents (this=0xadd00468, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#4  0xb6c92059 in QEventLoop::processEvents (this=0xae63e270, flags=) at kernel/qeventloop.cpp:149
#5  0xb6c924aa in QEventLoop::exec (this=0xae63e270, flags=...) at kernel/qeventloop.cpp:201
#6  0xb6b8e5a8 in QThread::exec (this=0xa1c2fd0) at thread/qthread.cpp:487
#7  0xb6c71c1b in QInotifyFileSystemWatcherEngine::run (this=0xa1c2fd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0xb6b9132e in QThreadPrivate::start (arg=0xa1c2fd0) at thread/qthread_unix.cpp:248
#9  0xb43fb96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0xb5f10a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb35de990 (LWP 26797)):
[KCrash Handler]
#6  0xb7579b50 in KontactInterface::Plugin::part (this=0xa0dfd90) at ../../kontactinterface/plugin.cpp:190
#7  0xafe0ba7d in KMailUniqueAppHandler::newInstance (this=0xa0f8c20) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#8  0xb757b7e9 in KontactInterface::UniqueAppHandler::newInstance (this=0xa0f8c20, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0xb757b874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0xa0f8c20, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfe697ec) at ./uniqueapphandler.moc:79
#10 0xb5471b34 in QDBusConnectionPrivate::deliverCall (this=0x9d61d60, object=0xa0f8c20, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0xb5472ddf in QDBusConnectionPrivate::activateCall (this=0x9d61d60, object=0xa0f8c20, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0xb54735ac in QDBusConnectionPrivate::activateObject (this=0x9d61d60, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#13 0xb5473b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x9ecb4b0) at qdbusintegrator.cpp:1477
#14 0xb6ca43fe in QObject::event (this=0xa0f8c20, e=0x9ecb4b0) at kernel/qobject.cpp:1248
#15 0xb61e34dc in QApplicationPrivate::notify_helper (this=0x9d6ad90, receiver=0xa0f8c20, e=0x9ecb4b0) at kernel/qapplication.cpp:4300
#16 0xb61ea05e in QApplication::notify (this=0xbfe6a204, receiver=0xa0f8c20, e=0x9ecb4b0) at kernel/qapplication.cpp:3704
#17 0xb71e4f2a in KApplication::notify (this=0xbfe6a204, receiver=0xa0f8c20, event=0x9ecb4b0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0xb6c93a3b in QCoreApplication::notifyInternal (this=0xbfe6a204, receiver=0xa0f8c20, event=0x9ecb4b0) at kernel/qcoreapplication.cpp:704
#19 0xb6c96473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9d4a4e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9d4a4e0) at kernel/qcoreapplication.cpp:1345
#21 0xb6c965dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0xb6cbfadf in QCoreApplication::sendPostedEvents (s=0x9d70710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x9d70710) at kernel/qeventdispatcher_glib.cpp:276
#24 0xb410a5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0xb410e2d8 in ?? () from /lib/libglib-2.0.so.0
#26 0xb410e4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0xb6cbf5d5 in QEventDispatcherGlib::processEvents (this=0x9d4a070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0xb62a3135 in QGuiEventDispatcherGlib::processEvents (this=0x9d4a070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0xb6c92059 in QEventLoop::processEvents (this=0xbfe6a164, flags=) at kernel/qeventloop.cpp:149
#30 0xb6c924aa in QEventLoop::exec (this=0xbfe6a164, flags=...) at kernel/qeventloop.cpp:201
#31 0xb6c9669f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0xb61e3577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in main (argc=1, argv=0xbfe6a424) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 246527, bug 246414, bug 245901, bug 242078, bug 237446.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-09-19 13:40:55 UTC

*** This bug has been marked as a duplicate of bug 194268 ***