Bug 229766 - KMail crashes Kontact
Summary: KMail crashes Kontact
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.1
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-07 06:17 UTC by happy
Modified: 2010-03-26 01:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description happy 2010-03-07 06:17:31 UTC
Application: kontact (4.4.1)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic-pae i686
Distribution: Ubuntu 9.10

-- Information about the crash:
When (accidentally) launching a duplicate KMail, existing instance crashes always, especially if process was embedded in Kontact

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0xb7616ae0 in KontactInterface::Plugin::part() () from /usr/lib/libkontactinterface.so.4
#7  0xaff1cb4d in ?? () from /usr/lib/kde4/kontact_kmailplugin.so
#8  0xb7618769 in KontactInterface::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterface.so.4
#9  0xb76187f4 in KontactInterface::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterface.so.4
#10 0xb553fce4 in QDBusConnectionPrivate::deliverCall (this=0x95dd2e0, object=0x98ee7e0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0xb5540f8f in QDBusConnectionPrivate::activateCall (this=0x95dd2e0, object=0x98ee7e0, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0xb554175c in QDBusConnectionPrivate::activateObject (this=0x95dd2e0, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#13 0xb5541cca in QDBusActivateObjectEvent::placeMetaCall (this=0xa12f478) at qdbusintegrator.cpp:1477
#14 0xb6d3b63e in QObject::event (this=0x98ee7e0, e=0xa12f478) at kernel/qobject.cpp:1248
#15 0xb627b3cc in QApplicationPrivate::notify_helper (this=0x95e4d48, receiver=0x98ee7e0, e=0xa12f478) at kernel/qapplication.cpp:4300
#16 0xb628201e in QApplication::notify (this=0xbfd4ef44, receiver=0x98ee7e0, e=0xa12f478) at kernel/qapplication.cpp:3704
#17 0xb728242a in KApplication::notify (this=0xbfd4ef44, receiver=0x98ee7e0, event=0xa12f478) at ../../kdeui/kernel/kapplication.cpp:302
#18 0xb6d2abeb in QCoreApplication::notifyInternal (this=0xbfd4ef44, receiver=0x98ee7e0, event=0xa12f478) at kernel/qcoreapplication.cpp:704
#19 0xb6d2d623 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x95c5b68) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x95c5b68) at kernel/qcoreapplication.cpp:1345
#21 0xb6d2d78d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0xb6d56d0f in QCoreApplication::sendPostedEvents (s=0x95ea110) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x95ea110) at kernel/qeventdispatcher_glib.cpp:276
#24 0xb41c7e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0xb41cb730 in ?? () from /lib/libglib-2.0.so.0
#26 0xb41cb863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0xb6d56805 in QEventDispatcherGlib::processEvents (this=0x95c5700, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0xb633ab35 in QGuiEventDispatcherGlib::processEvents (this=0x95c5700, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0xb6d29209 in QEventLoop::processEvents (this=0xbfd4eea4, flags=) at kernel/qeventloop.cpp:149
#30 0xb6d2965a in QEventLoop::exec (this=0xbfd4eea4, flags=...) at kernel/qeventloop.cpp:201
#31 0xb6d2d84f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0xb627b467 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b4c2 in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-03-26 01:16:15 UTC

*** This bug has been marked as a duplicate of bug 194268 ***