Bug 252373 - Kontact doesn't "close" and crashed when restarted.
Summary: Kontact doesn't "close" and crashed when restarted.
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-25 20:14 UTC by Justin
Modified: 2010-09-25 21:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin 2010-09-25 20:14:45 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
This happens about 50% of the time. When I close Kontact and later try to open it agan it either won't open (The icon bounces and a program tag opens at the bottom but after a bit both close and either nothing happens at all or I get a crash report. However either way, if I go to System Activity Kontact is still listed as a process and if I force kill it it will load normal next time it's clicked. If I go to System Activity right now, even after this crash report, it shows Kontact as "stopped". 

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f39dfbf2780 (LWP 1941))]

Thread 2 (Thread 0x7f39bcb7e710 (LWP 2022)):
#0  0x00007f39dccc5f83 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f39d57fa4a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f39d57fa8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f39de0b1566 in QEventDispatcherGlib::processEvents (this=0x2b59ef0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f39de086992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f39de086d6c in QEventLoop::exec (this=0x7f39bcb7dd90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f39ddf90d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f39de067178 in QInotifyFileSystemWatcherEngine::run (this=0x2b59360) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f39ddf93775 in QThreadPrivate::start (arg=0x2b59360) at thread/qthread_unix.cpp:248
#9  0x00007f39d7d719ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f39dccd26fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f39dfbf2780 (LWP 1941)):
[KCrash Handler]
#5  0xffffffff61746167 in ?? ()
#6  0x00007f39df259ffb in QWidget::show (this=0x26419c0) at /usr/include/qt4/QtGui/qwidget.h:485
#7  KontactInterface::UniqueAppHandler::newInstance (this=0x26419c0) at ../../kontactinterface/uniqueapphandler.cpp:138
#8  0x00007f39df25a0a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x26419c0, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00007f39df25a114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x26419c0, _c=QMetaObject::InvokeMetaMethod, _id=39984608, _a=0x7fffd50da9a0) at ./uniqueapphandler.moc:79
#10 0x00007f39db4d3486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#11 0x00007f39db4d46ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x26419c0, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00007f39db4d4f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#13 0x00007f39db4d5468 in QDBusActivateObjectEvent::placeMetaCall (this=0x2996670) at qdbusintegrator.cpp:1477
#14 0x00007f39de097d49 in QObject::event (this=0x26419c0, e=0x2996670) at kernel/qobject.cpp:1248
#15 0x00007f39dd44122c in QApplicationPrivate::notify_helper (this=0x20f9de0, receiver=0x26419c0, e=0x2996670) at kernel/qapplication.cpp:4300
#16 0x00007f39dd4476fb in QApplication::notify (this=0x7fffd50db720, receiver=0x26419c0, e=0x2996670) at kernel/qapplication.cpp:4183
#17 0x00007f39dea70526 in KApplication::notify (this=0x7fffd50db720, receiver=0x26419c0, event=0x2996670) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f39de08806c in QCoreApplication::notifyInternal (this=0x7fffd50db720, receiver=0x26419c0, event=0x2996670) at kernel/qcoreapplication.cpp:704
#19 0x00007f39de08a7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x20ce620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x20ce620) at kernel/qcoreapplication.cpp:1345
#21 0x00007f39de0b19d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#22 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#23 0x00007f39d57f68c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007f39d57fa748 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007f39d57fa8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007f39de0b1513 in QEventDispatcherGlib::processEvents (this=0x20cdd70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#27 0x00007f39dd4f146e in QGuiEventDispatcherGlib::processEvents (this=0x20fa110, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f39de086992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007f39de086d6c in QEventLoop::exec (this=0x7fffd50db660, flags=) at kernel/qeventloop.cpp:201
#30 0x00007f39de08aaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#31 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 241881, bug 231080.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-09-25 21:40:27 UTC
Merging with bug 194268.

As you can reproduce this quite easily, please read https://bugs.kde.org/show_bug.cgi?id=194268#c96

*** This bug has been marked as a duplicate of bug 194268 ***