Bug 237446 - Kontact does not open contacts on startup, after it is closed and reopened, kontact is unable to start
Summary: Kontact does not open contacts on startup, after it is closed and reopened, k...
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-13 00:01 UTC by FranJPR
Modified: 2010-06-06 17:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FranJPR 2010-05-13 00:01:44 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
When the pc starts, kontact does not show contacts due to a problem with akonadi. I close kontact and open it again and it is unable to open. I open kmail and the this crash report is generated. After the crash, kontact can be opened normally.



The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b1990 (LWP 1529))]

Thread 2 (Thread 0xb2319b70 (LWP 1605)):
#0  0x00badf5b in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#1  0x06ed0b66 in pthread_mutex_lock () from /lib/tls/i686/cmov/libc.so.6
#2  0x021ee7c8 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x021ef0ce in ?? () from /lib/libglib-2.0.so.0
#4  0x021ef4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0110860f in QEventDispatcherGlib::processEvents (this=0x91d7bc8, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x010db059 in QEventLoop::processEvents (this=0xb2319270, flags=) at kernel/qeventloop.cpp:149
#7  0x010db4aa in QEventLoop::exec (this=0xb2319270, flags=...) at kernel/qeventloop.cpp:201
#8  0x00fd75a8 in QThread::exec (this=0x9148658) at thread/qthread.cpp:487
#9  0x010bac1b in QInotifyFileSystemWatcherEngine::run (this=0x9148658) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00fda32e in QThreadPrivate::start (arg=0x9148658) at thread/qthread_unix.cpp:248
#11 0x00bab96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x06ec3a0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77b1990 (LWP 1529)):
[KCrash Handler]
#6  0x00d11b50 in KontactInterface::Plugin::part (this=0x89a2378) at ../../kontactinterface/plugin.cpp:190
#7  0x02b9fa7d in KMailUniqueAppHandler::newInstance (this=0x8974fe8) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#8  0x00d137e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x8974fe8, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00d13874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x8974fe8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc6a1dc) at ./uniqueapphandler.moc:79
#10 0x00ca9b34 in QDBusConnectionPrivate::deliverCall (this=0x8690d58, object=0x8974fe8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x00caaddf in QDBusConnectionPrivate::activateCall (this=0x8690d58, object=0x8974fe8, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00cab5ac in QDBusConnectionPrivate::activateObject (this=0x8690d58, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#13 0x00cabb1a in QDBusActivateObjectEvent::placeMetaCall (this=0x8d56f60) at qdbusintegrator.cpp:1477
#14 0x010ed3fe in QObject::event (this=0x8974fe8, e=0x8d56f60) at kernel/qobject.cpp:1248
#15 0x013274dc in QApplicationPrivate::notify_helper (this=0x869d938, receiver=0x8974fe8, e=0x8d56f60) at kernel/qapplication.cpp:4300
#16 0x0132e05e in QApplication::notify (this=0xbfc6abf4, receiver=0x8974fe8, e=0x8d56f60) at kernel/qapplication.cpp:3704
#17 0x0049ff2a in KApplication::notify (this=0xbfc6abf4, receiver=0x8974fe8, event=0x8d56f60) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x010dca3b in QCoreApplication::notifyInternal (this=0xbfc6abf4, receiver=0x8974fe8, event=0x8d56f60) at kernel/qcoreapplication.cpp:704
#19 0x010df473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x86794e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x86794e0) at kernel/qcoreapplication.cpp:1345
#21 0x010df5dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x01108adf in QCoreApplication::sendPostedEvents (s=0x869f790) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x869f790) at kernel/qeventdispatcher_glib.cpp:276
#24 0x021eb5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x021ef2d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x021ef4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x011085d5 in QEventDispatcherGlib::processEvents (this=0x8679070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x013e7135 in QGuiEventDispatcherGlib::processEvents (this=0x8679070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x010db059 in QEventLoop::processEvents (this=0xbfc6ab54, flags=) at kernel/qeventloop.cpp:149
#30 0x010db4aa in QEventLoop::exec (this=0xbfc6ab54, flags=...) at kernel/qeventloop.cpp:201
#31 0x010df69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x01327577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in main (argc=1, argv=0xbfc6ae14) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 237352, bug 237094, bug 234172.

Possible duplicates by query: bug 237352, bug 237094, bug 234172, bug 232851.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-06 17:36:19 UTC

*** This bug has been marked as a duplicate of bug 194268 ***