Bug 268954 - Kontakt crashes sometimes unexpected
Summary: Kontakt crashes sometimes unexpected
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-20 12:26 UTC by Robin Dieker
Modified: 2011-03-21 11:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Dieker 2011-03-20 12:26:47 UTC
Application: kontact (4.4.6)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
I havent done anything. I just used Kubuntu as normal and suddenly it crashed. 

Also, if I start Kopete, Kontact also opens. I dont know why that happens.

And, a Suggestion, a Google Synchronisation Possibility for Kontact Calendar and Contacts would be great!


Thanks

Robin Dieker

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7859730 (LWP 1629))]

Thread 2 (Thread 0xb1cbdb70 (LWP 1634)):
#0  0x00cd4416 in __kernel_vsyscall ()
#1  0x009a9df6 in poll () from /lib/libc.so.6
#2  0x07e2ea1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x07e2143c in ?? () from /lib/libglib-2.0.so.0
#4  0x07e21848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x061eb59f in QEventDispatcherGlib::processEvents (this=0x8a58c50, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x061bb609 in QEventLoop::processEvents (this=0xb1cbd270, flags=) at kernel/qeventloop.cpp:149
#7  0x061bba8a in QEventLoop::exec (this=0xb1cbd270, flags=...) at kernel/qeventloop.cpp:201
#8  0x060b7b7e in QThread::exec (this=0x8a56940) at thread/qthread.cpp:490
#9  0x0619a35b in QInotifyFileSystemWatcherEngine::run (this=0x8a56940) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x060badf9 in QThreadPrivate::start (arg=0x8a56940) at thread/qthread_unix.cpp:266
#11 0x05079cc9 in start_thread () from /lib/libpthread.so.0
#12 0x009b869e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7859730 (LWP 1629)):
[KCrash Handler]
#7  0x00ac8d80 in KontactInterface::Plugin::part (this=0x862a220) at ../../kontactinterface/plugin.cpp:190
#8  0x037f7a7d in KMailUniqueAppHandler::newInstance (this=0x862de80) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#9  0x00aca0e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x862de80, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#10 0x00aca174 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x862de80, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff2e9bc) at ./uniqueapphandler.moc:79
#11 0x008469dc in QDBusConnectionPrivate::deliverCall (this=0x82f5868, object=0x862de80, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:919
#12 0x00847cbf in QDBusConnectionPrivate::activateCall (this=0x82f5868, object=0x862de80, flags=272, msg=...) at qdbusintegrator.cpp:822
#13 0x0084849c in QDBusConnectionPrivate::activateObject (this=0x82f5868, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1399
#14 0x00848a2a in QDBusActivateObjectEvent::placeMetaCall (this=0x8a11fe0) at qdbusintegrator.cpp:1493
#15 0x061cf6a2 in QObject::event (this=0x862de80, e=0x0) at kernel/qobject.cpp:1219
#16 0x01037fdc in QApplicationPrivate::notify_helper (this=0x8306320, receiver=0x862de80, e=0x8a11fe0) at kernel/qapplication.cpp:4396
#17 0x0103e04e in QApplication::notify (this=0xbff2f3d4, receiver=0x862de80, e=0x8a11fe0) at kernel/qapplication.cpp:3798
#18 0x0060d68a in KApplication::notify (this=0xbff2f3d4, receiver=0x862de80, event=0x8a11fe0) at ../../kdeui/kernel/kapplication.cpp:310
#19 0x061bcb3b in QCoreApplication::notifyInternal (this=0xbff2f3d4, receiver=0x862de80, event=0x8a11fe0) at kernel/qcoreapplication.cpp:732
#20 0x061bfd8b in sendEvent (receiver=0x0, event_type=0, data=0x82dceb8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82dceb8) at kernel/qcoreapplication.cpp:1373
#22 0x061bff4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#23 0x061eba74 in sendPostedEvents (s=0x82feaa0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=0x82feaa0) at kernel/qeventdispatcher_glib.cpp:277
#25 0x07e1d855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x07e21668 in ?? () from /lib/libglib-2.0.so.0
#27 0x07e21848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x061eb565 in QEventDispatcherGlib::processEvents (this=0x82dcb78, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#29 0x010f9be5 in QGuiEventDispatcherGlib::processEvents (this=0x82dcb78, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x061bb609 in QEventLoop::processEvents (this=0xbff2f334, flags=) at kernel/qeventloop.cpp:149
#31 0x061bba8a in QEventLoop::exec (this=0xbff2f334, flags=...) at kernel/qeventloop.cpp:201
#32 0x061c000f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#33 0x01036e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#34 0x0804b132 in main (argc=1, argv=0xbff2f5f4) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 260348, bug 255958, bug 255029, bug 253472, bug 249231.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-03-21 11:59:55 UTC

*** This bug has been marked as a duplicate of bug 194268 ***