Bug 219979 - Kontact (Kmail) crash when network connectivity becomes suspect
Summary: Kontact (Kmail) crash when network connectivity becomes suspect
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-24 18:53 UTC by James T Smith
Modified: 2009-12-24 20:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James T Smith 2009-12-24 18:53:40 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Kontact (Kmail) crashes (segmentation fault) when the wireless network connection drops and Kontact doesn't know the connection is being re-negotiated.  This is also a problem with Plasma.  I'll report that bug the next time Plasma crashes.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x00007f8aeed1bcca in Kontact::Plugin::part (this=0x1f22500) at ../../kontactinterfaces/plugin.cpp:186
#6  0x00007f8ad97cfe21 in KOrganizerUniqueAppHandler::newInstance (this=0x1f3ee00) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#7  0x00007f8aeed1e0f9 in Kontact::UniqueAppHandler::newInstance (this=0x1f3ee00, asn_id=<value optimized out>, args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#8  0x00007f8aeed1e164 in Kontact::UniqueAppHandler::qt_metacall (this=0x1f3ee00, _c=QMetaObject::InvokeMetaMethod, _id=32646400, _a=0x7fff931b1640) at ./uniqueapphandler.moc:73
#9  0x00007f8aeb1a6ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#10 0x00007f8aeb1a7c69 in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x1f3ee00, flags=272, msg=...) at qdbusintegrator.cpp:796
#11 0x00007f8aeb1a82d5 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=..., msg=<value optimized out>, pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1370
#12 0x00007f8aeb1a87c8 in QDBusActivateObjectEvent::placeMetaCall (this=0x2644430) at qdbusintegrator.cpp:1464
#13 0x00007f8aed0860f9 in QObject::event (this=0x1f3ee00, e=0x2644430) at kernel/qobject.cpp:1111
#14 0x00007f8aed996efc in QApplicationPrivate::notify_helper (this=0x1a902e0, receiver=0x1f3ee00, e=0x2644430) at kernel/qapplication.cpp:4056
#15 0x00007f8aed99e1ce in QApplication::notify (this=0x7fff931b2250, receiver=0x1f3ee00, e=0x2644430) at kernel/qapplication.cpp:4021
#16 0x00007f8aee5cdab6 in KApplication::notify (this=0x7fff931b2250, receiver=0x1f3ee00, event=0x2644430) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f8aed076c2c in QCoreApplication::notifyInternal (this=0x7fff931b2250, receiver=0x1f3ee00, event=0x2644430) at kernel/qcoreapplication.cpp:610
#18 0x00007f8aed07780a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1a5f080) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1a5f080) at kernel/qcoreapplication.cpp:1247
#20 0x00007f8aed09f533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#22 0x00007f8ae68f0bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f8ae68f4598 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f8ae68f46c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f8aed09f1a6 in QEventDispatcherGlib::processEvents (this=0x1a5ecb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007f8aeda2b4be in QGuiEventDispatcherGlib::processEvents (this=0x1f22500, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007f8aed075532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f8aed075904 in QEventLoop::exec (this=0x7fff931b2190, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f8aed077ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x0000000000403f47 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 217299

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-24 20:14:33 UTC
This is being tracked at bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***