Bug 202260 - Crash after clicking on the KOrganizer tray icon
Summary: Crash after clicking on the KOrganizer tray icon
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-02 03:03 UTC by patrick_steinmueller
Modified: 2009-08-02 05:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description patrick_steinmueller 2009-08-02 03:03:11 UTC
Application that crashed: kontact
Version of the application: 4.3.0 rc3
KDE Version: 4.2.98 (KDE 4.2.98 (KDE 4.3 RC3))
Qt Version: 4.5.0
Operating System: Linux 2.6.28-14-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
Well it says it's a segmentation fault. I really did nothing special, i guess...


 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00740063 in ?? ()
#7  0xb191f26a in ?? () from /usr/lib/kde4/kontact_todoplugin.so
#8  0xb7910f39 in Kontact::UniqueAppHandler::newInstance () from /usr/lib/libkontactinterfaces.so.4
#9  0xb7910fc6 in Kontact::UniqueAppHandler::qt_metacall () from /usr/lib/libkontactinterfaces.so.4
#10 0xb5dc0d7a in QDBusConnectionPrivate::deliverCall (this=0x9f9efa8, object=0xa3432a0, msg=@0xa4595b8, metaTypes=@0xb143f34, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5dc2099 in QDBusConnectionPrivate::activateCall (this=0x9f9efa8, object=0xa3432a0, flags=272, msg=@0xa4595b8) at qdbusintegrator.cpp:803
#12 0xb5dc2501 in QDBusConnectionPrivate::activateObject (this=0x9f9efa8, node=@0xa4595a4, msg=@0xa4595b8, pathStartPos=26) at qdbusintegrator.cpp:1375
#13 0xb5dc29fa in QDBusActivateObjectEvent::placeMetaCall (this=0xa459578) at qdbusintegrator.cpp:1469
#14 0xb5cb73a0 in QObject::event (this=0xa3432a0, e=0xa459578) at kernel/qobject.cpp:1118
#15 0xb6188e9c in QApplicationPrivate::notify_helper (this=0x9fb1700, receiver=0xa3432a0, e=0xa459578) at kernel/qapplication.cpp:4084
#16 0xb619119e in QApplication::notify (this=0xbf99d888, receiver=0xa3432a0, e=0xa459578) at kernel/qapplication.cpp:3631
#17 0xb6daf5cd in KApplication::notify (this=0xbf99d888, receiver=0xa3432a0, event=0xa459578) at /build/buildd/kde4libs-4.2.98a/kdeui/kernel/kapplication.cpp:302
#18 0xb5ca6a3b in QCoreApplication::notifyInternal (this=0xbf99d888, receiver=0xa3432a0, event=0xa459578) at kernel/qcoreapplication.cpp:602
#19 0xb5ca7695 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9f87440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5ca788d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1132
#21 0xb5cd27ef in postEventSourceDispatch (s=0x9fa7b20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4d6bb88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4d6f0eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4d6f268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5cd2438 in QEventDispatcherGlib::processEvents (this=0x9f87028, flags={i = -1080436904}) at kernel/qeventdispatcher_glib.cpp:323
#26 0xb622a365 in QGuiEventDispatcherGlib::processEvents (this=0x9f87028, flags={i = -1080436856}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5ca506a in QEventLoop::processEvents (this=0xbf99d800, flags={i = -1080436792}) at kernel/qeventloop.cpp:149
#28 0xb5ca54aa in QEventLoop::exec (this=0xbf99d800, flags={i = -1080436728}) at kernel/qeventloop.cpp:200
#29 0xb5ca7959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#30 0xb6188d17 in QApplication::exec () at kernel/qapplication.cpp:3553
#31 0x0804bfef in _start ()

This bug may be a duplicate of or related to bug 200968

Reported using DrKonqi
Comment 1 Dario Andres 2009-08-02 05:26:46 UTC
Merging with bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***