Bug 193213 - kontact crashes trying to restart
Summary: kontact crashes trying to restart
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-19 11:07 UTC by Alin M Elena
Modified: 2009-08-30 20:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alin M Elena 2009-05-19 11:07:13 UTC
Application that crashed: kontact
Version of the application: 4.3.0 pre
KDE Version: 4.2.86 (KDE 4.2.86 (KDE 4.3 >= 20090514)) "release 125"
Qt Version: 4.5.1
Operating System: Linux 2.6.27.21-0.1-default x86_64

What I was doing when the application crashed:
Kontact starts automatically. I close kontact and korganizer. I start contact again. Korganizer starts kontact crashes.

Alin

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x00007fe13a53af78 in Kontact::UniqueAppHandler::newInstance() () from /usr/lib64/libkontactinterfaces.so.4
#6  0x00007fe13a53b022 in Kontact::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib64/libkontactinterfaces.so.4
#7  0x00007fe13a53b09a in Kontact::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkontactinterfaces.so.4
#8  0x00007fe137173324 in QDBusConnectionPrivate::deliverCall (this=0x62b390, object=0x9909c0, msg=@0x214b880, metaTypes=@0x7fff437da2e8, slotIdx=4) at qdbusintegrator.cpp:891
#9  0x00007fe13717428f in QDBusConnectionPrivate::activateCall (this=0x62b390, object=0x9909c0, flags=272, msg=@0x214b880) at qdbusintegrator.cpp:796
#10 0x00007fe1371747e3 in QDBusConnectionPrivate::activateObject (this=0x62b390, node=@0x214b858, msg=@0x214b880, pathStartPos=26) at qdbusintegrator.cpp:1375
#11 0x00007fe137174cd8 in QDBusActivateObjectEvent::placeMetaCall (this=0x214b810) at qdbusintegrator.cpp:1469
#12 0x00007fe136e692b8 in QObject::event (this=0x9909c0, e=0x214b810) at kernel/qobject.cpp:1118
#13 0x00007fe135b4c78d in QApplicationPrivate::notify_helper (this=0x64ddf0, receiver=0x9909c0, e=0x214b810) at kernel/qapplication.cpp:4057
#14 0x00007fe135b54a2a in QApplication::notify (this=0x7fff437dae90, receiver=0x9909c0, e=0x214b810) at kernel/qapplication.cpp:4022
#15 0x00007fe137c8d37b in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#16 0x00007fe136e5915c in QCoreApplication::notifyInternal (this=0x7fff437dae90, receiver=0x9909c0, event=0x214b810) at kernel/qcoreapplication.cpp:610
#17 0x00007fe136e59dda in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60e770) at kernel/qcoreapplication.h:213
#18 0x00007fe136e82c13 in postEventSourceDispatch (s=<value optimized out>) at kernel/qcoreapplication.h:218
#19 0x00007fe1307050fb in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#20 0x00007fe1307088cd in ?? () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fe130708a8b in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fe136e8289f in QEventDispatcherGlib::processEvents (this=0x60df60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:324
#23 0x00007fe135be3b0f in QGuiEventDispatcherGlib::processEvents (this=0x63eb70, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#24 0x00007fe136e579f2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1132309936}) at kernel/qeventloop.cpp:149
#25 0x00007fe136e57dbd in QEventLoop::exec (this=0x7fff437dadf0, flags={i = 1132310016}) at kernel/qeventloop.cpp:200
#26 0x00007fe136e5a0a4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#27 0x0000000000404995 in _start ()
Comment 1 Christophe Giboudeaux 2009-08-30 20:39:54 UTC

*** This bug has been marked as a duplicate of bug 194268 ***