Bug 227577 - Kontact fails to start
Summary: Kontact fails to start
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-18 21:38 UTC by Dan
Modified: 2010-02-19 23:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan 2010-02-18 21:38:30 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-19-generic x86_64
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f9a2b24a750 (LWP 11880))]

Thread 2 (Thread 0x7f9a0a06e910 (LWP 11887)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f9a28eaf4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x24ab718, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x24ab718, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f9a240e478c in QHostInfoAgent::run (this=0x24ab700) at kernel/qhostinfo.cpp:260
#4  0x00007f9a28eae445 in QThreadPrivate::start (arg=0x24ab700) at thread/qthread_unix.cpp:188
#5  0x00007f9a225bda04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f9a288b080d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9a2b24a750 (LWP 11880)):
[KCrash Handler]
#5  0x00007f9a2ac39cca in Kontact::Plugin::part (this=0x18ecdc0) at ../../kontactinterfaces/plugin.cpp:186
#6  0x00007f9a148b2bb6 in KMailUniqueAppHandler::newInstance (this=<value optimized out>) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:208
#7  0x00007f9a2ac3c0f9 in Kontact::UniqueAppHandler::newInstance (this=0x18f3190, asn_id=<value optimized out>, args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#8  0x00007f9a2ac3c164 in Kontact::UniqueAppHandler::qt_metacall (this=0x18f3190, _c=QMetaObject::InvokeMetaMethod, _id=26136000, _a=0x7fffe7b11150) at ./uniqueapphandler.moc:73
#9  0x00007f9a270c4ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#10 0x00007f9a270c5c69 in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x18f3190, flags=272, msg=...) at qdbusintegrator.cpp:796
#11 0x00007f9a270c62d5 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=..., msg=<value optimized out>, pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1370
#12 0x00007f9a270c67c8 in QDBusActivateObjectEvent::placeMetaCall (this=0x441ce10) at qdbusintegrator.cpp:1464
#13 0x00007f9a28fa40f9 in QObject::event (this=0x18f3190, e=0x441ce10) at kernel/qobject.cpp:1111
#14 0x00007f9a298b4efc in QApplicationPrivate::notify_helper (this=0x1445f80, receiver=0x18f3190, e=0x441ce10) at kernel/qapplication.cpp:4056
#15 0x00007f9a298bc1ce in QApplication::notify (this=0x7fffe7b11d60, receiver=0x18f3190, e=0x441ce10) at kernel/qapplication.cpp:4021
#16 0x00007f9a2a4ebab6 in KApplication::notify (this=0x7fffe7b11d60, receiver=0x18f3190, event=0x441ce10) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f9a28f94c2c in QCoreApplication::notifyInternal (this=0x7fffe7b11d60, receiver=0x18f3190, event=0x441ce10) at kernel/qcoreapplication.cpp:610
#18 0x00007f9a28f9580a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x140d080) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x140d080) at kernel/qcoreapplication.cpp:1247
#20 0x00007f9a28fbd533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#22 0x00007f9a2280ebce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f9a22812598 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f9a228126c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f9a28fbd1a6 in QEventDispatcherGlib::processEvents (this=0x140ccb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007f9a299494be in QGuiEventDispatcherGlib::processEvents (this=0x18ecdc0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007f9a28f93532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f9a28f93904 in QEventLoop::exec (this=0x7fffe7b11ca0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f9a28f95ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x0000000000403f47 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:218
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 225244

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-19 23:36:22 UTC
Merging with bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***