Bug 241142 - Crash after closing contact and launching korganizer
Summary: Crash after closing contact and launching korganizer
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-08 23:00 UTC by maba.gp
Modified: 2010-06-09 00:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maba.gp 2010-06-08 23:00:14 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Title pretty much says it all.
Is probably a duplicate anyway, filing it because the backtrace might provide additional hints about the cause.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7b0d719780 (LWP 2025))]

Thread 2 (Thread 0x7f7ae88f3710 (LWP 2173)):
#0  0x00007fffc50f8904 in clock_gettime ()
#1  0x00007f7b035c109f in *__GI_clock_gettime (clock_id=1, tp=0x7f7ae88f2ae0) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f7b0bbd499f in qt_gettime () at kernel/qcore_unix.cpp:111
#3  0x00007f7b0bbd96ad in QTimerInfoList::updateCurrentTime (this=0x1) at kernel/qeventdispatcher_unix.cpp:340
#4  0x00007f7b0bbd96d5 in QTimerInfoList::timerWait (this=0x1, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#5  0x00007f7b0bbd775d in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f7ae88f2bfc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00007f7b0bbd7805 in timerSourcePrepare (source=0x1, timeout=0x7f7ae88f2ae0) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00007f7b03320eb1 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x00007f7b03321318 in ?? () from /lib/libglib-2.0.so.0
#9  0x00007f7b033218fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x00007f7b0bbd7566 in QEventDispatcherGlib::processEvents (this=0x167d510, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#11 0x00007f7b0bbac992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#12 0x00007f7b0bbacd6c in QEventLoop::exec (this=0x7f7ae88f2d90, flags=) at kernel/qeventloop.cpp:201
#13 0x00007f7b0bab6d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#14 0x00007f7b0bb8d178 in QInotifyFileSystemWatcherEngine::run (this=0x11ccfa0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00007f7b0bab9775 in QThreadPrivate::start (arg=0x11ccfa0) at thread/qthread_unix.cpp:248
#16 0x00007f7b058989ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#17 0x00007f7b0a7f96cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#18 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7b0d719780 (LWP 2025)):
[KCrash Handler]
#5  0x0000000000bb9650 in ?? ()
#6  0x00007f7b0cd7fffb in KontactInterface::UniqueAppHandler::newInstance() () from /usr/lib/libkontactinterface.so.4
#7  0x00007f7b0cd800a9 in KontactInterface::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterface.so.4
#8  0x00007f7b0cd80114 in KontactInterface::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterface.so.4
#9  0x00007f7b08ffa486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#10 0x00007f7b08ffb6ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0xb93750, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007f7b08ffbf0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007f7b08ffc468 in QDBusActivateObjectEvent::placeMetaCall (this=0x1137650) at qdbusintegrator.cpp:1477
#13 0x00007f7b0bbbdd49 in QObject::event (this=0xb93750, e=0x1137650) at kernel/qobject.cpp:1248
#14 0x00007f7b0af6722c in QApplicationPrivate::notify_helper (this=0x6b0f30, receiver=0xb93750, e=0x1137650) at kernel/qapplication.cpp:4300
#15 0x00007f7b0af6d6fb in QApplication::notify (this=0x7fffc502e790, receiver=0xb93750, e=0x1137650) at kernel/qapplication.cpp:4183
#16 0x00007f7b0c596526 in KApplication::notify (this=0x7fffc502e790, receiver=0xb93750, event=0x1137650) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f7b0bbae06c in QCoreApplication::notifyInternal (this=0x7fffc502e790, receiver=0xb93750, event=0x1137650) at kernel/qcoreapplication.cpp:704
#18 0x00007f7b0bbb07e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x684620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x684620) at kernel/qcoreapplication.cpp:1345
#20 0x00007f7b0bbd79d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007f7b0331d8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f7b03321748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f7b033218fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f7b0bbd7513 in QEventDispatcherGlib::processEvents (this=0x683d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007f7b0b01746e in QGuiEventDispatcherGlib::processEvents (this=0x818cc0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f7b0bbac992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f7b0bbacd6c in QEventLoop::exec (this=0x7fffc502e6d0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f7b0bbb0aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x0000000000403e8e in _start ()

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 240876, bug 239984, bug 237446, bug 237352, bug 237094.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-09 00:58:16 UTC

*** This bug has been marked as a duplicate of bug 194268 ***