Bug 245005 - not sure what happened - just started as a test... then...
Summary: not sure what happened - just started as a test... then...
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 243727 245041 245977 246445 246526 246954 247000 248582 248678 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-18 03:13 UTC by WilleTan
Modified: 2010-09-19 13:40 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description WilleTan 2010-07-18 03:13:18 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-23-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
well, I had just installed the Kontact a few days earlier and did not have the chance to test out the application.

Today, 2010-07-17, I opened the Korganizer/Journal+ to check out the feature.

At this point, I was not aware that the Kontact was a completely integrated package with Kaddress, Korganizer, etc.  I may have opened the Kontact while the Korganizer/Journal+ was still open.

From the Kontact environment, I then tried to open the Kaddressbook.  The Kaddressbook did not open up and I tried again... that is when the crash error reporting pop up window opened.

I just opened Kontact again, after registering with the KDE Bug Tracking System and the Kaddressbook seems to work now.

I have one general question... are the Calendar and To-do List items logged into the Journal.  I guess my question is 'are the appointments and To-do items logged into the Journal as a record of my activites?'  If it does, this would be great for my purposes.  It would be nice - as I would consider that NATURALLY logging my (appointment and to-do list) activities into the Journal(s) would be meaningful and appropriate way to monitor my activities.



 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x0011db50 in KontactInterface::Plugin::part (this=0x94095e8) at ../../kontactinterface/plugin.cpp:190
#7  0x081ead7a in KOrganizerUniqueAppHandler::newInstance (this=0x940ac48) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0x0011f7e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x940ac48, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x0011f874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x940ac48, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff19bfc) at ./uniqueapphandler.moc:79
#10 0x00b9cb34 in QDBusConnectionPrivate::deliverCall (this=0x908a2c8, object=0x940ac48, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x00b9dddf in QDBusConnectionPrivate::activateCall (this=0x908a2c8, object=0x940ac48, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00b9e5ac in QDBusConnectionPrivate::activateObject (this=0x908a2c8, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1383
#13 0x00b9eb1a in QDBusActivateObjectEvent::placeMetaCall (this=0x9247140) at qdbusintegrator.cpp:1477
#14 0x011303fe in QObject::event (this=0x940ac48, e=0x9247140) at kernel/qobject.cpp:1248
#15 0x055fd4dc in QApplicationPrivate::notify_helper (this=0x9092b98, receiver=0x940ac48, e=0x9247140) at kernel/qapplication.cpp:4300
#16 0x0560405e in QApplication::notify (this=0xbff1a614, receiver=0x940ac48, e=0x9247140) at kernel/qapplication.cpp:3704
#17 0x00777f2a in KApplication::notify (this=0xbff1a614, receiver=0x940ac48, event=0x9247140) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x0111fa3b in QCoreApplication::notifyInternal (this=0xbff1a614, receiver=0x940ac48, event=0x9247140) at kernel/qcoreapplication.cpp:704
#19 0x01122473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9072a60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9072a60) at kernel/qcoreapplication.cpp:1345
#21 0x011225dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x0114badf in QCoreApplication::sendPostedEvents (s=0x9095d10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x9095d10) at kernel/qeventdispatcher_glib.cpp:276
#24 0x0210d5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x021112d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x021114b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x0114b5d5 in QEventDispatcherGlib::processEvents (this=0x9072588, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x056bd135 in QGuiEventDispatcherGlib::processEvents (this=0x9072588, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x0111e059 in QEventLoop::processEvents (this=0xbff1a574, flags=) at kernel/qeventloop.cpp:149
#30 0x0111e4aa in QEventLoop::exec (this=0xbff1a574, flags=...) at kernel/qeventloop.cpp:201
#31 0x0112269f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x055fd577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in main (argc=1, argv=0xbff1a834) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 242278, bug 240876, bug 239984, bug 235846, bug 235668.

Reported using DrKonqi
Comment 1 WilleTan 2010-07-18 03:15:58 UTC
if this is just your way of getting people to register their application?... LOL... funny :)

I don't think that; however, it would be funny...
Comment 2 Nicolas L. 2010-08-15 13:52:51 UTC
*** Bug 246954 has been marked as a duplicate of this bug. ***
Comment 3 Nicolas L. 2010-08-15 13:53:00 UTC
*** Bug 245977 has been marked as a duplicate of this bug. ***
Comment 4 Nicolas L. 2010-08-15 13:53:49 UTC
*** Bug 246445 has been marked as a duplicate of this bug. ***
Comment 5 Nicolas L. 2010-08-15 13:54:31 UTC
*** Bug 247000 has been marked as a duplicate of this bug. ***
Comment 6 Nicolas L. 2010-08-15 15:18:45 UTC
*** Bug 243727 has been marked as a duplicate of this bug. ***
Comment 7 Nicolas L. 2010-08-15 15:19:53 UTC
*** Bug 245041 has been marked as a duplicate of this bug. ***
Comment 8 Nicolas L. 2010-08-15 15:30:44 UTC
*** Bug 246526 has been marked as a duplicate of this bug. ***
Comment 9 Nicolas L. 2010-08-22 16:30:07 UTC
*** Bug 248582 has been marked as a duplicate of this bug. ***
Comment 10 Nicolas L. 2010-08-22 16:30:33 UTC
*** Bug 248678 has been marked as a duplicate of this bug. ***
Comment 11 Christophe Giboudeaux 2010-09-19 13:40:30 UTC

*** This bug has been marked as a duplicate of bug 194268 ***