Bug 208626 - crash of kontact while starting
Summary: crash of kontact while starting
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-26 19:30 UTC by p92
Modified: 2009-09-26 19:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p92 2009-09-26 19:30:20 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-11-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
crash of kontact while starting 

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x869a940) at /build/buildd/kdepim-4.3.1/kontactinterfaces/plugin.cpp:186
#7  0xb167d22e in KMailUniqueAppHandler::newInstance (this=0x869d148) at /build/buildd/kdepim-4.3.1/kontact/plugins/kmail/kmail_plugin.cpp:208
#8  0xb790bf39 in Kontact::UniqueAppHandler::newInstance (this=0x869d148, asn_id=@0x9ebb9c0, args=@0x9db9bb8) at /build/buildd/kdepim-4.3.1/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb790bfc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x869d148, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb9dbc8)
    at /build/buildd/kdepim-4.3.1/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5e12e5a in QDBusConnectionPrivate::deliverCall (this=0x82f9130, object=0x869d148, msg=@0x9445cc0, metaTypes=@0xbfb9dc78, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5e14072 in QDBusConnectionPrivate::activateCall (this=0x82f9130, object=0x869d148, flags=272, msg=@0x9445cc0) at qdbusintegrator.cpp:796
#12 0xb5e145e1 in QDBusConnectionPrivate::activateObject (this=0x82f9130, node=@0x9445cac, msg=@0x9445cc0, pathStartPos=21) at qdbusintegrator.cpp:1370
#13 0xb5e14ada in QDBusActivateObjectEvent::placeMetaCall (this=0x9445c80) at qdbusintegrator.cpp:1464
#14 0xb5d0b3b0 in QObject::event (this=0x869d148, e=0x9445c80) at kernel/qobject.cpp:1111
#15 0xb61bdd3c in QApplicationPrivate::notify_helper (this=0x830af28, receiver=0x869d148, e=0x9445c80) at kernel/qapplication.cpp:4056
#16 0xb61c603e in QApplication::notify (this=0xbfb9e448, receiver=0x869d148, e=0x9445c80) at kernel/qapplication.cpp:3603
#17 0xb6db785d in KApplication::notify (this=0xbfb9e448, receiver=0x869d148, event=0x9445c80) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#18 0xb5cfabcb in QCoreApplication::notifyInternal (this=0xbfb9e448, receiver=0x869d148, event=0x9445c80) at kernel/qcoreapplication.cpp:610
#19 0xb5cfb825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82e1440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5cfba1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5d266af in postEventSourceDispatch (s=0x830cf18) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4dcbb88 in IA__g_main_context_dispatch (context=0x830ce98) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#23 0xb4dcf0eb in g_main_context_iterate (context=0x830ce98, block=1, dispatch=1, self=0x831a160) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#24 0xb4dcf268 in IA__g_main_context_iteration (context=0x830ce98, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#25 0xb5d262f8 in QEventDispatcherGlib::processEvents (this=0x82e1028, flags={i = -1078336744}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb625fa75 in QGuiEventDispatcherGlib::processEvents (this=0x82e1028, flags={i = -1078336696}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5cf91fa in QEventLoop::processEvents (this=0xbfb9e3c0, flags={i = -1078336632}) at kernel/qeventloop.cpp:149
#28 0xb5cf9642 in QEventLoop::exec (this=0xbfb9e3c0, flags={i = -1078336568}) at kernel/qeventloop.cpp:201
#29 0xb5cfbae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb61bdbb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in main (argc=3, argv=0xbfb9e744) at /build/buildd/kdepim-4.3.1/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 208177

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-09-26 19:32:50 UTC

*** This bug has been marked as a duplicate of bug 194268 ***