Bug 242751 - Korganizer crashes on Startup
Summary: Korganizer crashes on Startup
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-25 08:17 UTC by ugubabba
Modified: 2010-06-25 11:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ugubabba 2010-06-25 08:17:45 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Korganizer crashes on Startup , in the background i had running mythtv and firefox. Could duplicate the crash.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7faddb70e780 (LWP 7572))]

Thread 2 (Thread 0x7fadb3fff710 (LWP 7679)):
#0  0x00007fadd87e0f53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fadd13154a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fadd13158fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fadd9bcb566 in QEventDispatcherGlib::processEvents (this=0x2931290, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fadd9ba0992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fadd9ba0d6c in QEventLoop::exec (this=0x7fadb3ffed90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fadd9aaad59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fadd9b81178 in QInotifyFileSystemWatcherEngine::run (this=0x2a3fcd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fadd9aad775 in QThreadPrivate::start (arg=0x2a3fcd0) at thread/qthread_unix.cpp:248
#9  0x00007fadd388c9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fadd87ed6cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7faddb70e780 (LWP 7572)):
[KCrash Handler]
#5  0x00007faddad7284a in KontactInterface::Plugin::part (this=0x2475c90) at ../../kontactinterface/plugin.cpp:190
#6  0x00007fadc26cea21 in ?? () from /usr/lib/kde4/kontact_korganizerplugin.so
#7  0x00007faddad740a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x248cf50, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#8  0x00007faddad74114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x248cf50, _c=QMetaObject::InvokeMetaMethod, _id=38231184, _a=0x7fffa0ec0470) at ./uniqueapphandler.moc:79
#9  0x00007fadd6fee486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#10 0x00007fadd6fef6ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x248cf50, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007fadd6feff0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007fadd6ff0468 in QDBusActivateObjectEvent::placeMetaCall (this=0x29c6120) at qdbusintegrator.cpp:1477
#13 0x00007fadd9bb1d49 in QObject::event (this=0x248cf50, e=0x29c6120) at kernel/qobject.cpp:1248
#14 0x00007fadd8f5b22c in QApplicationPrivate::notify_helper (this=0x1fba380, receiver=0x248cf50, e=0x29c6120) at kernel/qapplication.cpp:4300
#15 0x00007fadd8f616fb in QApplication::notify (this=0x7fffa0ec11f0, receiver=0x248cf50, e=0x29c6120) at kernel/qapplication.cpp:4183
#16 0x00007fadda58a526 in KApplication::notify (this=0x7fffa0ec11f0, receiver=0x248cf50, event=0x29c6120) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007fadd9ba206c in QCoreApplication::notifyInternal (this=0x7fffa0ec11f0, receiver=0x248cf50, event=0x29c6120) at kernel/qcoreapplication.cpp:704
#18 0x00007fadd9ba47e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1f90620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1f90620) at kernel/qcoreapplication.cpp:1345
#20 0x00007fadd9bcb9d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007fadd13118c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007fadd1315748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007fadd13158fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007fadd9bcb513 in QEventDispatcherGlib::processEvents (this=0x1f8fd70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007fadd900b46e in QGuiEventDispatcherGlib::processEvents (this=0x2475c90, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007fadd9ba0992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007fadd9ba0d6c in QEventLoop::exec (this=0x7fffa0ec1130, flags=) at kernel/qeventloop.cpp:201
#29 0x00007fadd9ba4aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x0000000000403e8e in _start ()

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 242278, bug 242078, bug 240876, bug 239984, bug 237446.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-25 11:41:31 UTC

*** This bug has been marked as a duplicate of bug 194268 ***