Bug 194683 - Korganizer crashed when starting from systemtray
Summary: Korganizer crashed when starting from systemtray
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-30 20:15 UTC by m.wege
Modified: 2009-05-30 20:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2009-05-30 20:15:15 UTC
Application that crashed: kontact
Version of the application: 4.3.0 pre
KDE Version: 4.2.85 (KDE 4.2.85 (KDE 4.3 Beta1))
Qt Version: 4.5.1
Operating System: Linux 2.6.30-020630rc6-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
I clicked on the icon, Korganizer attempted to start, then=crash

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x91951f8) at /build/buildd/kdepim-4.2.85/kontactinterfaces/plugin.cpp:186
#7  0xb192326a in KOrganizerUniqueAppHandler::newInstance (this=0x935c3a0) at /build/buildd/kdepim-4.2.85/kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0xb7952f39 in Kontact::UniqueAppHandler::newInstance (this=0x935c3a0, asn_id=@0x100dfeb0, args=@0xe553950) at /build/buildd/kdepim-4.2.85/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb7952fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x935c3a0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc850f8)
    at /build/buildd/kdepim-4.2.85/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5e23e2a in QDBusConnectionPrivate::deliverCall (this=0x908f050, object=0x935c3a0, msg=@0x143100d0, metaTypes=@0x13952674, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5e25149 in QDBusConnectionPrivate::activateCall (this=0x908f050, object=0x935c3a0, flags=272, msg=@0x143100d0) at qdbusintegrator.cpp:803
#12 0xb5e255b1 in QDBusConnectionPrivate::activateObject (this=0x908f050, node=@0x143100bc, msg=@0x143100d0, pathStartPos=26) at qdbusintegrator.cpp:1375
#13 0xb5e25aaa in QDBusActivateObjectEvent::placeMetaCall (this=0x14310090) at qdbusintegrator.cpp:1469
#14 0xb5d1c150 in QObject::event (this=0x935c3a0, e=0x14310090) at kernel/qobject.cpp:1118
#15 0xb61c3bcc in QApplicationPrivate::notify_helper (this=0x90a9aa8, receiver=0x935c3a0, e=0x14310090) at kernel/qapplication.cpp:4057
#16 0xb61cbede in QApplication::notify (this=0xbfc85978, receiver=0x935c3a0, e=0x14310090) at kernel/qapplication.cpp:3604
#17 0xb6de7c9d in KApplication::notify (this=0xbfc85978, receiver=0x935c3a0, event=0x14310090) at /build/buildd/kde4libs-4.2.85/kdeui/kernel/kapplication.cpp:307
#18 0xb5d0b7ab in QCoreApplication::notifyInternal (this=0xbfc85978, receiver=0x935c3a0, event=0x14310090) at kernel/qcoreapplication.cpp:610
#19 0xb5d0c405 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9076c08) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5d0c5fd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5d3758f in postEventSourceDispatch (s=0x90ab2a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4de1b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4de50eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4de5268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5d371d8 in QEventDispatcherGlib::processEvents (this=0x90919a0, flags={i = -1077389240}) at kernel/qeventdispatcher_glib.cpp:324
#26 0xb6265765 in QGuiEventDispatcherGlib::processEvents (this=0x90919a0, flags={i = -1077389192}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5d09dda in QEventLoop::processEvents (this=0xbfc858f0, flags={i = -1077389128}) at kernel/qeventloop.cpp:149
#28 0xb5d0a21a in QEventLoop::exec (this=0xbfc858f0, flags={i = -1077389064}) at kernel/qeventloop.cpp:200
#29 0xb5d0c6c9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb61c3a47 in QApplication::exec () at kernel/qapplication.cpp:3526
#31 0x0804bfef in main (argc=3, argv=0xbfc85c74) at /build/buildd/kdepim-4.2.85/kontact/src/main.cpp:218
Comment 1 Dario Andres 2009-05-30 20:24:13 UTC
Marking as duplicate of bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***